Jump to content

[SOLVED] iCloud and Facetime not working


  • Please log in to reply
28 replies to this topic

#21
gabrielepizza2010

gabrielepizza2010

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Bari
Hi everybody,
I tried many configurations i found here with no results :(
I have Chameleon 1672 bootloader and tried to edit it with Champlist with different serial number SMBios...
These are my files, hope somebody will help me to fix this problem...
Thank you

Attached Files



#22
Ashand

Ashand

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts

Beautiful, see the built-in (00) to the right. It is a really easy fix from the DSDT, no need the chameleon flag anymore. Also, the "essential" and "expected" behavior OF COURSE in Network Interfaces (en0 Now is True):


I need to change mine to but how? the explorer not let me do any changes..?

#23
dblackeby

dblackeby

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I'm also having the same problem, I've followed the other guides to make sure that Ethernet is en1, which has now meant I can access the AppStore successfully, however I'm unable to logon to iCloud of FaceTime.

I'm not using a DSDT as Ive used ##### installer method from ###### 4.4, so not sure where any edits would be. I've downloaded the IORegistryExplorer and tried to follow the fix for the previous people within this thread, and can see the value against ethernet@0 built-in is set to 01 as opposed to 00 in the images here. But don't know how I would change it.

Any suggestions gratefully received, everything else is working fine and stable.

#24
freddy3k

freddy3k

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male

Ethernet in NetworkInterfaces must to be "true".

Please upload your files o.c.B.p & smbios.plist. Also your .ioreg (using IORegistryExplorer.app) by "save a copy as" option.

Can you surf in internet by the Ethernet connection? I mean, is working fine?

I will need to take a look to those three (3) files.


i have already read almost all threads regarding this iCloud problem but nothing seems to work for me or i fail big time if your kindly enough to help me please... i really need your help.. tried almost all and i can't seem to find the problem..

PS
i'll attach my files and kindly please check it :(

attached files : ioreg, smbios.plist and my dsdt patch i would really appreciate your help.. :(

thanks
br
freddy

Attached Files



#25
dblackeby

dblackeby

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
freddy3k

I managed to find a solution to my issue on another site, details as follows:-



I knew it!!! Posted Image You need a valid UUID to make your iCloud work...

For everyone that tried everything and still failed... Check on your bdmesg if you have the same error I do...

If you do then

a) Install latest chameleon boot loader
B) Go to http://www.famkruith...et/uuid/uuidgen, and copy the uuid generated, then change the latest part to match the MAC address of your ethernet device
c) Add the following to your org.chameleon.Boot.plist
<key>SystemId</key>
<string>The key you modified from uuidgen</string>


Anyhow that solved my problem, and I can now use iCloud and FaceTime successfully. Hope this helps you and anyone else that is still having issues.

Regards

Dave

#26
Powaking

Powaking

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male

freddy3k

I managed to find a solution to my issue on another site, details as follows:-



I knew it!!! Posted Image You need a valid UUID to make your iCloud work...

For everyone that tried everything and still failed... Check on your bdmesg if you have the same error I do...

If you do then

a) Install latest chameleon boot loader
B) Go to http://www.famkruith...et/uuid/uuidgen, and copy the uuid generated, then change the latest part to match the MAC address of your ethernet device
c) Add the following to your org.chameleon.Boot.plist
<key>SystemId</key>
<string>The key you modified from uuidgen</string>


Anyhow that solved my problem, and I can now use iCloud and FaceTime successfully. Hope this helps you and anyone else that is still having issues.

Regards

Dave


This didn't work for me. In my case my build in ethernet is defective. When I try to install the kext driver it just freezes my computer. I have to use a RealTek USB wifi dongle.

Attached File  DSDT-IOReg.zip   416.45KB   8 downloads

#27
stellarola

stellarola

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 682 posts
  • Gender:Male
  • Location:Lextown, KY
**FOR THOSE WHO'VE TRIED EVERYTHING TO LOGIN TO ICLOUD/MESSAGES AND CAN'T. USE THIS KEXT**

http://cl.ly/3T2m2U2n332O

^
PlatformUUID.kext

--------------------------------------

I tried every solution and combination to fix the issue. I could log into the Mac App Store and iTunes Store, however I couldn't login to iCloud or Messages account. I kept getting a message saying "This is an Apple ID but not a valid iCloud account."

For some reason my Hardware UUID was causing a conflict and using the built-in UUID changer in Chameleon's boot.plist wasn't able to change my UUID either.

This kext will force the UUID to change. Be sure to install it to S/L/E and not E/E.

Godspeed.

PS - Thanks to Superhai for making this kext!

#28
adidasprince

adidasprince

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

freddy3k

I managed to find a solution to my issue on another site, details as follows:-



I knew it!!! Posted Image You need a valid UUID to make your iCloud work...

For everyone that tried everything and still failed... Check on your bdmesg if you have the same error I do...

If you do then

a) Install latest chameleon boot loader
B) Go to http://www.famkruith...et/uuid/uuidgen, and copy the uuid generated, then change the latest part to match the MAC address of your ethernet device
c) Add the following to your org.chameleon.Boot.plist
<key>SystemId</key>
<string>The key you modified from uuidgen</string>


Anyhow that solved my problem, and I can now use iCloud and FaceTime successfully. Hope this helps you and anyone else that is still having issues.

Regards

Dave


Worked for me!!! Before that my "Hardware UUID" in "System Profile" was 00000000-0000-1000-8000-MY_MAC_ADDR.

#29
GiovaTrabuzz

GiovaTrabuzz

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts

Hi everybody,
I tried many configurations i found here with no results :(
I have Chameleon 1672 bootloader and tried to edit it with Champlist with different serial number SMBios...
These are my files, hope somebody will help me to fix this problem...
Thank you







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy