Jump to content

{Guide} DELL INSPIRON N5110

* * * * * 14 votes

  • Please log in to reply
2105 replies to this topic

#21
LuckyLuck

LuckyLuck

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Ukraine
Hi Mohamed Khairy,thanks for this topic :D
I also have n5110 and running 10.7.2(all works fine,thanks for this forum ) But I have one little problem with screen brightness
After boot it 50-60% but after sleep it 100%
It is possible to fix this little bug

sorry for my english

#22
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male

Hi Mohamed Khairy,thanks for this topic :P
I also have n5110 and running 10.7.2(all works fine,thanks for this forum ) But I have one little problem with screen brightness
After boot it 50-60% but after sleep it 100%
It is possible to fix this little bug

sorry for my english

use n5110 patch i linked on topic made by madlon
it control brightness by bulging ac adaptor it works fine for me :D

#23
myska

myska

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Female

i did as you said , and the sound worked , as for the webcam , it works in windows , in mac , it can't be detected either by FaceTime , photo booth or an online webcam capture website

as for disabling the nvidia card , i can't this device called GFX0 or DGPU , so what i can do ?



Thanks Mohamed for this topic.

I've just found a program to disable/enable either one or both cards: http://codykrieger.com/gfxCardStatus

It helps but it doesn't solve the problem I have with my connectors (kernel log attached). I already tried to edit them on my part and I have also used Mohamed's modified kext but no luck. With this program instead of hanging every 5 secs, it hangs every 11 mins . Better than nothing. :P


Edit: Finally it also hangs but in another way everytime I load something (finder, safari, ...). When it freezes I can't do anything but reboot. :-( I have to downgrade to 10.7.1 as the new kexts related to hd 3000 make my hackintosh unusable. I hope someone will find a solution.

Attached Files



#24
LuckyLuck

LuckyLuck

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Ukraine

use n5110 patch i linked on topic made by madlon
it control brightness by bulging ac adaptor it works fine for me :)


Do you mean this patch from Inspiron 15R N5110.txt patch ?(I have all this patches in my dsdt)
Device (PNLF)
		{
			Name (_HID, EisaId ("APP0002"))
			Name (_CID, "backlight")
			Name (_UID, 0x0A)
			Name (_STA, 0x0B)
		}
	}

It already present in my dsdt and I can change brightness from system preferences
But after sleep screen is more bright than after boot,maybe it's only in my case(N5110Hi2310X3C500BSCDSblack)

#25
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male

Thanks Mohamed for this topic.

I've just found a program to disable/enable either one or both cards: http://codykrieger.com/gfxCardStatus

It helps but it doesn't solve the problem I have with my connectors (kernel log attached). I already tried to edit them on my part and I have also used Mohamed's modified kext but no luck. With this program instead of hanging every 5 secs, it hangs every 11 mins . Better than nothing. :unsure:


Edit: Finally it also hangs but in another way everytime I load something (finder, safari, ...). When it freezes I can't do anything but reboot. :-( I have to downgrade to 10.7.1 as the new kexts related to hd 3000 make my hackintosh unusable. I hope someone will find a solution.


this program nearly useless as it depend on prsence of mixer switch

for you did you use smbios macbookpro 8.1

also try new fresh install and use kexts i linked :)


something new i found it about optimus

intel hd graphics is connected only to internal laptop screen lvds and vga connector
and nvidia card do processing only for this connectors and intel card do rendering this when use nvidia optimums
so under mac osx driver we only can use intel for this two connectors

but HDMI has nearly only connection from nvidia card need conformation thanks for hisho for helping me as he has hdmi display

if we conformed that hdmi rendering is by nvidia i think we have hope to make nvidia card work when using hdmi so the two cards will work at the same time

Do you mean this patch from Inspiron 15R N5110.txt patch ?(I have all this patches in my dsdt)

Device (PNLF)
		{
			Name (_HID, EisaId ("APP0002"))
			Name (_CID, "backlight")
			Name (_UID, 0x0A)
			Name (_STA, 0x0B)
		}
	}

It already present in my dsdt and I can change brightness from system preferences
But after sleep screen is more bright than after boot,maybe it's only in my case(N5110Hi2310X3C500BSCDSblack)

you are right screen is brighter after sleep more than after boot


may be the driver problem

#26
myska

myska

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Female
Thanks for your quick response. I've deleted this app. Yes I'm using smbios 8.1 (your version). I've already tried several different fresh installs in different ways (MBR, GPT, with windows, without windows, vanilla Lion, Iatkos L1, Snow Leo,...). But I always get this connectors issue :-( I also tried using your kexts but no luck, it still hangs on a ramdom basis.

As for your dsdt patch, I did apply it to my dsdt and it compiled without errors but when I boot up using it first I get a white screen, then it goes black and just after it goes to sleep. Maybe the key will be to edit my dsdt. What are the changes you made to connectors? I read that you have HD 3000 id 0x0116 and Geforce GT 525M like I do. But I've only got VGA/HDMI (no DVI), maybe I should remove the line referring to DVI in my dsdt. Could you help me? According to ioregistryexplorer, my port number is 0x0, av-signal-type is 00 00 00 00 and connector-type is 02 00 00 00.

#27
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male

Thanks for your quick response. I've deleted this app. Yes I'm using smbios 8.1 (your version). I've already tried several different fresh installs in different ways (MBR, GPT, with windows, without windows, vanilla Lion, Iatkos L1, Snow Leo,...). But I always get this connectors issue :-( I also tried using your kexts but no luck, it still hangs on a ramdom basis.

As for your dsdt patch, I did apply it to my dsdt and it compiled without errors but when I boot up using it first I get a white screen, then it goes black and just after it goes to sleep. Maybe the key will be to edit my dsdt. What are the changes you made to connectors? I read that you have HD 3000 id 0x0116 and Geforce GT 525M like I do. But I've only got VGA/HDMI (no DVI), maybe I should remove the line referring to DVI in my dsdt. Could you help me? According to ioregistryexplorer, my port number is 0x0, av-signal-type is 00 00 00 00 and connector-type is 02 00 00 00.


see this is the topic talks about this problem

http://www.insanelym...howtopic=259705

but this problem appear only on pc not on notebook

as the first connector listed on vinalla kext is lvds ( laptop screen )

so normally we should dont have this problem

so try update bios if you dont updated it and dont use dsdt

and try to install retial lion version 10.7.2 and try to use smbios 8.2

and see if the problem is still here



about edited framebuffer kext

this is config i did

0000000: 0102 0200 1007 0000 1007 0000 ............
000000c: 0503 0000 0200 0000 3000 0000 ........0... LVDS
0000018: 0602 0000 0010 0000 0900 0000 ............ VGA
0000024: 0000 0000 0000 0000 0000 0000 ............ NONE
0000030: 0000 0000 0000 0000 0000 0000 ............ NONE


and this config dont cause proble, to me

only vga need to make small work to get picture on it with detect display

#28
myska

myska

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Female
Thanks again for your support and all the information you provided. :)

This hanging problem also happens on certain laptops (http://www.tonymacx8...9b49f31f7718edc). I did try to edit my connectors by following bcc9's instructions but the only connector that allowed me to boot up was the first one listed (i.e. 0503 0000 0200 0000 3000 0000) as everytime I deleted it testing other combinations it would lead to a black screen. But unfortunately the problem remained the same even after I deleted the others connectors to leave this one alone. Since yesterday, I'm testing the stock AppleIntelSNBGraphicsFB.kext from 10.7.0 and it seems that I have much less freezes. I believe that maybe there is something to edit in this kext to stop freezes but not the connectors table as this one is strictly identical to the one from 10.7.2 (same number of connectors). I had installed Lion retail and upgraded to 10.7.2 but this version made my laptop unusable (too many freezes). I had also tried all smbios, but only 8.1, 8.2 and 8.3 worked otherwise I would get black screen with all the others. My current bios is A08 but I also had the same issues as when using A07.

Edit: I've just found these modded n5110 bios: http://forum.noteboo...0-bios-mod.html but I don't dare to try them. Anyone did it before?

#29
LuckyLuck

LuckyLuck

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Ukraine
Finally!!! no more panics on VoodooHDA!!!
AppleHDA from 10.6.2 + legacy kext + dsdt
All works fine :( :( :D
http://www.insanelym...p;#entry1770374
Posted Image

#30
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male

Thanks again for your support and all the information you provided. :)

This hanging problem also happens on certain laptops (http://www.tonymacx8...9b49f31f7718edc). I did try to edit my connectors by following bcc9's instructions but the only connector that allowed me to boot up was the first one listed (i.e. 0503 0000 0200 0000 3000 0000) as everytime I deleted it testing other combinations it would lead to a black screen. But unfortunately the problem remained the same even after I deleted the others connectors to leave this one alone. Since yesterday, I'm testing the stock AppleIntelSNBGraphicsFB.kext from 10.7.0 and it seems that I have much less freezes. I believe that maybe there is something to edit in this kext to stop freezes but not the connectors table as this one is strictly identical to the one from 10.7.2 (same number of connectors). I had installed Lion retail and upgraded to 10.7.2 but this version made my laptop unusable (too many freezes). I had also tried all smbios, but only 8.1, 8.2 and 8.3 worked otherwise I would get black screen with all the others. My current bios is A08 but I also had the same issues as when using A07.

Edit: I've just found these modded n5110 bios: http://forum.noteboo...0-bios-mod.html but I don't dare to try them. Anyone did it before?

to me i have no cause for this hanging to be done :rolleyes: sorry
you have same hardware so you should get it work like ours performance
there are a09 bios try it


this modded bios for nvidia card overclocking it give me nvidia card bios separated we can use it on future for nvidia card

Finally!!! no more panics on VoodooHDA!!!
AppleHDA from 10.6.2 + legacy kext + dsdt
All works fine :D :D :D
http://www.insanelym...p;#entry1770374

good
to me no panic with voodoo but want to use applehda

i will try first to use data linked on 10.7.2 kext
if not working will use 10.6.2 next

edit used directly 10.6.2 :D
waiting for next dell driver to solve problems with audio in

added update for guide

#31
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male
nvidia HDMI audio not load correct with applehda 10.6.2 kext but work with 10.7.2 but idt codec doesn't work

#32
myska

myska

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Female
Thanks for your feedback. I'm thinking of testing this modded bios as they made disabling nvidia card possible. I have the feeling that my issue is related to "nvidia optimus". :(

#33
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male

Thanks for your feedback. I'm thinking of testing this modded bios as they made disabling nvidia card possible. I have the feeling that my issue is related to "nvidia optimus". :(

ok good luck

does any one solved external mic problem on windows ?!

#34
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male
added patched applehda 10.7.2 for our codec
now it support both idt codec and nvidia hdmi codec

as before line in not working


i hope that one try to connect hdmi cable and see if hdmi appear on sound on system pref or not :)

#35
LuckyLuck

LuckyLuck

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Ukraine
AppleHDA 10.7.2 works,thanks for your work

#36
myska

myska

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Female

ok good luck


Thanks. I flashed my bios from GT-525M to GT-550M 0.83v but although my nvidia graphics are now underclocked and the temperature dropped by 25° C, there is no way to completely disable nvidia Optimus. I think my best chance is to edit my dsdt accordingly. I read the link suggested by hisho but as I have no disabling function in my dsdt, I have no idea how I could edit it. I attached my dsdt (from bios A09) but I'm not even sure if this is possible with my chipset (HM67).

I even tried 10.7.3 (11D16) update but although the artifacts I was experiencing in 10.7.2 disappeared, I still have the same intermittent issue (freezes every 5 seconds when loading any app) so I went back to 10.7.1 which is the most stable version for me.

#37
Victor Max

Victor Max

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
first of all, thank you very much for the hard work that you are putting in...

i have managed to install os x lion (10.7.2) with #####...

as you have said, the installation itself takes graphics driver.. also, it installs ethernet driver... then, i updated the battery percentage, processor power, camera, card reader, usb 3.0 (all one by one.. install--reboot--install)... but, ethernet adapter was lost right after i installed the very first kext i.e. battery percentage... so i thought i screwed something up and did complete installation again... and this time again, graphics and ethernet were installed.. so now i install camera kext first.. same thing again !! ethernet disappeared right after that !!

also, i have not been able to install any of the audio drivers successfully...

can you please shed some light on the ethernet adapter problem ???

ps: btw, i disabled wifi-bluetooth since i was unable to install os x when it was switched on...

#38
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,124 posts
  • Gender:Male
install kexts and use myfix google it to fix kext cache



as i said before i had also problem on eth

#39
Victor Max

Victor Max

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
yes.. installed os again and this time was successful with installing the supported hardware... now only wifi remains :)




thank you very much :D

#40
Victor Max

Victor Max

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
now, that i have confirmed that everything except wifi works in the hackintosh, i want to dual boot it with windows 7... and there are many guides out there but from whichever i have tried, they dont seem to work... so can you please advise as which one to follow ??





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy