Jump to content

Workstation 8/9/10, Player 4/5/6 and Fusion 4/5/6 Mac OS X Unlocker


  • Please log in to reply
540 replies to this topic

#441
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Just a quick update, Workstation 10.0.1, Player 6.0.1 and Fusion 6.0.1 have been released and OS X 10.8 and OS X 10.9 are working OK once the unlocker 1.2.x has been re-installed. I have updated the darwin.iso in the Download section to 6.0.1 from the latest version of Fusion.



#442
savestheday

savestheday

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

Do you guys have a way of getting full resolution out of VMware tools in Mavericks?  Using 6.0.1 VMware tools. I'm stuck at 1024x768.  



#443
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Do you guys have a way of getting full resolution out of VMware tools in Mavericks?  Using 6.0.1 VMware tools. I'm stuck at 1024x768.  

savestheday,

 

See the following post to help with your resolution issue:

 

http://www.insanelym...r-56/?p=1955770



#444
trungpt

trungpt

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

Just a quick update, Workstation 10.0.1, Player 6.0.1 and Fusion 6.0.1 have been released and OS X 10.8 and OS X 10.9 are working OK once the unlocker 1.2.x has been re-installed. I have updated the darwin.iso in the Download section to 6.0.1 from the latest version of Fusion.

 

Thank you for your info. I'm going to install v10.0.1 soon :D



#445
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Thank you for your info. I'm going to install v10.0.1 soon :D

trungpt,

 

If you are coming from Workstation 9.0.2, just be aware existing OS X VMs may need to be upgraded to vHW10 (Virtual Hardware) to boot, and do not forget to re-install the unlocker.



#446
trungpt

trungpt

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

trungpt,

 

If you are coming from Workstation 9.0.2, just be aware existing OS X VMs may need to be upgraded to vHW10 (Virtual Hardware) to boot, and do not forget to re-install the unlocker.

Thank you. I'm using v9.0.2. The unlocker is awesome :)



#447
luckman212

luckman212

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

Anyone tried this on VMware 10.0.1 build 1379776? Just wondering if it still works



#448
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Anyone tried this on VMware 10.0.1 build 1379776? Just wondering if it still works

luckman212,

 

All works fine with Workstation 10.0.1 build 1379776, see my earlier post:

 

http://www.insanelym...cker/?p=1958189

 

Also the new seed of 10.9.1 (developer preview) works fine in Workstation 10.0.1



#449
luckman212

luckman212

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

Cool, thanks MSoK!



#450
neox

neox

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

i want to thank you for this usefull topic. 

tryed to everything the "right way" but i have a little problem: i get this message while booting mountain lion. 

 

"The CPU has been disabled by the guest operating system. Power off or reset the virtual machine".

 

i tryed ressetting/ shutting off-on but i still get the same error message.

 

i'm using VMware 10.0 patched with the 1.2.0 unlocker.



#451
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,025 posts
  • Gender:Male
  • Location:Manchester UK

i want to thank you for this usefull topic. 

tryed to everything the "right way" but i have a little problem: i get this message while booting mountain lion. 

 

"The CPU has been disabled by the guest operating system. Power off or reset the virtual machine".

 

i tryed ressetting/ shutting off-on but i still get the same error message.

 

i'm using VMware 10.0 patched with the 1.2.0 unlocker.

 

What CPU do you have?



#452
neox

neox

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

AMD E 450 64bit



#453
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,025 posts
  • Gender:Male
  • Location:Manchester UK

AMD E 450 64bit

 

You will need to find a kernel for AMD as vanilla OS X cannot boot on that CPU.



#454
itsme2

itsme2

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hello,

 

after installation VMware Workstation 10.0.1 on my Windows 8.1 PC (Intel VT-X is supported, according to the Intel Processor Identification Utility) and installing Donks Unlocker 1.20, I tried to install MAC OS X Mavericks on a freshly created VM, selecting "Mac OS X 10.9" as Guest OS.

But I stopped already when trying to start that VM - with the error "OSX is not supported with binary translation error" :(

 

How can I solve this error to successfully perform a fresh install of Mavericks?

Setting the Guest OS to anything else should help, I read - but to what?

 

Please help.

 

 

*Edit*

 

I found the solution: In BIOS, VT-X was already enabled, as was Trusted Execution Protection (or a similar setting in BIOS). After I disabled that protection setting, the binary translation eroor when booting up the OS X guest was gone and I had no problem of installing Mac OS X successfully.

 

Maybe this solution can help other users that are alsso facing the binary translation error although VT-X is enabled in the BIOS of the host machine.



#455
salado

salado

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male

Thanks for the information found in this thread. Now I have up and running Mavericks running in the VMWare Fusion. 

Overall, with vmware-tools, SVGA-II and guestd-update. The user experience is much bettern than I had with the VirtualBox 4.3.6.

 

But, I still can't get iCloud and iMessage fixed on either VMWare or VirtualBox Mavericks VMs. This is quite important for my use case.

I want to send iMessage from the VM instead of typing on the screen of the phone. 

 

If anybody knows a sure solution, Please share.

 

Update 1: I did my Google part, found a tool called "iMessage Enabler". Don't know if anybody has experience with it for Mavericks VM?

 

Update 2: The iCloud was only partially signed in. "Mail" and "Notes" can't be activated. I changed the network adaptor from NAT to Bridged. Now, both "Mail" and "Notes" are active. But still got the error message for iMessage (see attached screenshot). Also, Map application doesn't work.

 

Thanks in advance!

Attached Files



#456
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,025 posts
  • Gender:Male
  • Location:Manchester UK

Thanks for the information found in this thread. Now I have up and running Mavericks running in the VMWare Fusion. 

Overall, with vmware-tools, SVGA-II and guestd-update. The user experience is much bettern than I had with the VirtualBox 4.3.6.

 

But, I still can't get iCloud and iMessage fixed on either VMWare or VirtualBox Mavericks VMs. This is quite important for my use case.

I want to send iMessage from the VM instead of typing on the screen of the phone. 

 

If anybody knows a sure solution, Please share.

 

Update 1: I did my Google part, found a tool called "iMessage Enabler". Don't know if anybody has experience with it for Mavericks VM?

 

Update 2: The iCloud was only partially signed in. "Mail" and "Notes" can't be activated. I changed the network adaptor from NAT to Bridged. Now, both "Mail" and "Notes" are active. But still got the error message for iMessage (see attached screenshot). Also, Map application doesn't work.

 

Thanks in advance!

 

Messages  actually does not work on Fusion on Mac. VMware did state they think it is a bug. As for Maps you need QE/CI for hat and the video drivers for VMware and VirtualBox do not have that capability.



#457
salado

salado

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male

Messages  actually does not work on Fusion on Mac. VMware did state they think it is a bug. As for Maps you need QE/CI for hat and the video drivers for VMware and VirtualBox do not have that capability.

 

Thanks Donk! What about VMWare Player 6 and VMWare WorkStation 10.0.1 on Windows 7?



#458
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Thanks Donk! What about VMWare Player 6 and VMWare WorkStation 10.0.1 on Windows 7?

salado,

 

Exactly the same issues, as the vast majority of the code is shared between Player 6, Fusion 6, Workstation 10 and ESXi 5.5.



#459
salado

salado

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male

salado,

 

Exactly the same issues, as the vast majority of the code is shared between Player 6, Fusion 6, Workstation 10 and ESXi 5.5.

 

So there is no fix at this point for iMessage on VMWare family. Does the "iMessage Enabler" help? 

VirtualBox has the same issue. I will keep looking and send update here.



#460
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,025 posts
  • Gender:Male
  • Location:Manchester UK

So there is no fix at this point for iMessage on VMWare family. Does the "iMessage Enabler" help? 

VirtualBox has the same issue. I will keep looking and send update here.

 

You are welcome to try but it changes lots of things in the VM and installs Chameleon boot loader so I for one won't be trying it. I have some new ideas on how to modify the nvram variables which appear to be important to the iCloud system. If you want to try it out let me know. However, I have broke too many new Apple IDs to want to carry on testing this myself.







3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy