Jump to content

Marvel Yukon 2 kext for Lion


  • Please log in to reply
35 replies to this topic

#1
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
Hey there,

until I started trying to make Lion GM work on my GA-P965-DS4 I used the attached kext (do NOT use with Lion, will not boot!) to make my ethernet work. I placed this kext in /E/E. However, with the Lion GM this does no longer work, does anyone know a replacement? I'd be very grateful for any hint! My board uses the Marvell 8056 chipset for gigabit LAN.

Thanks in advance!

Best,
E.

Attached Files



#2
Rackers

Rackers

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Use the attached Kext, I just used it to successfully get the same Ethernet working!

Use KextUtility to install it, do not just copy and paste, it didn't work for me.

After you have installed it using KextUtility, reboot and then run this command in terminal

sudo ipconfig set en0 DHCP


EDIT: All the usual Ethernet information is actually being reported now, it seems this Kext is fully working!

Attached Files



#3
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
Thanks for uploading this and I am happy that the kext works for you, however my system stops booting once this kext is installed :/

#4
Rackers

Rackers

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Have you tried booting with -v?

#5
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
Yes, of course, I always do. My system always stops with fsck check whenever I use a kext that is not ... well liked. Happened with my old way to enable my graphics (/E/E, now netkas patched files in /S/L/E). There's no debug information I could offer because the boot process simply dies and I need to reboot setup from USB to replace the changed kext with a backup. Then the system boots just fine, again.

:-(

P.S: In case it is of any relevance:

- Sound works thanks to binpatched 10.6.8 kext in /S/L/E
- GFX works thanks to netkas patched kexts in /S/L/E

/E/E contents: fakesmc.kext, ioahciblockstorageinjector.kext, nullcpupowermanagement.kext

smbios: MacPro3,1
DSDT.aml from DSDT generator, worked in 10.6.8

#6
vmaraccini

vmaraccini

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hi,
I have the same adapter as you, but a different board (P6T-Deluxe V2)
I managed to get it working on the GM (11A511) with this kext...
Hope it helps you too.

Attached Files



#7
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
Did you put it in /E/E or /S/L/E?

#8
vmaraccini

vmaraccini

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
E/E if I am not mistaken..

#9
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
Does not work, either. Thanks for trying, tough. :)

What's funny is, that both of you basically included some infos in the Info.plist, which I also tried before and which did not work. Rackers wrote it directly into the IONetworkingFamily, vmaraccini injected the information into it trough /E/E. Both don't work for me but for you, although the files are only slightly different. The system does not panic (visibly at least) but simply halts on boot. How can I possibly find out what's wrong here? ;)

#10
Kasakka

Kasakka

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts
All I did was edit the AppleYukon2 plugin inside IONetworkingFamily. I simply copied the parts from the previous 10.5/10.6 plugin and then copied the other options (Ringsize etc stuff) from the 88e8055 version. Works just fine on my Abit IP35.

Would not work without the Ringsize things. Does anyone know what they actually do and what they should be for the 88e8056?

Oh and the kext must be in S/L/E to work. In fact you can just forget about E/E and use the kernel cache option with Lion. To identify hacked kexts, add a label to them so they're easily found and color coded in S/L/E.

#11
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
So you copy all kexts to /S/L/E, including things like fakesmc etc.?

#12
Rackers

Rackers

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts

Hi,
I have the same adapter as you, but a different board (P6T-Deluxe V2)
I managed to get it working on the GM (11A511) with this kext...
Hope it helps you too.


I had to reinstall Lion today as for some reason the system went strange when I started it this morning (bad kext?).

I instead used the Kext attached by the above and placed it in E/E and it works perfectly without needing to mess around with Kext utilities and stuff!

#13
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
I did not manage to make my ethernet work, the whole setup seems messy. I have no clue what I am doing wrong :/

#14
Makimba

Makimba

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
I've just installed Lion GM on 965p-DS4 and everything (sound, graphic card, ethernet) is working fine.
I've used my Snow Leopard DSDT.aml for speepstep, reset bios, graphic. AppleHDA.kext provide by Effendi for the sound and Marvell88E8056.kext provide by vmaraccini for the network (put in /E/E with the vanilla IONetworkingFamily.kext). Thank you so much for your help :)

Posted Image

#15
Kasakka

Kasakka

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts

So you copy all kexts to /S/L/E, including things like fakesmc etc.?


Yes. Then you need to set UseKernelCache to Yes in com.apple.boot.plist in /Extra so Chameleon uses the kernel cache instead of Extensions.mkext.

#16
Makimba

Makimba

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts

Yes. Then you need to set UseKernelCache to Yes in com.apple.boot.plist in /Extra so Chameleon uses the kernel cache instead of Extensions.mkext.


I'm not, the only kext i put in /S/L/E is AppleHDA.kext. Everything else is in /Extra. It's more clean this way.

#17
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
Yes, but the boot process takes longer (like using -f). However, I did it the same way, I prefer less work after an update from Apple ;)

#18
alborto

alborto

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Does not work, either. Thanks for trying, tough. ;)

What's funny is, that both of you basically included some infos in the Info.plist, which I also tried before and which did not work. Rackers wrote it directly into the IONetworkingFamily, vmaraccini injected the information into it trough /E/E. Both don't work for me but for you, although the files are only slightly different. The system does not panic (visibly at least) but simply halts on boot. How can I possibly find out what's wrong here? :(


I have the same problem, the system does not panic (visibly at least) but simply halts on boot and when i restore a backup the system start again but without eth support.
I tryed all, injection form /E/E or /S/L/E , edited kext on /E/E or /S/L/E.

I installed whit MaLd0n' USB stick and Lion GM (http://www.insanelym...howtopic=256729) whit DSDT Auto-Patche for windows 7 and nothing other.

I don't know what to do, any help is wellcome.

PS: sorry for my bad english.

#19
Effendi

Effendi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Vienna, Austria
My solution: Buy the Apple USB-to-Ethernet adaptor, it works with that one...

#20
Makimba

Makimba

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
I also have some code in my DSDT.dsl for the ethernet :

Posted Image

Device (PEX4)
			{
				Name (_ADR, 0x001C0004)
				Method (_STA, 0, NotSerialized)
				{
					Return (0x0F)
				}

				Method (_PRW, 0, NotSerialized)
				{
					Return (Package (0x02)
					{
						0x09, 
						0x05
					})
				}

				Name (PIC4, Package (0x04)
				{
					Package (0x04)
					{
						0xFFFF, 
						Zero, 
						LNKA, 
						Zero
					}, 

					Package (0x04)
					{
						0xFFFF, 
						One, 
						LNKB, 
						Zero
					}, 

					Package (0x04)
					{
						0xFFFF, 
						0x02, 
						LNKC, 
						Zero
					}, 

					Package (0x04)
					{
						0xFFFF, 
						0x03, 
						LNKD, 
						Zero
					}
				})
				Name (API4, Package (0x04)
				{
					Package (0x04)
					{
						0xFFFF, 
						Zero, 
						Zero, 
						0x10
					}, 

					Package (0x04)
					{
						0xFFFF, 
						One, 
						Zero, 
						0x11
					}, 

					Package (0x04)
					{
						0xFFFF, 
						0x02, 
						Zero, 
						0x12
					}, 

					Package (0x04)
					{
						0xFFFF, 
						0x03, 
						Zero, 
						0x13
					}
				})
				Method (_PRT, 0, NotSerialized)
				{
					If (LNot (PICF))
					{
						Return (PIC4)
					}
					Else
					{
						Return (API4)
					}
				}

				Device (LAN)
				{
					Name (_ADR, Zero)
					Name (_PRW, Package (0x02)
					{
						0x0B, 
						0x04
					})
					Method (_DSM, 4, NotSerialized)
					{
						Store (Package (0x04)
							{
								"built-in", 
								Buffer (One)
								{
									0x01
								}, 

								"device_type", 
								Buffer (0x09)
								{
									"ethernet"
								}
							}, Local0)
						DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
						Return (Local0)
					}
				}
			}






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy