Jump to content

[GUIDE] Dell Studio 1558 ATI 5470 Core i7 - What I've got working so far

- - - - -

  • Please log in to reply
225 replies to this topic

#1
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada
UPDATE 2 (06/08/2011): For a lion installation, this guide is unnecessary. Follow either one of these two guides to install Lion (both require a Mac). Installation using a usb here. Installation WITHOUT using a usb here.

After installation of Lion is complete use this kext pack and com.apple.boot.plist. Use Kext Helper to install the kexts. If you get kernel panics because of audio kext AppleHDA, remove it and install VoodooHDA 2.7.2 from #####. Everything is provided by CharlieSheen: http://www.mediafire...kh3vb7pth15jn91

UPDATE 1: All recent changes made are in RED.

My system:
  • Dell Studio 1558
  • Core i7 (720QM) 1.6Ghz
  • 4GB DDR3 1333Mhz RAM
  • ATI Mobility HD 5470 1GB (1366x768)
  • (The much hated) Broadcom BCM4313 [14e4:4727]
  • 500GB (7200 RPM) HDD

Thanks to the awesome user mac-lovin on the tonymacx86 forum I was able to get the following working.

What I have working: Graphics card (without QE/CI), Touchpad, Keyboard, USB Ports, Bluetooth, CD/DVD drive
To get QE/CI working (after the release of Lion) see CharlieSheen's post here.


What I DON'T have working: Wireless, battery indicator

Note: I'm using a retail OS X 10.6.3 DVD

The process (what you've been waiting for *drum roll*):
- Booted with Chameleon RC5 rev650 (no special boot flags)

- Installed OS X (10.6.3)

- When restarted, booted Chameleon with "-v busratio=20 arch=i386" "-x -v busratio=20 arch=i386" ---> We boot into safe mode to avoid a kernel panic. See below.

When in safe mode, external devices or other partition types shown in Finder. What I do first is boot with "-v busratio=20 arch=i386", copy the Combo Update and other files from my Storage NTFS partition to my desktop and then reboot again with "-x -v busratio=20 arch=i386"

- Installed 10.6.7 Combo Update followed by ##### 3.7.2 (I think the version number might be wrong will correct ASAP)

##### options:
  • System Utilities - All
  • OSx86 Software - All
  • Graphics - ATI 1.6.34.13
  • Realtek Gigabit Ethernet 2.0.6
  • Audio - Voodoo HDA 2.7.2
  • Kexts -> Miscellaneous - All except USB 3.0 and Voodoo PS/2 Controller

- At this point, towards the end of the ##### installation, I get a kernel panic and I have to restart. There's probably something that I have to remove to avoid it because according to mac-lovin, I shouldn't be getting one. The steps I was guided through were meant to be done without restarting after ##### was done. To avoid this you boot into safe mode '-x'.

- Anyway, after restarting (without boot flags) I open KextHelperb7 and drag the VoodooPS2Controller.kext, SuperIOFamily.kext and VoodooBattery in the box and run it.

- I installed bcm43xx_enabler.sh (Open a terminal, type sudo, drag the file to the terminal window)

- Installed Chimera.pkg (Not sure about the version number either)

- Installed the prefPane for Chameleon

- Copied the com.apple.boot.plist supplied by mac-lovin to the /Extras folder

Even after installing the bcm enabler my wireless doesn't work. However it works for mac-lovin (if I didn't mention it earlier, he has the same PC specs as me). I would be happier if I could get at least that working though. =\

For Bluetooth, just install this pkg assuming you have either the Dell Wireless 365, 370 or 410 Bluetooth Module: Attached File  DellBluetoothHCI.1.2.pkg.zip   27.92KB   233 downloads

Attached the VoodooBattery kext separately: Attached File  VoodooBattery.kext.zip   15.76KB   268 downloads

Here are some of the files I've mentioned above. They don't include Chimera, Chameleon boot cd image and #####
Attached File  Studio_1558_i7_Files.zip   1.01MB   520 downloads

#2
Shirosaki

Shirosaki

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I have had succes with Hazard OSX Snow leopard 10.6.6i, things like the broadcom wifi work and my gpu to, but I got the 4570.

So far I have heard the 5470 is not working well under OSX, so you not going reach so far as I did with the older ati card.

#3
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada

I have had succes with Hazard OSX Snow leopard 10.6.6i, things like the broadcom wifi work and my gpu to, but I got the 4570.

So far I have heard the 5470 is not working well under OSX, so you not going reach so far as I did with the older ati card.

Were you able to get QE/CI working? That's the only thing from my graphics card that doesn't work.

Aside from that just my wireless, which I'm more interested in solving.

#4
Shirosaki

Shirosaki

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Yes but thats because I got the 4570 and not 5470. The WiFi i got working with the broadcom fix included in Hazard OSX Snow leopard 10.6.6i

#5
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball
The user, fayens has got the 5470 to work with glitches. I will see that it will work, and Ill attempt to mitigate the transparent menu bar glitch. As for the WLAN, I would order a Dell Wireless 1510 card off of ebay, or use a USB dongle. I will be installing Lion, as that is the future of mac.

And to the guy with the 4xxx series, you likely have a 1557 or a 1555 or something, which includes the aforementioned 1510 WLAN card.

#6
Shirosaki

Shirosaki

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
No I got a 1558, they first still sold them with ATI RADEON HD 4570 and later they started selling with the ATI RADEON HD 5470.

I got a Broadcom 4312 I guess, but broadcom fix worked for me, but be honest that distro I named was only succeed installation method.

#7
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball

No I got a 1558, they first still sold them with ATI RADEON HD 4570 and later they started selling with the ATI RADEON HD 5470.

I got a Broadcom 4312 I guess, but broadcom fix worked for me, but be honest that distro I named was only succeed installation method.


Are you sure? Or maybe it was only US sold laptops that are 1558 are only 5470. I though that was the only difference between a 1557 and an i7 1558.

anyways.....

I have achieved glitch free QE/CI for the 5470

1. Use Lion DP4
2. Use the injector from this thread. http://www.insanelym...p...891&hl=5470
3. Edit com.apple.boot.plist the way fayens suggested. http://www.insanelym...p...250256&st=0

Transparency works perfectly. Will post screens once I get this USB Wifi dongle to work with my Studio 1558.

#8
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada

Are you sure? Or maybe it was only US sold laptops that are 1558 are only 5470. I though that was the only difference between a 1557 and an i7 1558.

anyways.....

I have achieved glitch free QE/CI for the 5470

1. Use Lion DP4
2. Use the injector from this thread. http://www.insanelym...p...891&hl=5470
3. Edit com.apple.boot.plist the way fayens suggested. http://www.insanelym...p...250256&st=0

Transparency works perfectly. Will post screens once I get this USB Wifi dongle to work with my Studio 1558.


Is the DP4 stable?

Your link for the injector says page not found.

#9
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball
http://www.multiupload.com/PV9EYYPXW7

Try that link

And yeah, on my Desktop I haven't had a single problem with it and I have had it up for over a week. My other laptop is a Core Duo and doesn't support it, and my 1558 i7 works fine with it, although I've only had it up since earlier today.

Edit: Thread link didn't work, I copied and pasted the direct link to the RAR

#10
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball
All in all its coming together pretty well.

Battery indicator I managed to get in SL. I don't think its working for any laptop on Lion at the moment.

For the 1558 with the DW1520, you need to swap out for a DW1510 or a USB Wifi dongle.

Use lifelike27's way of getting your trackpad working with VoodooPS2/#####, the one in the 1557 thread is very much inferior. (No gestures, doesn't appear in system preferences as anything)

The display tab of Lion's about this mac says its two generic external monitors. Do not mind that, it displays on the internal screen perfectly.

#11
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada

All in all its coming together pretty well.

Battery indicator I managed to get in SL. I don't think its working for any laptop on Lion at the moment.

For the 1558 with the DW1520, you need to swap out for a DW1510 or a USB Wifi dongle.

Use lifelike27's way of getting your trackpad working with VoodooPS2/#####, the one in the 1557 thread is very much inferior. (No gestures, doesn't appear in system preferences as anything)

The display tab of Lion's about this mac says its two generic external monitors. Do not mind that, it displays on the internal screen perfectly.


I'm currently in an area with limited bandwidth so I can't download the Lion DP yet. When I can I'll post a detailed instruction of the process.

#12
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball
Yeah thats straight. This close to the retail lion coming out, I would just wait for that. Also, Do your volume control keys work properly?

#13
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada
No the volume controls don't. If you press max volume, it continuously goes till max like someones pressing the button. After a while it crashes and I have to control the volume manually from the indicator icon.

Btw, where do I get the Developer Preview from? Torrent?


Do you have your laptop fan running on low-medium even when not in use? Mine does that for some reason. I don't even have battery support on mine so I think that might be the cause.

#14
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball
Yeah I got the same issue with the volume keys. I have determined is a voodoops2 or keyboard issue an not the audio driver.

Register for the Mac Developer Program is the only official way of getting it for now. Torrents are frowned upon here haha

And I got battery indicator working. Someone uploaded a Lion version of VoodooBattery on kexts.com. My fan is fine too.

So my system is working perfectly now, except for the keys issue, and my wireless has to have a usb wifi dongle attached until my DW1510 comes in. Maybe check off function key use only in the BIOS and use a hotkey application to change F7-F12 into "multimedia keys"

#15
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada

Yeah I got the same issue with the volume keys. I have determined is a voodoops2 or keyboard issue an not the audio driver.

Register for the Mac Developer Program is the only official way of getting it for now. Torrents are frowned upon here haha

And I got battery indicator working. Someone uploaded a Lion version of VoodooBattery on kexts.com. My fan is fine too.

So my system is working perfectly now, except for the keys issue, and my wireless has to have a usb wifi dongle attached until my DW1510 comes in. Maybe check off function key use only in the BIOS and use a hotkey application to change F7-F12 into "multimedia keys"


Yeah, I've tried changing the function keys from bios. Same issue there.

#16
Shirosaki

Shirosaki

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Yeah I got the same issue with the volume keys. I have determined is a voodoops2 or keyboard issue an not the audio driver.

Register for the Mac Developer Program is the only official way of getting it for now. Torrents are frowned upon here haha

And I got battery indicator working. Someone uploaded a Lion version of VoodooBattery on kexts.com. My fan is fine too.

So my system is working perfectly now, except for the keys issue, and my wireless has to have a usb wifi dongle attached until my DW1510 comes in. Maybe check off function key use only in the BIOS and use a hotkey application to change F7-F12 into "multimedia keys"

That issue with volume keys I got to, if you press them that small window will not go away unless I mute it.

#17
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada

Register for the Mac Developer Program is the only official way of getting it for now. Torrents are frowned upon here haha


Do I have to register as a paid developer for it?

EDIT: Nevermind, I guess I have to. I can't afford to pay $99 though. =\

Anyway you could attach the lion kexts needed? Pleaseee :angel: :D

Could you also tell me the status of your DW1510, I might consider buying one as well. I ordered a USB dongle atm with a Realtek chipset. There's a Mac driver available on Realtek website and it was updated in June so it should work. I think it was a RTL8188CUS.

#18
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball
I am pretty sure in Snow it will create graphical glitches and such, like the white menu bar and the non functioning spotlight, like what fayens's results were.

#19
CharlieSheen

CharlieSheen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
  • Location:South Carolina
  • Interests:Ball

Do I have to register as a paid developer for it?

EDIT: Nevermind, I guess I have to. I can't afford to pay $99 though. =\

Anyway you could attach the lion kexts needed? Pleaseee :unsure: :P

Could you also tell me the status of your DW1510, I might consider buying one as well. I ordered a USB dongle atm with a Realtek chipset. There's a Mac driver available on Realtek website and it was updated in June so it should work. I think it was a RTL8188CUS.


workI just ordered one on eBay from Hong Kong, so it will be a week or so, but it should natively work as Airport. My dongle is a Belkin with the Eealtek RTL8192SU chipset. The Realtek driver kind of annoying as it pops up after you start up, and the usual methods of trying to hide it will make you have to actually click the application for your wifi to work.

#20
lifelike27

lifelike27

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:Toronto, Canada

workI just ordered one on eBay from Hong Kong, so it will be a week or so, but it should natively work as Airport. My dongle is a Belkin with the Eealtek RTL8192SU chipset. The Realtek driver kind of annoying as it pops up after you start up, and the usual methods of trying to hide it will make you have to actually click the application for your wifi to work.


I live in Canada and because of the postal strike no mail is getting through. I guess I'll have to wait longer. =\





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy