Jump to content

[Guida] Installare OS X Lion e Mountain Lion !

Guida Installare OSX Lion Mountain

  • Please log in to reply
2282 replies to this topic

#2121
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro
Dal nervoso ho caricato tutti i kext e anche il dsdt.aml della guida di fabio, magicamente è partita l'installazione, ora devo soltanto caricare di nuovo tutti i kext e il dsdt nell'installazione su hdd vero?
Ovviamente anche fakeSMC e il chamaleon?

#2122
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D

Dal nervoso ho caricato tutti i kext e anche il dsdt.aml della guida di fabio, magicamente è partita l'installazione, ora devo soltanto caricare di nuovo tutti i kext e il dsdt nell'installazione su hdd vero?
Ovviamente anche fakeSMC e il chamaleon?

Sicuro che il dsdt sia generico per la mobo? non usare dsdt compilati per altri sistemi se non sono fatti in modo da essere generici. Può portare problemi al computer.

niente da fare...si blocca sempre ti posto due immagini la prima facendo partire in modalita verbose semplice,la seconda ho dato il comando verbose+il comando che mi avevi dato in precedenza -f arch=i386 etc

edit: nessuna novità per ora

#2123
enricandre

enricandre

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Sicuro che il dsdt sia generico per la mobo? non usare dsdt compilati per altri sistemi se non sono fatti in modo da essere generici. Può portare problemi al computer.


edit: nessuna novità per ora


ho scritto anche ad un inglese giorni fa,secondo lui è la scheda video che dà problemi e non è compatibile

#2124
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Si ma quel genere di problema si risolve usando npci=2000 all'avvio

l'alternativa potrebbe essere il metodo originale, ossia sostituire i file AppleACPIPlatform & IOPCIFamily con quelli di snow leopard 10.6.7 (li trovi qui AppleACPIPlatform & IOPCIFamily)

però questo procedimento non l'ho mai provato su ML (mal che vada non parte, peggio di così non può andare :D )

#2125
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro
Il dsdt e quello di Fabio71 per la p5q deluxe, ke cm mobi è identica alla mia, differenzia sl da fatto ke ha qualche connettore in più, penso sia abbastanza simile...
Cmq ho un altro problema, al riavvio della USB dp l'installazione nn trovo l'hdd con l'installazione fatta prima, quindi l'installazione e nulla...


Ps: per installare o dovuto formattare la partizione in guid...
Ah dimenticavo se puo essere utile io voglio installare os x in un secondo hd, e sul pc in questione gira già winzoz 7


#2126
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Il dsdt non va bene, deve essere la stessa identica scheda, altrimenti può portare problemi

L'hard disk se puoi mettilo sul primo canale sata, e scollega gli altri. Dopo aver fatto l'installazione avvia da usb, ma invece di lanciare nuovamente l'installazione seleziona l'hard disk dove hai installato osx

#2127
enricandre

enricandre

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Si ma quel genere di problema si risolve usando npci=2000 all'avvio

l'alternativa potrebbe essere il metodo originale, ossia sostituire i file AppleACPIPlatform & IOPCIFamily con quelli di snow leopard 10.6.7 (li trovi qui AppleACPIPlatform & IOPCIFamily)

però questo procedimento non l'ho mai provato su ML (mal che vada non parte, peggio di così non può andare :D )


per non fare errori :P
dove dovrei metterli i file?

#2128
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
All'interno della tua usb, nel percorso /System/Library/Extensions

già che ci sei, nella usb hai la cartella Extra/Extensions vero? che file ci sono dentro?

#2129
enricandre

enricandre

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

All'interno della tua usb, nel percorso /System/Library/Extensions

già che ci sei, nella usb hai la cartella Extra/Extensions vero? che file ci sono dentro?


c'è e dentro ho:
cartella extensions con dentro fakesmc.kext,ds store e ioahckblocstorageinjector.kext
org.chamaleon.boot.plist
smbios.plist
cartella themes
.ds store

ti ho aggiunto un link la foto dopo aver sostituito quei file...
dopo qualche minuto ha aggiunto una riga con scritto:
still waiting boot o una frase del genere


http://img543.images...7/img0623ck.jpg

#2130
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro
Installazione riuscita, o quasi....

#2131
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro
Ok ora parte chameleon ma nn mi vede la partizione contenente ML, cosa bisogna fare?

#2132
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D

http://img543.images...7/img0623ck.jpg

Ok, proviamo ad eliminare AppleUSBUHCI? vediamo che succede

qui non vedo still waiting

Ok ora parte chameleon ma nn mi vede la partizione contenente ML, cosa bisogna fare?

Se hai usato altri strumenti che non sono neanche di questo forum tra l'altro, di certo non so aiutarti. E comunque dovresti leggere il regolamento

#2133
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro

Ok, proviamo ad eliminare AppleUSBUHCI? vediamo che succede

qui non vedo still waiting


Se hai usato altri strumenti che non sono neanche di questo forum tra l'altro, di certo non so aiutarti. E comunque dovresti leggere il regolamento


Ops chiedo scusa, ho rimediato,
cmq per farti capire meglio, quello ke ho detto prima me lo faceva anche con la tua guida, installando sl con chameleon quest'ultimo nn mi vede la partizione con mountain lion, questo è successo dal momento ke con utility disk ho inizializzato la partizione in guid...
Come posso fare a riprendere quella partizione?

#2134
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro
Leggevo sul forum ufficiale del voodooprojects che è possibile nascondere delle partizioni con chameleon, e possibile fare l'azione inversa?

#2135
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Di default le partizioni sono tutte visibili, quindi a meno che non hai fatto tu qualcosa, è difficile che la partizione sia nascosta. Potresti provare a ripetere l'installazione, oppure cambiare bootloader

#2136
enricandre

enricandre

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Ok, proviamo ad eliminare AppleUSBUHCI? vediamo che succede

qui non vedo still waiting


Se hai usato altri strumenti che non sono neanche di questo forum tra l'altro, di certo non so aiutarti. E comunque dovresti leggere il regolamento


still waiting nn c'è perche è comparso dopo quando stavo quasi gia per riavviare perche era fermo li,e non ho pensato a rifare un'altra foto :P quando è comparso il messaggio ho avuto la conferma che eravamo piantati
in system/library/extension non trovo appleUSBUHCI dovrei trovarlo da un'altra parte?

#2137
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Allora, prima di procedere, non stai usando usb 3.0 vero? Se non stai usando porte usb 3.0 (o dispositivi con usb 3.0), proviamo così

1) Apri il file /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBUHCI.kext/Contents/Info.plist

è un file di testo, lo puoi aprire anche da windows

2) Cerca la stringa
<key>IOPCIClassMatch</key>
<string>0x0C030000</string>

3) Sostituisci quella stringa con questa

<key>IOPCIMatch</key>
<string>0x28308086 0x28318086 0x28348086 0x28358086</string>

Quindi prova ad avviare con -f


----

Metodo 2, se non funziona il primo, proviamo ad andar giù pesante. Elimina tutto il kext, /System/Library/Extensions/IOUSBFamily.kext/

avvia sempre con
-f
e vediamo che succede ;)

#2138
blerk85

blerk85

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Tiriolo Catanzaro

Di default le partizioni sono tutte visibili, quindi a meno che non hai fatto tu qualcosa, è difficile che la partizione sia nascosta. Potresti provare a ripetere l'installazione, oppure cambiare bootloader

E quale dovrei usare?


#2139
enricandre

enricandre

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Allora, prima di procedere, non stai usando usb 3.0 vero? Se non stai usando porte usb 3.0 (o dispositivi con usb 3.0), proviamo così

1) Apri il file /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBUHCI.kext/Contents/Info.plist

è un file di testo, lo puoi aprire anche da windows

2) Cerca la stringa

<key>IOPCIClassMatch</key>
<string>0x0C030000</string>

3) Sostituisci quella stringa con questa

<key>IOPCIMatch</key>
<string>0x28308086 0x28318086 0x28348086 0x28358086</string>

Quindi prova ad avviare con -f


----

Metodo 2, se non funziona il primo, proviamo ad andar giù pesante. Elimina tutto il kext, /System/Library/Extensions/IOUSBFamily.kext/

avvia sempre con
-f
e vediamo che succede ;)


Ecco come non detto sto usando un wd usb 3.0...porcaccia la miseria!
vedo di far un po di giri di file e di usarne un altro

#2140
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D

E quale dovrei usare?

Non necessariamente un altro, semplicemente un'altra usb con una nuova installazione di chameleon. Al massimo manche qualche kext per la tua configurazione

Ecco come non detto sto usando un wd usb 3.0...porcaccia la miseria!
vedo di far un po di giri di file e di usarne un altro

Ecco...abbiamo trovato il problema...le usb 3.0 non funzionano nativamente su osx, bisogna fare qualche modifica





Also tagged with one or more of these keywords: Guida, Installare, OSX, Lion, Mountain


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy