Jump to content

BCM5722, BCM5754/M, BCM5755/M, BCM5787/M and BCM5906/M NIC driver (32/64-bit)


  • Please log in to reply
238 replies to this topic

#201
existation

existation

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

Does this version support 10.9? Since now I have only 10.9 on my laptop.



#202
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
It should work for 10.9.

#203
existation

existation

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

I make some tests. Bad driver. I use patched AppleBCM5701Ethernet for eth.

Broadcom 57765-B0:

 

  Name: Ethernet

  Type: Ethernet Controller

  Bus: PCI

  Slot: Built-In

  Vendor ID: 0x14e4

  Device ID: 0x16b1

  Subsystem Vendor ID: 0x17aa

  Subsystem ID: 0x3975

  Revision ID: 0x0010

  Link Width: x1

  BSD name: en0

  Kext name: AppleBCM5701Ethernet.kext

  Location: /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701Ethernet.kext

  mDNS offload capable: dc:0e:a1:e0:82:ea

  Version: 3.6.9b2



#204
Toucanet

Toucanet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts

Where can I find a BCM57780 Broadcom ethernet controller working kext for Mavericks?



#205
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male

Where can I find a BCM57780 Broadcom ethernet controller working kext for Mavericks?

http://www.insanelym...le/79-bcm5722d/

I also have BCM57780, it should also work well for you as well



#206
Toucanet

Toucanet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts

Thank you very very much, it works! ;)



#207
Hacktrix2006

Hacktrix2006

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 423 posts
  • Gender:Male

Hi all just done a clean install of Mavericks and i made sure i downloaded the latest drive for the BCM5906M now in 10.8.4 it was working without issues but in 10.9 nothing its. All i see in console is

 

18/11/2013 21:29:23.000 kernel[0]: my_name_adlan_BCM5722D: Failed to register interrupt source
 
and
 
18/11/2013 21:38:44.263 com.apple.kextcache[483]: kext my.name.adlan.BCM5722D  203059000 is in exception list, allowing to load
 
Any ideas on getting this Lan card working in Mavericks ??? thanks in advance


#208
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male

Hi all just done a clean install of Mavericks and i made sure i downloaded the latest drive for the BCM5906M now in 10.8.4 it was working without issues but in 10.9 nothing its. All i see in console is
 
18/11/2013 21:29:23.000 kernel[0]: my_name_adlan_BCM5722D: Failed to register interrupt source
 
and
 

18/11/2013 21:38:44.263 com.apple.kextcache[483]: kext my.name.adlan.BCM5722D  203059000 is in exception list, allowing to load
 
Any ideas on getting this Lan card working in Mavericks ??? thanks in advance

seems the problem with permissions. Did you try to load without cashes. Or to lunch kext utility?



#209
weezul

weezul

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Newcastle, UK
  • Interests:Music!

Hey, I've just turned my Dell xps 8300 into a hackintosh with great success. However, using this Ethernet driver results in upload cut outs.

 

For instance, if I am streaming an mp3 from my SMB file server, it tends to stop every minute or so for a couple of seconds. Looking at network utility, it will also give me a receive error. For some odd reason, Videos stream fine but my music library always cuts out and the pauses between tracks are longer than they should be.

 

Also browsing the SMB share is a little slow, every new request for a folder listing tends to take forever. Model is BCM57788 NetLink ™ Gigabit Ethernet, according to Network Utility.

 

It also only connects at 100MBit, although my Powerline Adapters are suppsoed to be all 500MBps :)

Is it worth trying the patched AppleBCM5701Ethernet method?

Thanks for any advice



#210
Mieze

Mieze

    Giant Cat

  • Coders
  • 574 posts
  • Gender:Female
  • Location:Germany
  • Interests:Cats

Hey, I've just turned my Dell xps 8300 into a hackintosh with great success. However, using this Ethernet driver results in upload cut outs.

 

For instance, if I am streaming an mp3 from my SMB file server, it tends to stop every minute or so for a couple of seconds. Looking at network utility, it will also give me a receive error. For some odd reason, Videos stream fine but my music library always cuts out and the pauses between tracks are longer than they should be.

 

Also browsing the SMB share is a little slow, every new request for a folder listing tends to take forever. Model is BCM57788 NetLink ™ Gigabit Ethernet, according to Network Utility.

 

It also only connects at 100MBit, although my Powerline Adapters are suppsoed to be all 500MBps :)

Is it worth trying the patched AppleBCM5701Ethernet method?

Thanks for any advice

 

It's probably not a driver issue but a known weakness of Apple's SMB implementation. In order to resolve SMB performance issues set

net.inet.tcp.delayed_ack: 2

using sysctl. Also check the servers network configuration.

 

Please keep in mind that Ethernet doesn't support 500MBps, only 10, 100 and 1000, and if your Powerline adapters don't support gigabit speed you're limited to FE.

 

You can try to patch Apple's driver but I don't think this will work. According to Broadcom's Programmer's Guide your BCM57788 is not a member of the BCM57785 family.

 

Mieze



#211
weezul

weezul

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Newcastle, UK
  • Interests:Music!

Thanks for the info. You are right, the adaptor is sold as 500mps but will only connect up to 100mps as the device doesn't have a gigabit ethernet port.... who comes up with this stuff?!?!?! 

Anyway, I will try what you suggested. Still new to all this, so just incase i mess something up what is the default setting of that value?

Thanks again

 

edit: found it's 3. No probs. Streaming some music now at 2... still stopping every now and again. Browsing the SMB share is still pretty naff. Vielen Dank fur die hilfe sowieso!



#212
Mieze

Mieze

    Giant Cat

  • Coders
  • 574 posts
  • Gender:Female
  • Location:Germany
  • Interests:Cats

Anyway, I will try what you suggested. Still new to all this, so just incase i mess something up what is the default setting of that value?

 

 

 

 

 

 

The client version of OS X uses 3 as a default, while OS X Server and Windows use 2.

 

Mieze



#213
weezul

weezul

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Newcastle, UK
  • Interests:Music!

You know what? It's settled down now, working like a charm streaming 96khz 24bit FLAC. Danke schone!!!!!



#214
kcskcw

kcskcw

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male

Do you support this?
(generated from linux with lspci -nn)
01:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM57786 Gigabit Ethernet PCIe [14e4:16b3] (rev 01)    



#215
kcskcw

kcskcw

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male

humpty dumpty bump.....



#216
Rockey12

Rockey12

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Earth
  • Interests:no comi

Hello to everyone i just wanna shear that BCM5752 doesn't work after sleep wake up any solution would be really appreciated



#217
LightningRider

LightningRider

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Hello bros...

I installed the 10.9.2 in my acer, using the 2.3.5 version and still the same error of, cable ''connected red bottom, manually green bottom without work''... The problem persist yet?

Thanks for help us.

Cheers.



#218
hjudT

hjudT

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hi,

I am trying to get BCM5784M working with no success so far
by using version 2.3.5 ML_BCM5722D.kext downloaded from this thread.
(page 7, Alex Auditore Posted 24 June 2013 - 01:23 PM)

The error I get is the following:
02/03/2014 12:29:56.000 kernel[0]: BCM5722D (Build date/time: Jun 24 2013 12:24:10)
02/03/2014 12:29:56.000 kernel[0]: my_name_adlan_BCM5722D: Failed to register interrupt source

I installed the kext as Alex Auditore suggested by using Kext_Utility v2.5.6 and rebooted
"seems the problem with permissions. Did you try to load without cashes. Or to lunch kext utility"

The card works perfectly in linux, so I assume I should not miles away from getting this hardware
working in MacOSX, right? Any suggestions please?


Some background information:

(1)
BCM5784M Gigabit Ethernet (deviceid=0x1698 vendor=0x14e4)

(2)
Acer Aspire 7738G
Q9000
8GB RAM

(3)
Mountain Lion 10.8.5 (12F37)

(4)
booting through Chameleon, content of org.chameleon.Boot.plist as follows
<key>Boot Banner</key>
<string>No</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>-v -f PCIRootUID=0 npci=0x3000 DSDT=null</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>No</string>
 

 

Some hardware info taken from linux

BCM5784_part1_zps4ba76578.png

 

BCM5784_part2_zps574c4859.png



#219
Mieze

Mieze

    Giant Cat

  • Coders
  • 574 posts
  • Gender:Female
  • Location:Germany
  • Interests:Cats

Please post an IOReg dump.

 

Mieze



#220
hjudT

hjudT

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Dump as requested taken with IOReg v3.0.2

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy