Jump to content

ATI Radeon HD 5450 Working On Snow Leopard


  • Please log in to reply
159 replies to this topic

#41
Jerry_MK2

Jerry_MK2

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Maybe I made one step forward, but still no acceleration for this card.

After installing mac os x 10.6.4 update, my ASUS EAH5450 was working but without acceleration. Only 1 resolution, the one I inserted in com.apple.Boot.plist. No resolution change possible.

After installing mac os x 10.6.6 update, I got black screen before entering the desktop, even using UseAtiROM option with 1002_68f9.rom in EXTRA folder.

So, I replaced the ati drivers in S/L/E with the drivers downloaded from this post:

http://www.insanelym...howtopic=224063

and now no more black screen. I can see my desktop. My card is working exactly like before 10.6.6 update. But acceleration and resolution change are still not working.
I also added device id in Ati5000controller.kext, but still no acceleration and resolution change.

What else must I do for having acceleration and resolution change?

p.s. during boot in verbose mode (-v), I noticed that at some point it says:

not loaded kext com.apple.Ati5000controller.kext - file not found................

but that file is present in S/L/E

#42
bas123

bas123

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I did it. My screen resolution is good and i can choose other resolutions. I think also that it has QE/CI because there are a lot more visual effects and front row works. I am so happy. I just followed literally the steps.

To boot after the 10.6.6 update, you have to install usbrollback from ##### after you installed the update.

Attached Files



#43
LifeOnRice

LifeOnRice

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts

Iatkos is not vanilla kernel,this topic only for mac os x retail(vanilla kernel),i tried with iatkos v7 and such error you can download kernel vanilla or try remove ati5000controler.kext and boot with -f -v
my vanilla kernel 10.6.0 http://www.mediafire...5kf9dx34yv7jr3a


i checked on OSXtools, its says vanilla kernel..

#44
Jerry_MK2

Jerry_MK2

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

I did it. My screen resolution is good and i can choose other resolutions. I think also that it has QE/CI because there are a lot more visual effects and front row works. I am so happy. I just followed literally the steps.

To boot after the 10.6.6 update, you have to install usbrollback from ##### after you installed the update.


Can you send me the whole root/EXTRA folder and all the ATI Kexts present in your S/L/E folder please?

amiga.x@libero.it

it is also my msn contact.

#45
LifeOnRice

LifeOnRice

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
ill try to do is to remove all ati drivers, with no graphics modding

#46
knoma

knoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
@bas123

please can you write a step by step guide? did you use #####? i would be very happy i can also change my resolution.


greetings

#47
bas123

bas123

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

@bas123

please can you write a step by step guide? did you use #####? i would be very happy i can also change my resolution.


greetings

Here it is.

1. Download the all-in-one from white_apple_x86
2. Install the ati hd 5000 bootloader.
3. Copy the rom from the all-in-one to "your os x drive"/Extra
4. Install the ATY_init.kext and atiframebuffer.kext with kextutility.
5. Reboot
6. Edit your bootplist



<key>Kernel Flags</key>
<string>arch=i386</string
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseAtiROM</key>
<string>Yes</string>
<key>AtiFb</key>
<string>Hoolock</string>
<key>Graphics Mode</key>
<string>1400x1024x32</string> (here you have to fill in your native resolution eg.: 1366x768x32)


7. Reboot
8. Install the 10.6.4 update
9. Reboot
10. Download #####
11. Download the graphicsupdate http://supportdownlo...csUpdate1.0.dmg
12. install the graphics update
13. if kernel panic. Remove atix3000.kext and ati5000.kext
14. download 10.6.6 update, i used combo
14. open the 10.6.6 update but don't press restart
15. install the update(10.6.6) but don't reboot.
16. open ##### when 10.6.6 update is open (if 10.6.6 update installer close, just let it like that)
17. choose drivers/kexts-->miscelancious-->IOUSBRollback and install it.
18. close ##### and reboot
19. everything has to work

#48
Jerry_MK2

Jerry_MK2

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I followed again the guide step by step. After installed mac os x 10.6.6 update and (without rebooting) installed IOUSBRollback, after reboot I have black screen just before entering the desktop.
I think it's not a kernel panic, because I can hear the hard disk continue loading.

How can I fix the black screen problem?

#49
knoma

knoma

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
may me you must delete the x3000 and the ati5000 controller kext. i had the the problem with a black display. aber deleting the files the the graphic output worked.


you do boot from #####? did install fakesmc.kext?

#50
yukistvn

yukistvn

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Sorry For My English BadPosted Image
My graphics card ati radeon hd 5450 working on snow leopard after installed 10.6.6.

And how do make them work

Only For Kernel Vanilla

Waring Backup Your Data
0.Download the all_in_one.rar
1.Install ATI Chameleon bootloader for Radeon HD5000
2.The ROM image under /Extra should be named <vendorid>_<deviceid>.rom(ATI 5450 is 1002_68f9.rom)
3.Install Atiframebuffer.kext and ATY_init.kext to S/L/E (ATI5000Controller don’t need)
4.Edit com.apple.boot.plist

<key>Kernel Flags</key>
<string>arch=i386</string
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseAtiROM</key>
<string>Yes</string>
<key>AtiFb</key>
<string>Hoolock</string>
<key>Graphics Mode</key>
<string>Your Resolutions </string>

ATI 5450 tested Fb working on Uakari,Vervet,Hoolock and other untested.Recommend Hoolock.

5.Install update 10.6.4 reboot and install graphic update 1.0 (if you get kernel panic after installed graphic update 1.0,try boot –x to safe mode and remove all ATIRadeonX3000.kext,I use hfs+ for windows to remove it )(the graphic update 1.0 only for 10.6.4)
6.Open OSX86Tool repair permissons.
7.Install Update 10.6.6 will add ATIRadeonX3000.kext,ATI5000Controller.kext

After reboot will it work,you need to do step by step,If you get any error tell me. :rolleyes:
link download


http://supportdownlo...csUpdate1.0.dmg

ATI 5450 is 68f9
ATY_init.kext not support 5450 so it will display the 5500




QE CI it work

Edit
Sorry I not have time for you,i will help you,if i can
If you your kernel not vanilla you will get KP after install Graphic Update,I tried with legacy kernel and get kp "invalid kernel"


Mach_kernel:http://www.mediafire.com/?5kf9dx34yv7jr3a
New boot loader http://www.kexts.com...0-rc5-r745.html
I tried with chameleon r747 is not success(kp),you can try it.


hi white_apple
i have succesful got my ATI 5450 work, but QL/CI it's not enable , can you help me out!
thanks

#51
LifeOnRice

LifeOnRice

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
Hi, how can i fix the kernel panic after installing Snow Leopard Graphics update? i get a kernel panic and cannot boot from safe mode. thanks white_apple_x86

#52
lilsully4

lilsully4

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Do you think this will work with the 5470?

#53
bas123

bas123

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

may me you must delete the x3000 and the ati5000 controller kext. i had the the problem with a black display. aber deleting the files the the graphic output worked.


you do boot from #####? did install fakesmc.kext?

You have to always delete that kexts

#54
bas123

bas123

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Hi, how can i fix the kernel panic after installing Snow Leopard Graphics update? i get a kernel panic and cannot boot from safe mode. thanks white_apple_x86

You have to boot in windows and use transmac or similar to remove them.

#55
LifeOnRice

LifeOnRice

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts

I followed again the guide step by step. After installed mac os x 10.6.6 update and (without rebooting) installed IOUSBRollback, after reboot I have black screen just before entering the desktop.
I think it's not a kernel panic, because I can hear the hard disk continue loading.

How can I fix the black screen problem?



me too i got a black screen after rebooting can anyone help us? white_apple_x86? bas123?? thanks

#56
rubenmr

rubenmr

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I have a problem.

I installed osx retail 10.6 with EFI Empire.

Install HD500Inject, ati kexts and modify my boot.plist

Updated to 10.6.6

If i load OSX with EFI Empire CD, it loads ok, ATI works perfectly, resolutions QE...

But, when i load without CD, i have this screen, everything loads ok, nothing KP

Posted Image

I have same boot (chameleon v2 rc3 pcefi_10.4), kexts in extra folder & kernel (mach_kernel.test7) than EFI Empire CD.

What can i do???

(Sorry for my english)

#57
taky2008

taky2008

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts
I do All the steps but i sciked update steps cuz i'm allready have 10.6.6 but after all when i restart the screen Doent work only mixed colors with non meaning pla help me am using Hazard 10.6.6

#58
bas123

bas123

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

me too i got a black screen after rebooting can anyone help us? white_apple_x86? bas123?? thanks

I don't know a solution, but what connection do you use. (ge.: hdmi, vga, dvi,...) because i use a laptop and that uses an internal connection. I can't use any screen trough hdmi or vga.

#59
Selby

Selby

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I followed again the guide step by step. After installed mac os x 10.6.6 update and (without rebooting) installed IOUSBRollback, after reboot I have black screen just before entering the desktop.
I think it's not a kernel panic, because I can hear the hard disk continue loading.

How can I fix the black screen problem?


I had the same issue, sounded like the system was still running but nothing was showing on the screen. Solved the problem by simply using the DVI output from my graphics card rather than the vga. Hope this solves the problem for you.

#60
LifeOnRice

LifeOnRice

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
i currently have a VGA(currently using), a DVI, and Display Port? which one would work?

EDIT: i tried DVI, i get a black screen





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy