Jump to content

[Guida] Installazione Snow Leopard retail su Asus P5QD Turbo


  • Please log in to reply
252 replies to this topic

#1
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male

Premessa

Non postate domande banali su problemi elementari che non riguardano la guida.
I suddetti post verranno eliminati senza preavviso.
Per poter installare questa guida senza problemi sono richieste alcune conoscenze-base del mondo Hackintosh.
Quindi, prima di partire, date un'occhiata alle F.A.Q.

Cosa ci occorre

Cosa ci occorre:

Aggiornamenti di Mac OS X combinati:

Installazione

Avviate il PC con il BootCD inserito.
Alla schermata di Chameleon rimuovete il BootCD e inserite il DVD di Snow Leopard; dopo aver atteso alcuni secondi premete F5, spostatevi sull'icona del DVD di SL e premete Invio.
Una volta partito l'installer avviate Utility Disco e, dopo aver selezionato l'HD sul quale volete installare SL, cliccate su Partiziona; create una partizione con Formato Mac OS esteso (Journaled) poi cliccate su Opzioni... e mettete la spunta a Tabella partizione GUID.

Infine cliccate su Applica.
Una volta terminato il processo chiudete Utility Disco e continuate l'installazione, selezionate l'HD appena formattato e proseguite.
Al termine dell'installazione cliccate sul pulsante Riavvia.
Fate nuovamente bootare il PC con il BootCD inserito ma stavolta selezionate come disco di avvio l'HD dove avete appena installato SL.

Post-installazione


  • Installate Chameleon 2 RC5 nell'HD dove avete appena installato SL
  • Sostituite la cartella Extra nella root dell'HD di SL
  • Installate l'Aggiornamento di Mac OS X v10.6.x combinato
  • Installare l'AppleHDADisabler
  • Installate l'AttansicL1eEthernet
  • Installate il VoodooHDA e il VoodooHDA.prefPane
  • Se avete dispositivi IDE-PATA installate anche il JMicronATA e il JMicron36xSATA

Gestione energetica nativa

Con l'avvento delle ultime versioni di Chameleon 2 RC5 non c'è più bisogno di utlizzare kext o modificare il DSDT per ottenere la gestione energetica nativa tramite l'AppleIntelCPUPowerManagement.kext.
Ho già aggiunto al com.apple.boot.plist le due righe che sono necessarie per l'ottenimento della gestione energetica nativa:

<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>


DSDT

Come potete vedere nella cartella Extra sono presenti, oltre al DSDT, alcune tabelle SSDT.
Per la precisione sono 7:

  • SSDT = SSDT(AtherosL1e).aml
  • SSDT-1 = SSDT(DTGP).aml
  • SSDT-2 = SSDT(LPCB).aml
  • SSDT-3 = SSDT(SATA).aml
  • SSDT-4 = SSDT(SBUS).aml
  • SSDT-5 = SSDT(UHCI-EHCI).aml
  • SSDT-6 = SSDT(ViaVT1708S).aml
Queste sono del tutto analoghe a modifiche fatte direttamente al DSDT, ma ho preferito utilizzare queste.

Al momento il sistema è quasi del tutto funzionante.
Dico quasi perché lo sleep e l'ibernazione non funzionano.
Avrei trovato una soluzione che consiste nell'installare lo SleepEnabler.kext, ma per poter usare quest'ultimo, pena kp sull'AppleIntelCPUPowerManagement.kext è necessario utilizzare anche il NullCPUPowerManagement.kext, soluzione a me non gradita :P
Però se preferite...


Per quanto riguarda lo sleep tenete presente che l'autosleep non funziona.
Per ovviare a questo "problema" vi consiglio di dare un'occhiata a questo topic (grazie KWS :P ).
In questo modo avrete l'autosleep perfettamente funzionante. Per me è molto comodo visto che utilizzo questa funzione.

Per quanto riguarda inevce l'ibernazione purtroppo ancora non funziona :angel:
Se si mette in Stop il computer il sistema scrive correttamente la sleep image e poi si spegne.
Il problema è che al successivo boot il Wake kernel non avviene correttamente, infatti l'immagine viene caricata ma dopodiché si ha un kp:

Posted Image

Testate un po' anche voi e fate sapere se avete anche voi kp o no.

Il resto funziona correttamente.

Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

Posted Image

Naturalmente appena ci saranno nuovi aggiornamenti verrete informati.

Stay tuned

Edited by mrmojorisin17, 09 April 2011 - 08:28 PM.


#2
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
Ok sto aggiornando alla 10.6.3, la prima cosa che noto è che è un po' lento nell'aprire l'animazione della cartella applicazioni, come se fosse qualcosa relativo al video.

Comunque allego il mio com.apple.Boot.plist

[codebox]Graphics Mode
1680x1050x32
Kernel
mach_kernel
Kernel Flags
PciRoot
0
Timeout
5[/codebox]

e il SMBios.plist

[codebox]SMbiosversion
IM71.88Z.007A.B03.0803051705
SMfamily
iMac
SMmemmanufacter_4
Kingston
SMmempart_4
SMmemserial_4
SMproductname
iMac7,1[/codebox]

Nel caso ci fossero suggerimenti

Presto uploado il DSDT.

#3
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Come identificativo ti consiglio di usare MacPro:

<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMproductname</key>
<string>MacPro3,1</string>


Per identificare in maniera corretta le RAM, se hai 4 blocchi, con Lizard ne devi aggiungere 4, non uno cliccando su 4, altrimenti è come se avessi solo un blocco di RAM nel modulo 4.


Ok, ho installato l'aggiornamento, tutto ok.

Il nuovo smbios è questo:

SMbiosversion	MP31.88Z.006C.B02.0801021250	SMcputype	1281	SMfamily	Mac Pro	SMmemmanufacter_1	Kingston	SMmemmanufacter_2	Kingston	SMmemmanufacter_3	Kingston	SMmemmanufacter_4	Kingston	SMmempart_1		SMmempart_2		SMmempart_3		SMmempart_4		SMmemserial_1		SMmemserial_2		SMmemserial_3		SMmemserial_4		SMmemspeed	1066	SMmemtype	19	SMproductname	MacPro3,1

qui invece il DSDT: Attached File  dsdt.zip   33.49KB   23 downloads

Ho fatto tutto come descritto nella guida con l'audio ma non va....help me XD

EDIT: Audio andato.

il problema principale rimane il video, e le animazioni lente, come risolvere??

la risoluzione mi risulta 1024x768

#4
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
Tutto ok. Tranne i seguenti problemi:

1. La scheda video va malissimo ho anche aggiunto tramite efi string ma niente, le animazioni sono molto lente (tipo spaces, exposè, la dashboard)

il video risulta sfocato nonostante abbia aumentato la risoluzione, penso dipenda tutto dalla scheda video.

Sembra che il Quartz GL non sia attivo.

2. Gli hdd interni mi vengono visti come esterni

Come risolvere questi due problemi??

#5
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
Risolto per il video, ora la scheda video è stata riconosciuta, anche se come risoluzione non mi permette di mettere una risoluzione massima del mio schermo (1600x900).

Rimangono gli HDD di colore arancione ma alla fine non è un problema così grave :P, sembra tutto funzionante, ora ho fatto da utility disco le altre due partizioni, dovrò gestire tutto da grub speriamo bene :D

EDIT: Risoluzione impostata a 1600x900

#6
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
Troppo bello per essere vero. :)

Windows non si installa in nessuna delle partizioni che ho fatto uff

Qualche guida su un triplo boot ?? non ne trovo molte in giro

#7
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
Alla fine ho risolto con un Dual Boot, grazie alla guida di {censored}: http://www.insanelym...howtopic=203026

Il dsdt l'ho sostituito e funziona alla grande, per ora sembra che sia davvero tutto ok.

Ho solo due domande:

1.Come faccio ad essere sicuro che tutto l'hardware è stato riconosciuto correttamente?? (Quad Core 8gb di ram ecc.)

2.Posso installare tutti gli aggiornamenti da "Aggiornamento Software" di Apple??

Grazie mille in anticipo

#8
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Per l'hardware guarda in System Profiler (clicca sulla mela in alto a sinistra, Informazioni su questo Mac/More Info...).
Per verificare se ti vede tutti i core il numero totale di nuclei deve essere 4.
Hai provato anche Sleep ed Ibernazione? Scarica e installa SmartSleep così puoi settare la modalità di sleep del PC (solo Sleep o solo Ibernazione) per fare le prove:
Attached File  SmartSleep.2.6._929506_.dmg.zip   571.43KB   27 downloads
Verifica anche che funzionino reboot/shutdown dopo la messa in Stop del PC.
Sto ancora lavorando al DSDT, presto avrete buone nuove. :(
Per gli aggiornamenti vai tranquillo, io li ho fatti e non è successo nulla. :)

#9
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Per l'hardware guarda in System Profiler (clicca sulla mela in alto a sinistra, Informazioni su questo Mac/More Info...).
Per verificare se ti vede tutti i core il numero totale di nuclei deve essere 4.
Hai provato anche Sleep ed Ibernazione? Scarica e installa SmartSleep così puoi settare la modalità di sleep del PC (solo Sleep o solo Ibernazione) per fare le prove:
Attached File  SmartSleep.2.6._929506_.dmg.zip   571.43KB   27 downloads
Verifica anche che funzionino reboot/shutdown dopo la messa in Stop del PC.
Sto ancora lavorando al DSDT, presto avrete buone nuove. :(
Per gli aggiornamenti vai tranquillo, io li ho fatti e non è successo nulla. :)


Il numero dei nuclei è 4 ma se clicco su memoria per verificare la ram mi esce scritto che si è verificato un errore.

Sleep ed ibernazione in realtà non li uso XD quindi sto a posto così per ora ihih, mi preoccupa solo il fatto della ram

#10
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Controlla che il sistema sia avviato a 64bit. Vai in System Profiler/Software e controlla la voce: Estensioni e Kernel a 64bit: Sì.
Se avvii a 64bit vedrai che la tua RAM è riconosciuta.
Anche se non li usi mi faresti la cortesia di provarli? Grazie.

#11
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Controlla che il sistema sia avviato a 64bit. Vai in System Profiler/Software e controlla la voce: Estensioni e Kernel a 64bit: Sì.
Se avvii a 64bit vedrai che la tua RAM è riconosciuta.
Anche se non li usi mi faresti la cortesia di provarli? Grazie.


Ok il sistema sembra funzionare a 64bit,
ma c'è un altro problema, ora che ho reinstallato il sistema e copiato il dsdt, risulta tutto un po' "lento", velocità delle pagine internet compresa, coincidenza??

#12
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Il DSDT non credo c'entri nulla.
Casomai prova anche quello "vergine" e confronta.

#13
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Il DSDT non credo c'entri nulla.
Casomai prova anche quello "vergine" e confronta.


Strano, cosa puo' essere??
sembra proprio la velocità del pc che sia calata eppure ho fatto gli stessi procedimenti dell'installazione precedente

#14
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Sei sicuro che sia tutto ok?

#15
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Sei sicuro che sia tutto ok?


Sisi credo di si la scheda video è stata regolarmente ricoosciuta i nuclei sono 4 e la ram anche se non mi da informazioni il sistema parte a 64 bit, ora provo qualche programma più "pesante" tipo photoshop e ti faccio sapere

#16
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Ok. Prova anche Sleep ed Ibernazione please.

#17
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Ok. Prova anche Sleep ed Ibernazione please.


Nada mi sembra più lento rispetto a prima, provo con il vecchio dsdt non si sa mai XD

Sembra un problema video, ora non si vedono più bene i menu quando clicco con il tasto destro

EDIT: I colori sono tutti sfasati un po' ovunque che cavolo succede??

#18
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Ok, prova col vecchio DSDT, se continua a fare così cerchiamo di capire qual è il problema.

#19
.Snake24.

.Snake24.

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male

Ok, prova col vecchio DSDT, se continua a fare così cerchiamo di capire qual è il problema.


Difetti di grafica spariti ma rimane la lentezza, penso sia dovuto alla scheda video, ma non riesco proprio a capire cosa c'è che non va

#20
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Cosa usi per far andare la scheda video? Graphics Enabler nel c.a.B.p.? EFI String? Injector vari?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy