Jump to content

AnVAL (ACPI Loader)


  • Please log in to reply
1537 replies to this topic

#1481
jlvaio

jlvaio

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts
@valv
hello happy good year

many times i asking you to take a look at some vaio info for the strange vaio problem

but now one user find something:

he find how to enable his internal screen but what works in his computer doesn t work perfect for all user now
i ask you because you are develloping chameleon and so you can add option or fix to your version

it seems the vaio problem was due to a non needed display driver and as i see in many osx installer : nvkush nv33 nv42 etc there no option to uninstall this part of device so could explain why display unload at graphics loaded

actually the user who had the display working use chameleon 700 because a certain kind of graphic enabler

so if you can investigate for help vaio user community

i give you the link where user"navid n"find issue
http://www.insanelym...p...8556&st=460

thanks for your help

#1482
dickhouse

dickhouse

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:The Gunners HomeTown
Any plan for HD 6470M andy??

#1483
Goron

Goron

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male
  • Location:somewhere out there ...
Just tested v 5.1.4, bdmesg below ... just one question:


It says, filesize of my NVidia.ROM is too big and therefor it is truncated, what does that mean ??????????


sh-3.2# ./bdmesg
msr(221): ia32_perf_stat 0x06004824
max: 8.5 current: 8.5
CPU: Vendor/Model/ExtModel: 0x756e6547/0x17/0x1
CPU: Family/ExtFamily: 0x6/0x0
CPU: MaxCoef/CurrCoef: 0x8/0x8
CPU: MaxDiv/CurrDiv: 0x1/0x1
CPU: TSCFreq: 3403MHz
CPU: FSBFreq: 400MHz
CPU: CPUFreq: 3403MHz
CPU: NoCores/NoThreads: 4/4
CPU: Features: 0x0000025f
Attempting to read GPT
Read GPT
Reading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93B
Reading GPT partition 2, type 48465300-0000-11AA-AA11-00306543ECAC
Reading GPT partition 3, type 48465300-0000-11AA-AA11-00306543ECAC
Read HFS+ file: [hd(0,1)/Extra/com.apple.Boot.plist] 527 bytes.
Attempting to read GPT
Read GPT
Reading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93B
Reading GPT partition 2, type 48465300-0000-11AA-AA11-00306543ECAC
Failed to find boot signature on BIOS device 82h
Read HFS+ file: [hd(0,2)/Extra/com.apple.Boot.plist] 614 bytes.
Setting boot-uuid to: 51604703-5CD1-360A-ACBC-E2F2D0EC2565
Read HFS+ file: [hd(0,2)/System/Library/CoreServices/SystemVersion.plist] 479 bytes.
Loading Darwin 10.6
Loading kernel mach_kernel
Read HFS+ file: [hd(0,2)/mach_kernel] 4096 bytes.
Read HFS+ file: [hd(0,2)/mach_kernel] 5579907 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/ACPIMonitor.kext/Contents/Info.plist] 2011 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/AD2000b.kext/Contents/Info.plist] 79456 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/AppleYukon2Injector.kext/Contents/Info.plist] 2147 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/DeviceMergeNub.kext/Contents/Info.plist] 2063 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/Info.plist] 3940 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/IntelThermal.kext/Contents/Info.plist] 1501 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/NVClockX.kext/Contents/Info.plist] 1662 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/SuperIOFamily.kext/Contents/Info.plist] 1227 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/JMicronATA.kext/Contents/Info.plist] 2035 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/LegacyJMB36xSATA.kext/Contents/Info.plist] 2373 bytes.
LoadDrivers: Loading from [/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext]
Read HFS+ file: [hd(0,2)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4096 bytes.
Read HFS+ file: [hd(0,2)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4163450 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/ACPIMonitor.kext/Contents/MacOS/ACPIMonitor] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/ACPIMonitor.kext/Contents/MacOS/ACPIMonitor] 34304 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/DeviceMergeNub.kext/Contents/MacOS/DeviceMergeNub] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/DeviceMergeNub.kext/Contents/MacOS/DeviceMergeNub] 38312 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/MacOS/FakeSMC] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/MacOS/FakeSMC] 57416 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/IntelThermal.kext/Contents/MacOS/IntelThermal] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/IntelThermal.kext/Contents/MacOS/IntelThermal] 34184 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/NVClockX.kext/Contents/MacOS/NVClockX] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/NVClockX.kext/Contents/MacOS/NVClockX] 105864 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/SuperIOFamily.kext/Contents/MacOS/SuperIOFamily] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/FakeSMC.kext/Contents/PlugIns/SuperIOFamily.kext/Contents/MacOS/SuperIOFamily] 37160 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/JMicronATA.kext/Contents/MacOS/JMicronATA] 4096 bytes.
Read HFS+ file: [hd(0,2)/Extra/Extensions/JMicronATA.kext/Contents/MacOS/JMicronATA] 87632 bytes.
Read HFS+ file: [hd(0,2)/Extra/DSDT.aml] 37563 bytes.
Using PCI-Root-UID value: 0
nVidia GeForce 9800 GT 512MB NV92 [10de:0614] :: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)
Looking for nvidia video bios file /Extra/10de_0614.rom
Read HFS+ file: [hd(0,2)/Extra/10de_0614.rom] 126464 bytes.
Filesize of /Extra/10de_0614.rom is bigger than expected! Truncating to 0x10000 Bytes!
Using nVidia Video BIOS File /Extra/10de_0614.rom (65536 Bytes)
LAN Controller [11ab:4364] :: PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)
Setting up lan keys
Read HFS+ file: [hd(0,2)/Extra/SMBIOS.plist] 846 bytes.
Intel P35/G33 DRAM Controller [8086:29c0] at 00:00.0
Frequency detected: 400 MHz (800) Dual Channel
CAS:5 tRC:5 tRP:5 RAS:18 (5-5-5-18)
Slot: 0 Type 19 2048MB (DDR2 SDRAM) 800MHz Vendor=AENEON
PartNo=AET860UD00-25DC08X SerialNo=580125A2
Slot: 1 Type 19 2048MB (DDR2 SDRAM) 800MHz Vendor=AENEON
PartNo=AET860UD00-25DC07X SerialNo=320106B8
Slot: 2 Type 19 2048MB (DDR2 SDRAM) 800MHz Vendor=Team Group
PartNo=Team-Value-800 SerialNo=00000000
CPU is Intel® Core™2 Quad CPU Q9550 @ 2.83GHz, family 0x6, model 0x17
Patched DMI Table
Found SMBIOS System Information Table 1
Customizing SystemID with : 2059001e-8c00-0101-8239-001e8cb51709
Read HFS+ file: [hd(0,2)/Extra/DSDT.aml] 37563 bytes.
ACPI table not found: SSDT.aml
FADT: Restart Fix applied!
FADT: Using custom DSDT!
FADT: Restart Fix applied!
FADT: Using custom DSDT!
Starting Darwin x86_64

#1484
r0ck3r4ever

r0ck3r4ever

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Gender:Male
Hello,

For those who have the same problem like me with using this bootloader, Os X hanging right before initializing the desktop (in my situation using ati hd 4870), try the following.

Download the latest source code from valv's branch, also download the latest source code from trunk or any other branch with working ati injection. Then copy the files ati.c, ati.h , device_inject.c, device_inject.h located in "i386/libsaio" from trunk or other branch, in valv's source code in the same folder (replace the files).

After that, build the bootloader using these simple commands from Terminal

cd /path_to_valv_code/
make "embedtheme"

and then copy the boot file from sym/i386 folder to / in your file system .

The reason that this works is because in one of those files that I replaced must be a bug. It might also work for other users with nvidia cards who might experience the same problem.

I just used my intuition for this.
I have to mention that I am not a C developer although I learned C in school.

I tried this with the latest revisions and now my system works perfectly. I use this because it has auto resolution and also it enables me to use native power management.

Thank you Valv for your effort, and I hope you will fix this small issue soon.

I will attach my boot file tomorrow for those who want to skip the process.

Update: I uploaded my boot file.

Attached Files

  • Attached File  boot.zip   211.95KB   35 downloads


#1485
Justin6920G

Justin6920G

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
I will be trying this on my AMD build, I will let you know how it goes. Hopefully it'll get rid of my boot CD dependancy ;)

#1486
-ZeR0-

-ZeR0-

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Well, everything works now exept the Graphics.
I was using kaybl's boot file before, and i ever got fan at 100% and a blackscreen.
Now it is exactly the same, and if i use GraphicsEnabler=no , it loads up normally and everything, but i just see the apple logo and a spinning cycle, if i use vebose mode it stops there where normally the screen should appear.
If i press enter i get that error sound like normal.
So it seems to load everything but just the gfx wont display the gui and desktop.
GFX: Radeon XFX HD 5870
My other specs: http://www.mein-pc.e...Bumblebee-/8264

#1487
JBraddock

JBraddock

    Ph.D (Can) in Human Rights

  • Members
  • PipPipPipPipPipPipPip
  • 549 posts
  • Location:UK
@Valv, I believe there is a bug in AnVaL which prevents OSX resuming from hibernate and puts it into sleep again while it tries to wake up.

I found in HP Mini topic that they had the same problem, which had been solved by rev 653 of Meklort branch.
Can anyone else confirm this behaviour
?

Edit: Silly me. I forgot that I had removed Wake=Yes from my boot.plist!

#1488
r0ck3r4ever

r0ck3r4ever

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Gender:Male

Well, everything works now exept the Graphics.
I was using kaybl's boot file before, and i ever got fan at 100% and a blackscreen.
Now it is exactly the same, and if i use GraphicsEnabler=no , it loads up normally and everything, but i just see the apple logo and a spinning cycle, if i use vebose mode it stops there where normally the screen should appear.
If i press enter i get that error sound like normal.
So it seems to load everything but just the gfx wont display the gui and desktop.
GFX: Radeon XFX HD 5870
My other specs: http://www.mein-pc.e...Bumblebee-/8264


Use my boot file, it might work for you. I had the same behavior and I decided to do a custom build for myself.

#1489
-ZeR0-

-ZeR0-

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Use my boot file, it might work for you. I had the same behavior and I decided to do a custom build for myself.

Well how can i do this if i'm only on my Windows with HFS+ because i can't boot in SL?

#1490
r0ck3r4ever

r0ck3r4ever

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
  • Gender:Male

Well how can i do this if i'm only on my Windows with HFS+ because i can't boot in SL?


You can use MacDrive. It is commercial software but it works grate.

Place the boot file on the root of your partition (the SL partition) after you install MacDrive (it will install the HFS+ driver for Windows).

#1491
-ZeR0-

-ZeR0-

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Well i'v done that but i see no changes... Still the same.
Do you use some kext's like atiframebuffer or aty_init or so?

#1492
-ZeR0-

-ZeR0-

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
It does not work on my XFX HD 5870.
When i use GraphicsEnabler=yes i get a "no signal" screen on my monitor and the fan goes to 100%.
When i set it to no, and using vebose mode, it loads till Device in Slot 1
And then it hangs (fails at initializing ?) i can press etject, what works i can go in sleep and up again but i still see the same text.
Using Snow Leopard 10.6.5 64-Bit on this PC:
http://www.mein-pc.e...Bumblebee-/8264

#1493
Funky frank

Funky frank

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 325 posts
Hello,

can someone explain to me please how I install Chameleon on a NTFS partition with Windows XP on it?
I know that there is "boot.sys" for that - or not? There is a way to load a boot.iso of chameleon on a ntfs drive.

Please! I cannot refind the info about it.


EDIT: Found bootemu. How can I create now a working bootemu iso of anval?

#1494
dickhouse

dickhouse

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:The Gunners HomeTown
any good news regarding fb or kexts for ATI 6xxx series.. Apple has released new macbook pro with mobility 6470 + 6750.

#1495
Time2Retire

Time2Retire

    Retired

  • Retired Developers
  • 1,012 posts
  • Gender:Female
  • Location:anonymouse.eu
@valv: Hi valv,
I think to have found a solution for the per-core-read problem of TM1. Apparently you need to use leaf b (Function 0Bh) and use the ID to get to a target core, thread or package (depending the arguments).

See also: 241618.pdf chapter 5.1.12

When EAX is initialized to a value of 0Bh, the CPUID instruction returns core/logical processor topology information in EAX, EBX, ECX, and EDX registers. This function requires ECX be initialized with an index which indicates which core or logical processor level to return information about. The BIOS or OS is expected to call this function (CPUID.EAX=0Bh) with ECX = 0 (Thread), 1 (Core), 2..n (Package), until EAX=0 and EBX=0, indicating no more levels. The order in which the processor topology levels are returned is specific since each level reports some cumulative data and thus some information is dependent on information retrieved from a previous level.


and:

BIOS is expected to iterate through the core / logical processor hierarchy using CPUID Function Bh with ECX using input values from 0-N. In turn, the CPUID function Bh provides topology information in terms of levels. Level 0 is lowest level (reserved for thread), level 1 is core, and the last level is package. All logical processors with same topology ID map to same core/package at this level.
BIOS enumeration occurs via iterative CPUID calls with input of level numbers in ECX starting from 0 and incrementing by 1. BIOS should continue until EAX = EBX = 0 returned indicating no more levels are available (refer to Table 5-17). CPUID Function Bh with ECX=0 provides topology information for the thread level (refer to Table 5-15). And CPUID Function Bh with ECX=1 provides topology information for the Core level (refer to Table 5-16). Note that at each level, all logical processors with same topology ID map to same core or package which is specified for that level.

Hope this helps my friend :rolleyes:

#1496
onosan

onosan

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Location:Denmark
Obviously quite noob'ish but here goes:

When trying to follow the 'manual installation procedure' i'm stalled almost instantly :(

- Have hooked up my SSD HD via usb on my macbook
- Installed SL from dvd
- diskutil list gives
Attached File  diskutil.jpg   51.26KB   34 downloads

BM:~ bme$ sudo -s
Password:
bash-3.2# newfs_hfs -v EFI /dev/disk1s1
Initialized /dev/rdisk1s1 as a 200 MB HFS Plus volume
bash-3.2# fdisk -f boot0hfs -u -y /dev/rdisk1
fdisk: could not open MBR file boot0hfs: No such file or directory


Should I just continue with the following instructions or what am I doing wrong?

#1497
wastez

wastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
  • Gender:Male

Obviously quite noob'ish but here goes:

When trying to follow the 'manual installation procedure' i'm stalled almost instantly ;)

- Have hooked up my SSD HD via usb on my macbook
- Installed SL from dvd
- diskutil list gives
Attached File  diskutil.jpg   51.26KB   34 downloads

BM:~ bme$ sudo -s
Password:
bash-3.2# newfs_hfs -v EFI /dev/disk1s1
Initialized /dev/rdisk1s1 as a 200 MB HFS Plus volume
bash-3.2# fdisk -f boot0hfs -u -y /dev/rdisk1
fdisk: could not open MBR file boot0hfs: No such file or directory


Should I just continue with the following instructions or what am I doing wrong?


Have you changed into the right folder where the boot0 file is, because you have to do this before you enter the command?!


Greetz

#1498
onosan

onosan

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Location:Denmark
Ah - I thougth I had ;)

After moving into the anval5 folder I can now continue until i am stalled again:


bash-3.2# pwd
/Users/bme
bash-3.2# cd anval5
bash-3.2# fdisk -f boot0hfs -u -y /dev/rdisk1
bash-3.2# dd if=boot1h of=/dev/rdisk1s1
2+0 records in
2+0 records out
1024 bytes transferred in 0.001016 secs (1007972 bytes/sec)
bash-3.2# mkdir /Volumes/EFI
bash-3.2# mount_hfs /dev/disk1s1 /Volumes/EFI
bash-3.2# cp boot /Volumes/EFI
bash-3.2# fdisk -e /dev/rdisk1
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
Enter 'help' for information
fdisk: 1>

#1499
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
Onosan,
the message
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
can be safely ignored, just keep on with the rest of the commands ;)
This prompt
fdisk: 1>
is waiting for you to set the active partition.

#1500
onosan

onosan

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Location:Denmark
thanks Azimutz!

Extremely glad someone are willing to offer some handheld help 8^)
Ok - when continuing I'm asked:


fdisk: 1> p
Disk: /dev/rdisk1 geometry: 9729/255/63 [156301488 sectors]
Offset: 0 Signature: 0xAA55
Starting Ending
#: id cyl hd sec - cyl hd sec [ start - size]
------------------------------------------------------------------------
1: EE 1023 254 63 - 1023 254 63 [ 1 - 156301487] <Unknown ID>
2: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
3: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
fdisk: 1> f 1
Partition 1 marked active.
fdisk:*1> w
Device could not be accessed exclusively.
A reboot will be needed for changes to take effect. OK? [n]

Is it a full reboot of my macbook n' all or ...?!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy