Jump to content

[Update-Guide] ATI Mobility Radeon X1350 totally WORKS


  • Please log in to reply
21 replies to this topic

#1
super_engine

super_engine

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 191 posts
***Update***01-nov-2009**************************
Attach ATITadeonX1000.kext and RadeonHD.kext for X1350
************************************************

Hi to all
Finally, after months and months, i have on my laptop HP 6820s the ATI Mobility Radeon X1350 (Dev 7196) TOTALLY working with:

1.Full Resolution (1440x900)
2.QE/CI Enabled

Why this

1. After a hard job our big DONG has compiled an ATI Framebuffer that enable LVDS connector on laptop LCDs. Attached at this topic there is the new RadeonHD kext. In the info.plist you must only put your EDID information. It works very fine
2. Attach also ATIRadeonX1000.kext customitized for dev 7196

3. Attach also Voodoo kernel (last version). RadeonHD.kext is more stable with this kernel.

How install
To install RadeonHD.kext and ATIRadeonX1000.kext use kexthelper
To install the Voodoo kernel:
Open Terminal
type "sudo -s" and insert your password
Go to root directory "cd .." many times
type "cp mach_kernel mach_kernel_OLD" make a copy of old kernel
type "rm mach_kernel" delete old kernel
type "cp (position of voodoo kernel) mach_kernel" copy voodoo kernel in the root
type "reboot"

At the reboot press F8 and at the prompt type "-v -f"
Now you have full resolution and QE/CI enabled

For more details on the Dong'd RadeonHD framebuffer look at ATIFramebuffer section of this forum

Good Luck

http://*apidshare.co...Kernel.zip.html

Attached Files



#2
AsteriXOnline

AsteriXOnline

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Worked on 10.5 but i can't find my edid info. I have a 6820s hp notebook. Can you post your radeon HD with your edid info ?? or tell me how to put my own edid info in the plist.

#3
super_engine

super_engine

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 191 posts

Use readEDID under winzoz



#4
gigioz79

gigioz79

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Great news!
I never abandoned the hope to install leopard on my hp 6820s!

Just few questions:

1) which version of leopard have you installed?
2) *APIDSHARE is no longer avaible, how can I obtain the files?
3) Have you installed successifully all the rest of components (SOUND-WIFI) ?

Thankyou very much!

#5
super_engine

super_engine

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 191 posts
Hi Gigio (also you italian ???)
I have attached the working files (atiradeonx1000.kext foe enable ci/qe and radeonhd.kext for full resolution). Install the two kext with kexthelper and reboot with -v -f flags

Use voodooHDA for very good audio working
Buy a USB-WiFi (i have DLink DWL-G122 - 18 Euros)

Good Luck

#6
gigioz79

gigioz79

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Yes I'm italian too (Florence)!
Tonight I'll make some tries with my notebook...
Just a question, which version of leopard have you used?

Thank you very much!

Ps. some days ago I wrote to you a PM.

#7
nubz69

nubz69

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
You don't need usb-wifi adaptor. I have wifi working, it's a broadcom.

#8
corsairrowell

corsairrowell

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
I have been trying to use this guide to get my mobility x1300 working, but it's only been partially successful. As with others, I have had the problem of only the center of the screen on my Dell Inspiron 6400 having any display. I installed this kext set, and while it does fill the entire screen, the display is mostly black with multicolored artifacts and lines where windows are, and white bars where the menu bar and dock are (See pic, sorry, crappy phone pic)). I can boot with the -x flag, but the display is once again 1024x768 and oesn't fill whole screen. Removing the kexts allows me to boot regularly again. What is going on?

I have added my EDID info to the ATIRadeonX1000.kext, but do I add it to the RadeonHD.kext? If so, where?

Thanks! I've been searching all over for a solution to this.

Attached Files



#9
corsairrowell

corsairrowell

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Anyone?

#10
super_engine

super_engine

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 191 posts

Anyone?


hi
i'm here to help you.
i think that can be a good idea install one kext for time.
1. install ATIRadeonX1000.kext. in this kext you must only input your DeviceID (delete my 7196 and write your ID) in info.plist and in hex file. If you haven't experience about this give me your DeviceID so i'll edit your good kext. this kext allows you ti have graphics acceleration.
2. install RadeonHD.kext. Here you must put your EDID info in info.plist file. Also here if you haven't experience give me your EDID data.

Good luck

#11
ss_insaneguy

ss_insaneguy

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
  • Gender:Male
Hey all,

I created a guide over here (http://www.insanelym...howtopic=196083) for the x1400 card. They should be very similar except for a few specifics related to the x1350. It might be helpful to those looking to get it working.

Thanks.

#12
super_engine

super_engine

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 191 posts

Hey all,

I created a guide over here (http://www.insanelym...howtopic=196083) for the x1400 card. They should be very similar except for a few specifics related to the x1350. It might be helpful to those looking to get it working.

Thanks.


I've read your guide. Very good job for all X1300-X1550 series (mobility and no). That guide is a "reference guide" for all peoples that want test our Graphics Card under OSX86 world.


The problem is that some peoples want a "perfect customized guide" for their machines. And this is very difficultous in the "open world of osx86".

Thanks for your big and deep cooperation in the X1300-X1550 series under OSX86

A last question

Any news for our cards under SL ?. there is a hope to have graphics acceleration under SL?

#13
corsairrowell

corsairrowell

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

hi
i'm here to help you.
i think that can be a good idea install one kext for time.
1. install ATIRadeonX1000.kext. in this kext you must only input your DeviceID (delete my 7196 and write your ID) in info.plist and in hex file. If you haven't experience about this give me your DeviceID so i'll edit your good kext. this kext allows you ti have graphics acceleration.
2. install RadeonHD.kext. Here you must put your EDID info in info.plist file. Also here if you haven't experience give me your EDID data.

Good luck


Hello super_engine! Sorry for delay in response, things have been incredibly busy.

It would be great if you could customize a kext for me! i'd be really thankful!

My device id is 7149.

My EDID is (I think):

00FFFFFF FFFFFF00 44934C00 00000000 000F0103 80211578 0A479994 574F8C27 27505400 00000101 01010101 01010101 01010101 0101CB1B 00A05020 17303020 26004BCF 10000018 0000000F 0008002A 00010004 00324A04 14000000 00FE0059 43343734 00000000 00000000 000000FE 00404C58 6080B4E0 FF01010A 20200047

EDID collected from windows using softMCS.

Thanks again! Hope you can help me, happy new year!

#14
corsairrowell

corsairrowell

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
I had some time on my hands and injected my EDID into RadeonHD.kext, and I got full resolution (1280*800) after a restart. Cool, half done!

Now I have been trying to use ATIRadeonX1000.kext, but ever after putting in my device ids I get a kernel panic when booting normally, but interestingly no kernel panic when booted with the -v flag, although the video is like the photo I posted in an earlier post in this thread. Lots of artifacts, with a black screen, ie completely unusable.

So, halfway done. Maybe I am entering the device ID wrong? I entered it as 0x71491002.

Thanks for the help!

#15
corsairrowell

corsairrowell

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Another update on my situation....

I tried installing an unmodified version of ATIRadeonx1000.kext, and interestingly this fixed the kernel panic issue, but did not enable QE/CI. That is the only issue that needs fixing now, resolution is fixed.

I read somewhere that you have add your device ID to both the Info.plist file in ATIRadeonX1000.kext AND to a hex file in the kext. I have no idea what file is the hex file, and no idea how to edit it. I have a feeling editing it and adding my device ID to Info.plist will fix my problems.

It would be awesome if someone could tell me how to do this. No guides I've read actually explain how to do this, they just assume the user has already learned how. :huh:

Thanks!

Edit: I figured out how to add my device ID to the hex file and to the info.plist file, but now the computer just hangs on boot at the apple logo after it switches to full resolution. I can still boot into safe mode. Hmmm....

#16
stefanello

stefanello

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts

hi
i'm here to help you.
i think that can be a good idea install one kext for time.
1. install ATIRadeonX1000.kext. in this kext you must only input your DeviceID (delete my 7196 and write your ID) in info.plist and in hex file. If you haven't experience about this give me your DeviceID so i'll edit your good kext. this kext allows you ti have graphics acceleration.
2. install RadeonHD.kext. Here you must put your EDID info in info.plist file. Also here if you haven't experience give me your EDID data.

Good luck


Hi, I can mod RadeonHD.kext, but no luck with ATIRadeonX1000.kext, particularly in hex file modding! Can someone help me?

#17
XEOST

XEOST

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I just tried on a 10.6.3 on my 6820s, it does not work. It gives me a black screen with a white cube on the top left and I see the mouse when I move.

Super_engine did you try on a SL ? :rolleyes:

EDIT : RadeonHD.kext work well !!! So no QE/CI.....

#18
XEOST

XEOST

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I found these kexts. works perfectly on my 6820s with X1350 7196.
Kexts ATI x1350 7196 for 10.6.x
:angel:

#19
stefanello

stefanello

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts

***Update***01-nov-2009**************************
Attach ATITadeonX1000.kext and RadeonHD.kext for X1350
************************************************

Hi to all
Finally, after months and months, i have on my laptop HP 6820s the ATI Mobility Radeon X1350 (Dev 7196) TOTALLY working with:

1.Full Resolution (1440x900)
2.QE/CI Enabled

Why this

1. After a hard job our big DONG has compiled an ATI Framebuffer that enable LVDS connector on laptop LCDs. Attached at this topic there is the new RadeonHD kext. In the info.plist you must only put your EDID information. It works very fine
2. Attach also ATIRadeonX1000.kext customitized for dev 7196

3. Attach also Voodoo kernel (last version). RadeonHD.kext is more stable with this kernel.

How install
To install RadeonHD.kext and ATIRadeonX1000.kext use kexthelper
To install the Voodoo kernel:
Open Terminal
type "sudo -s" and insert your password
Go to root directory "cd .." many times
type "cp mach_kernel mach_kernel_OLD" make a copy of old kernel
type "rm mach_kernel" delete old kernel
type "cp (position of voodoo kernel) mach_kernel" copy voodoo kernel in the root
type "reboot"

At the reboot press F8 and at the prompt type "-v -f"
Now you have full resolution and QE/CI enabled

For more details on the Dong'd RadeonHD framebuffer look at ATIFramebuffer section of this forum

Good Luck

http://*apidshare.co...Kernel.zip.html


installd the RadeonHD.kext and everything's fine.. when i try the ATIRadeonX1000.kext i can get the qe\qi but with some glitches.. how can i solve?

#20
stefanello

stefanello

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
help me!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy