Jump to content

SOLVED:X4500 Mouse artifact with Native Resolution


  • Please log in to reply
125 replies to this topic

#21
viccer

viccer

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
"Many thanks for your help! I will try this. :) "


Hi ahhkolaa,

Works for me :wacko: , video has 1440x900 and software mouse pointer after applying your dsdt. By the way, one more prob.. I got horizontal stripes. Any solution with this?

Guys, if you already solved stripes, please post your kexts.


Thanks!

Viccer
dell e6400
video: x4500 MHD 2a42

#22
Hav0c

Hav0c

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

here is the file:

Although I didn´t try to install the driver without the dsdt.aml file the driver (and this file) work great on my Dell 1545. I also managed to get Quartz GL working with the driver.

#23
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

"Many thanks for your help! I will try this. ;) "


Hi ahhkolaa,

Works for me :angel: , video has 1440x900 and software mouse pointer after applying your dsdt. By the way, one more prob.. I got horizontal stripes. Any solution with this?

Guys, if you already solved stripes, please post your kexts.


Thanks!

Viccer
dell e6400
video: x4500 MHD 2a42


Please post all relevant kext and files and how to use it.
I also have Dell E6400 and crave for a 1440x900 native resolution.

Thanks

#24
myska

myska

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Female

Please post all relevant kext and files and how to use it.
I also have Dell E6400 and crave for a 1440x900 native resolution.

Thanks


I justinstalled AppleIntelGMAX3100FB_softcursor_sleep.kext via kexthelper and then copy the ahhkolaa's dsdt onto the root of my mac drive. But we don't have the same laptop, mine is an Inspiron 1545.

#25
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

I just�installed AppleIntelGMAX3100FB_softcursor_sleep.kext via kexthelper and then copy the ahhkolaa's dsdt onto the root of my mac drive. But we don't have the same laptop, mine is an Inspiron 1545.


Thanks I was talking to viccer, he has Dell E6400.
I'm using the dsdt.aml file that was posted here with the patched IntelAppleGMAX3100FB.kext file.
I installed the kext using kext helper but noticed that the kext was not loaded by mac os x.
it was not listed in the kextstat list.

EDIT: I restored the original 3100 kext files and this is the errors I'm getting in /var/log/system

1)error mapping module file /System/Library/Extensions/AppleIntelGMAX3100.kext/Contents/MacOS/AppleIntelGMAX3100
2)cant map module files
3)internal error getMacClasGraph found no classes.
4)cant check load addresses of module

How do I resolve this?
Thanks

#26
shimodo

shimodo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
It worked and was I think I was in native reso of 1280x800 but there is no LCD backlight.

How can I fix that?

Running on eMachines E725
Intel GMA x4500 2A42

#27
viccer

viccer

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Please post all relevant kext and files and how to use it.
I also have Dell E6400 and crave for a 1440x900 native resolution.

Thanks


Hi embedded,

Got chameleon 2.0 rc3 bootloader to load dsdt.

1. You need DSDT.AML of ahhkolaa can be found at Post #12 of this thread. Put this on your root /.
2. Jasim's kext named AppleIntelGMAX3100FB_softcursor_sleep.kext.zip on Post #1. Install this via kexthelper.
3. Make sure you remove all non-working kexts(i mean rm -rf /System/Library/2a42* if you tried Tennieke way in Genius bar) and do this "rm -rf /System/Library/Extentions.mkext" to flush the driver cache.
4. Restart.
5. Boot with -v -f flags.


I suspect you need chameleon 2 rc3 bootloader for the native reso to work. Before it's not working with me until I tried dsdt mentioned above.

Works flawlessly on external monitor without stripes.. my main laptop monitor still has vertical stripes.

Let me know your results.

dell e6400
4500mhd 2a42

#28
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Hi embedded,

Got chameleon 2.0 rc3 bootloader to load dsdt.

1. You need DSDT.AML of ahhkolaa can be found at Post #12 of this thread. Put this on your root /.
2. Jasim's kext named AppleIntelGMAX3100FB_softcursor_sleep.kext.zip on Post #1. Install this via kexthelper.
3. Make sure you remove all non-working kexts(i mean rm -rf /System/Library/2a42* if you tried Tennieke way in Genius bar) and do this "rm -rf /System/Library/Extentions.mkext" to flush the driver cache.
4. Restart.
5. Boot with -v -f flags.


I suspect you need chameleon 2 rc3 bootloader for the native reso to work. Before it's not working with me until I tried dsdt mentioned above.

Works flawlessly on external monitor without stripes.. my main laptop monitor still has vertical stripes.

Let me know your results.

dell e6400
4500mhd 2a42


Thanks for your replay.
the dsdt.aml file was loaded with chameleon rc2, so I guess rc2 will do the job.

could you please upload all of your GMAX3100 files so I could use them?
I mean the GMAX3100 , GMAX3100FB and the driver and bundle files.

From some reason my original GMAX3100 kext was not loaded due to errors.
I suspect that I'm not using the original kexts.

I think using your GMAX3100 kext and relevant files will finally solve my native resolution issue.

Thanks

#29
viccer

viccer

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Thanks for your replay.
the dsdt.aml file was loaded with chameleon rc2, so I guess rc2 will do the job.

could you please upload all of your GMAX3100 files so I could use them?
I mean the GMAX3100 , GMAX3100FB and the driver and bundle files.

From some reason my original GMAX3100 kext was not loaded due to errors.
I suspect that I'm not using the original kexts.

I think using your GMAX3100 kext and relevant files will finally solve my native resolution issue.

Thanks



Here is stock 10.5.7 GMAX3100 kexts.

#30
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Here is stock 10.5.7 GMAX3100 kexts.


Thanks, I'll start the process all over again.
Hopefully I'll get 1440x900 resolution. ;)

#31
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Thanks, I'll start the process all over again.
Hopefully I'll get 1440x900 resolution. :unsure:


I've restored all of my 3100 files using your original 3100 files.
I installed the modified 3100Fb using KextHelper and I got this line in the system.log

Cannot resolve dependencies for appleIntelGMAX3100.kext

and no GMAX3100 nor GMAX3100FB were loaded.

EDIT: I've changed some kext version to match the version I'm using in AppleIntelGMAX3100.kext/Content/Info.plist
and now the GMAX3100 was loaded.

Should the GMAX3100FB kext be loaded?
Right now I didn't see it in kextstat.
I've noticed that the dependencies kext versions are different from the version I'm using, should I change it to the correct versions?

I'm using Mac os x 10.5.7 Vanilla.
Viccer what version are you using?

Thanks

#32
near46

near46

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts
i am new to hackintosh but i am going to try this also :unsure:

#33
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

i am new to hackintosh but i am going to try this also :D


Has someone managed to get 1440x900 resolution on Dell E6400 running on mac os x 10.5.7 vanilla?
I've been trying all kext and nothing did the trick.

The AppleIntelGMAX3100FB does not want to be loaded!
All I need is native resolution.

Thanks

#34
paintitblack

paintitblack

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Native resolution here on Toshiba Satellite with 4500. Waiting for QE/CI and don't mind helping develop, I have no programming skills but I would still do what I can. Thanks for the kext!!

#35
kushalgrover

kushalgrover

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
it is not working on my inspiron 1545. for some reason screen goes black even after doing -f -v at the boot prompt have tried and reinstalled kalyway without any VGA drivers selected.

PLEASE HELP

#36
shimodo

shimodo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
when will officially support this card?

#37
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Is there a solution to the vertical stripes?

thanks

#38
Hoang Kien

Hoang Kien

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Thanks so much.
My Lenovo Y430 work perfectly :)

#39
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

Thanks so much.
My Lenovo Y430 work perfectly :(


does anyone know how to overcome the blue screen issue?
I'm using the modified DSDT.aml that was posted here and the 2A42..FB.kext.

thanks

#40
taaeb

taaeb

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Cairo, Egypt
  • Interests:Artist
Thanks Jasim.
I have Lenovo N 500, working good.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy