Jump to content

ep43-ds3l-problème ACPI_SMC_PlatformPlugin

- - - - -

  • Please log in to reply
11 replies to this topic

#1
berserk99

berserk99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Bonjour à tous,

Je bloque complétement sur l'installation de snow leopard, depuis plusieurs jours et je commence à désespérer... :)

J'ai essayé presque tous les tutoriaux que j'ai trouvé sur le net, mais j'arrive toujours au même résultat. Quand je lance l'install avec chameleon l'écran gris avec la pomme apparait, la "roue" de chargement tourne pendant une trentaine de secondes et puis plus rien, tout se bloque.

En mode verbose je vois que c'est l' ACPI_SMC_PlatformPlugin qui bloque

quand je met le NullCPUPowerManagement.kext

j'obtiens le message :

ACPI_SMC_PlatformPlugin::start-waitForService ressourcematching (AppleINtelCPUpowerManagement) timed out




et quand je l'enlève j'ai :

ACPI_SMC_PlatformPlugin:pushCPU_CSTdata_CSTevaluation failed








Est-ce que quelqu'un saurai d'où peut venir le problème ?

merci d'avance pour vos réponses




ma config tourne très bien sous leopard 10.5.4

gigabyte ep43 ds3l

core2duo 8400

4gb ram crucial 

ati x1900

#2
menardorama

menardorama

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Salut
J'ai une ep45-ds3lr (presque la meme avec le RAID en plus).

Voici comment j'ai fait :
* Depuis un Windows, j'ai fait un dsdt pour la carte reseau la mobo mais pas la CG. + Fix CMOS Reset (tu trouvera facilement dans le forum anglais)
* Depuis un Leopard : Install Snow (mais pas par l'installer direct, il faut aller /System/Instal..../OSIntall.mpkg)
* Install EFI 10.1 avec tous les kexts necessaires
* Reboot, si tu as plusieurs disques sata, met ton dd de snow tou seul sur le port sata 0
* Au niveau de Chameleon boot en -x32 -v -f (noyau 32 bits en verbose sans les extensions).
* Termine ton install tu devrais pas avoir de problème.
* Telecharge Kext util, il va te corriger tous tes problèmes de droits et reconstruire ton cache (j'avais des kernel panic tout le temps avant de trouver ça).

Si ça t'interesse je peux essayer de t'uploader mon dsdt.aml pour l'ep45-ds3lr ça doit être presque la meme chose

Pour le son, je suis passé par un injecteur trouvé sur darwinx86.

Mais pense à toujours repasser un coup de kext util apres un rajout de kext.

Bon courage

#3
Kangaroos

Kangaroos

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 185 posts
  • Gender:Male
  • Location:France
Bonjour, malgrè tout met problème l'install marche bien.

Donc depuis mon leopard qui marche j'ai sur une second disque créé une partion source de 8Go et une partition d'install.
Faire une copie du dvd de SL sur la partition de 8Go grace à l'utilitaire disque.
Faire une clé USB avec un chameleon, les kexts additionnel dans Extra, en option le dsdt.aml si tu en a un.
Booter avec la clé USB, se positionner avec les flèches droites ou gauche sur la partition de 8Go qui possède les sources d'install et booter sur cette partition avec les options -v -x32
L'install se déroule normalement sur une partition vierge ou en upgrade (j'ai mis à jour mon leopard en SL sans problème).
Au premier boot booter sur le SL installé grace à la clé usb
Installer le boot loader qui va bien, customiser le répertoire /Extra, etc (de la même manière que lors de la création de la clé usb).
Rebooter ensuite sur le disque, normalement tout marche. Essayer le boot en 32bits (-x32 comme option) et en 64bits (pas d'option, c'est le mode par défaut de SL).

A noter que j'ai fait ça avec chameleon RC1 + fichier de boot modifier par netkas, normalement le chameleon RC3 doit fonctionner nativement et peut être même booter sur le dvd, au quel cas plus de besoin de partition temporaire avec les sources d'install. Par contre je te conseil quand même de passer par un boot temporaire par clé usb, ça te permet de faire des test de bon fonctionnement de ton /Extra, du com.apple.boot.plist et de ton dsdt.aml avant le passer en définitif sur le disque.

Bon courage.

#4
berserk99

berserk99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
 Merci pour vos réponses, mais j'ai déjà essayé ces méthodes sans succès...

Par contre je crois savoir d'où viens le problème. Quand je lance le boot en mode verbose, je vois




ACPI_SMC_PlatformPlugin: push CPU_CST Pata CST evalution failed




et après plus rien, tout se bloque...

J'ai cherché sur le forum, mais j'ai troujours pas trouvé la solution.

#5
Kangaroos

Kangaroos

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 185 posts
  • Gender:Male
  • Location:France
Que dispose tu comme kext dans ton /Extra de boot ?

Il te fait imperativement faksmc.kext sinon il cherche la puce smc hardware doit se trouver sur ta carte mère "Apple" :) mais manque de chance il ne la trouve pas ^^

Idem il te faut NullCPUPowerManagement.kext dans ton extra.

Mon install fonctionne désormais correctement je vais donc faire un post la dessus dans la journée.

#6
berserk99

berserk99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
 Le problème est que quand je met NullCPUPowerManagement.kext j'obtiens ça :acpi_smc_PlatformPlugin::start-waitForService ressource matching(AppleIntelCPUpowerManagement)timed out

et ça reste bloqué là dessus




sinon j'ai :

fakesmc.kext

OPenHaltRestart.kext

PlatformUUID.kext

SleepEnabler.kext

Disabler.kext

LegacyHDA.kext

#7
Kangaroos

Kangaroos

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 185 posts
  • Gender:Male
  • Location:France
Quel version de bios utilise tu ? Avais tu déjà Leopard d'installer sur ta machine ? La configurationde ton bios est elle correcte ?

#8
berserk99

berserk99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
J'utilise la version F6 qui n'est pas la plus récente mais qui fonctionne très bien avec Leopard.

Pareil pour la config du bios, j'ai rien changé étant donné que ça fonctionne. Et je l'ai revérifié en suivant des tutoriaux... :D

Voilà à quoi ressemble mon écran au moment où ça bloque : 

Posted Image

#9
Trauma!

Trauma!

    Took too much...

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:France

J'ai essayé presque tous les tutoriaux que j'ai trouvé sur le net, mais j'arrive toujours au même résultat. Quand je lance l'install avec chameleon l'écran gris avec la pomme apparait, la "roue" de chargement tourne pendant une trentaine de secondes et puis plus rien, tout se bloque.


Ton problème est lié a la decryption. Met a jour ton FakeSMC.kext ou reinstalle le correctement... fin fait quelque chose quoi.

Le erreurs évoquée plus haut sont liée au speedstep d'OSX, ton DSDT et ton SSDT ne sont apparemment pas compatible (dans comme dans une immense majorité des cas). Mais ça n'empêchera pas ton ordinateur de démarrer.

Bonne chance.

#10
berserk99

berserk99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
 J'ai suivi ton conseil, j'ai retéléchargé le FakeSMC.kext et je l'ai réinstallé avec les autres kext, mais ça ne change rien. Je vois pas comment je peux l'installer mieux que ça.

Du coup j'ai essayé un nouveau tuto, qui consiste à lancer chameleon avec un cd de boot puis de le remplacer par le dvd de SL pour lancer l'installation. Et là ça se bloque toujours après  : 

acpi_smc_PlatformPlugin::start-waitForService ressource matching(AppleIntelCPUpowerManagement)timed out

Donc juste en lançant l'installation du cd, avant même d'avoir à installer le moindre kext , ou ficher de boot, j'obtiens toujours cette erreur 

J'en viens à me demander si c'est pas un problème avec ma carte mère ep43ds3l car il y a aucun tuto et peu de retours avec ce matériel. Pourtant elle est très proche de ep45ds3l et sur l'osx86wiki je vois que quelqu'un a réussi à faire tourner SL dessus. De plus comme je l'ai dit plus haut, Leopard tourne parfaitement sur cette config.

Je ne sais plus trop quoi tenter...



















Ton problème est lié a la decryption. Met a jour ton FakeSMC.kext ou reinstalle le correctement... fin fait quelque chose quoi.

Le erreurs évoquée plus haut sont liée au speedstep d'OSX, ton DSDT et ton SSDT ne sont apparemment pas compatible (dans comme dans une immense majorité des cas). Mais ça n'empêchera pas ton ordinateur de démarrer.

Bonne chance.
[/quote]

#11
Kangaroos

Kangaroos

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 185 posts
  • Gender:Male
  • Location:France
Bon, je viens de diagnostiquer ton problème de manière plus approfondi.

Ton Leopard fonctionne peut être avec ta version de bios f6 mais Snow Leopard fonctionne de manière différente avec des fonctions différentes et ce qui marchais avant ne marche pas forcement maintenant.

J'ai extrait le DSDT de mon bios EP45-DS3LR.F2 de tes bios EP43-DS3L.F6 et F8

Ensuite je n'ai fait aucune modif sur les fichiers DSDT extraits et j'ai fait un checksum md5.

EP45-DS3LR.F2 : A0CE7194FA10C48E2D48571203042067
EP43-DS3L.F6 : ADDEA042EA76C59F21F958689A79CF3A
EP43-DS3L.F8 : A0CE7194FA10C48E2D48571203042067

Comme tu peux le remarquer deux correspondent, celui de ma carte mère qui fonctionne en Snow Leopard et la version F8 de ta carte mère, donc déjà un bon point de départ serais de mettre ta carte mère à jour car on serais sur qu'elle présente a Snow Leopard un DSDT qui lui est compatible (vu que ça marche chez moi).

Si tu utilisais un dsdt.aml il faudra que tu le refasse.

Je te joint ton dsdt en version f8 non décompilé (juste extrait du bios) et la version patché contre le reset CMOS (pas décompilé, j'ai juste changé l'octet qui pose problème).

Attached File  dsdt_ep43ds3l_f8.zip   6.21KB   5 downloads
Attached File  dsdt_ep43ds3l_f8_Fix_CMOS.zip   6.22KB   9 downloads

J'ai un tuto en cours de rédaction qui commence a bien être avancé, tu peux t'appuyer dessus pour t'aider.
http://www.insanelym...howtopic=184987

Bon courage

#12
berserk99

berserk99

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Merci beaucoup pour ton aide, j'ai flashé mon bios sans problème pour passer à la F8, mais ça ne change absolument rien...Je vais réessayer ton tutorial.

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy