Jump to content

Installing OS X 10.6 On Maximus Formula


  • Please log in to reply
26 replies to this topic

#1
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Hello everyone,

Currently I have iATKos v7 (10.5.7 updated to 10.5.8) on my PC:

Motherboard: ASUS Maximus Formula X38
Chipset: ICH9
CPU: Intel E6420 2.13 @ 3.20
GPU: XFX nVidia 9800 GTX+

All is working (Shutdown, sleep, ecc.). Now I'm trying to install Snow Leopard, but when I boot I get always a KP

HELP!

:P

#2
ReLaXXeR

ReLaXXeR

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
Klick ME!!!

#3
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

Klick ME!!!


So it's a DSMOS problem? I'll try ;D

#4
jacoweb

jacoweb

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Male
  • Location:Norway
  • Interests:Hackintosh!
you need the right bootloader to.. Then use kext utility.. remember to boot in SL with -x

#5
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

you need the right bootloader to.. Then use kext utility.. remember to boot in SL with -x


Chamelon RC1 + EFI 10.2 it's ok?

Chamelon RC1 + EFI 10.2 it's ok?


Trying with

Chamelon RC1 + EFI 10.2 [Bootloader]
FakeSMC + DSMOS [Extra]

Chamelon RC1 + EFI 10.2 it's ok?



Trying with

Chamelon RC1 + EFI 10.2 [Bootloader]
FakeSMC + DSMOS [Extra]


=(

Posted Image

Kernel Panic

In the Extra folder the is:

FakeSMC, DSMOS, AHCIPortInjector, ATAPortInjector, AHCIBlockStorageInjector

AHCIPortInjector, ATAPortInjector, AHCIBlockStorageInjector were installed by Chamaleon

#6
superfaen

superfaen

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
i am not by my computer right now so I can't be 100 % specific. I have a maximus formula, the kexts I use are dsmos.kext (gonna try with fakesmc instead tonight.), ionetworkingkext.kext, a fix for ioahci and that platform uuid kext. I have generated a dsml file too, and inserted the disk uuid into the plist and com.apple.boot.list.
I had a lot of kernel panics before.
When installing SL from within Leopard I had to deselect Language translations X11 etc. to avoid getting an error at the end of the installation. Still I couldn't repair permissions etc. I used chameleon 1 first, which boots fine, but not in 64 bit mode.
Then I tried installing SL to another partition from within SL (booted with chameleon 1) and the installer completes successfully with all options selected. Then I installed Chameleon 2 (not rc) with pc efi 10.1 and it works without panics. I will test more the following days.
Sorry for not being specific with versions etc. but I don't have everything at the top of my head :P

#7
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

i am not by my computer right now so I can't be 100 % specific. I have a maximus formula, the kexts I use are dsmos.kext (gonna try with fakesmc instead tonight.), ionetworkingkext.kext, a fix for ioahci and that platform uuid kext. I have generated a dsml file too, and inserted the disk uuid into the plist and com.apple.boot.list.
I had a lot of kernel panics before.
When installing SL from within Leopard I had to deselect Language translations X11 etc. to avoid getting an error at the end of the installation. Still I couldn't repair permissions etc. I used chameleon 1 first, which boots fine, but not in 64 bit mode.
Then I tried installing SL to another partition from within SL (booted with chameleon 1) and the installer completes successfully with all options selected. Then I installed Chameleon 2 (not rc) with pc efi 10.1 and it works without panics. I will test more the following days.
Sorry for not being specific with versions etc. but I don't have everything at the top of my head :P


I'll try :)

#8
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Can someone, who has a fully working Snow Leopard installation (with maximus formula) post the Kexts he used to make it work?

#9
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

Can someone, who has a fully working Snow Leopard installation (with maximus formula) post the Kexts he used to make it work?


UP

:(

#10
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
UP #2 Help Please!

#11
ReLaXXeR

ReLaXXeR

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
Hi,

i will give you tomorrow eving more feedback because then i will try to install snow on my maximus formula.
For your Info, please delete the dsmos.kext what i posted in the second post because netkas replaced it with the better working fakeSMC.kext. Use this in the /e/e folder, also use only Chameleon RC2.
The fakeSMC works perfectly with the maximus formula board on leopard. I don not use the UUID kext, i fixed it by using an efi string added to my grafic string.

Are you using a retail snow install disk?
Did you create a boot132 disk for booting from the this retail disk? Or are you going to install directly from leopard ?

I will keep you up to date. I think I will work without having many problems, I am an optimistic ;-)

good night,
cheers,
ReLaXXeR

#12
superfaen

superfaen

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
What I did: I found out that installing SL from a Leopard partition was a bad idea (in my case). If you deselect all the printer drivers, X11 etc. everything seems to be ok. But It is not. The solution for me was to install SL from within SL :)
I have a few disks to test with, so it wasn't really a problem. If you only have one disk this will be hard.

I have a working 10.5.8, installed SL from Leo by pressing Shift+CMD+G and typing the path to OSInstall.mpkg (Mac OS X Install DVD/System/Installation/Packages/). Deseleceted everything but the basesystem and installed. I then installed chameleon 1 and used the kext files from here in the extra folder:
http://www.teknojunk...32-coming-soon/

Remember to build extensions.mkext. I also made a dsdt.aml and inputted the gfx string into com.apple.boot.plist. I also edited platformuuid.kext with the id of my disk. Maybe I did something with SMBios.plist too. Don't remember.

Anyways,this install wasn't working great (repairing permissions doesn't work, only 32 bit etc.)

So I tried installing SL from this installation to a third disk without deselecting anything, and it works great. Now I use FakeSMC.kext, some IOAHCI to fix the orange icons,platformuuid.kext and IONetworking.kext with Chameleon + PCEfi 10.1. I have a edited com.apple.boot.plist and smbios.plist in the extension folder along with a generated dsdt.aml and Extensions.mkext (which I made with Kext Utility.)

That's it. 4 kexts where only one or two is really important. 2 plist files and dsdt.aml.
You could avoid using platformuuid.kext if you input your disk uuid into com.apple.boot.plist. (I assume)

I think it's possible to make a boot cd to install SL from scratch without all these extra steps, but I can't be bothered now that I have it working. And installing SL is so quick anyways, installing it twice is ok for me.

The most important thing I have learned is that installing SL from Leo will not work. (at least not for me)

#13
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

Are you using a retail snow install disk?
Did you create a boot132 disk for booting from the this retail disk? Or are you going to install directly from leopard ?

I will keep you up to date. I think I will work without having many problems, I am an optimistic ;-)

good night,
cheers,
ReLaXXeR


I'm using a .DMG of a Retail Snow Leopard DVD (Gold Master). No Boot-132. I'll keep trying too :P

What I did: I found out that installing SL from a Leopard partition was a bad idea (in my case). If you deselect all the printer drivers, X11 etc. everything seems to be ok. But It is not. The solution for me was to install SL from within SL :)
I have a few disks to test with, so it wasn't really a problem. If you only have one disk this will be hard.

I have a working 10.5.8, installed SL from Leo by pressing Shift+CMD+G and typing the path to OSInstall.mpkg (Mac OS X Install DVD/System/Installation/Packages/). Deseleceted everything but the basesystem and installed. I then installed chameleon 1 and used the kext files from here in the extra folder:
http://www.teknojunk...32-coming-soon/

Remember to build extensions.mkext. I also made a dsdt.aml and inputted the gfx string into com.apple.boot.plist. I also edited platformuuid.kext with the id of my disk. Maybe I did something with SMBios.plist too. Don't remember.

Anyways,this install wasn't working great (repairing permissions doesn't work, only 32 bit etc.)

So I tried installing SL from this installation to a third disk without deselecting anything, and it works great. Now I use FakeSMC.kext, some IOAHCI to fix the orange icons,platformuuid.kext and IONetworking.kext with Chameleon + PCEfi 10.1. I have a edited com.apple.boot.plist and smbios.plist in the extension folder along with a generated dsdt.aml and Extensions.mkext (which I made with Kext Utility.)

That's it. 4 kexts where only one or two is really important. 2 plist files and dsdt.aml.
You could avoid using platformuuid.kext if you input your disk uuid into com.apple.boot.plist. (I assume)

I think it's possible to make a boot cd to install SL from scratch without all these extra steps, but I can't be bothered now that I have it working. And installing SL is so quick anyways, installing it twice is ok for me.

The most important thing I have learned is that installing SL from Leo will not work. (at least not for me)


Mhmm I can install Snow Leopard from Leopard with no errors don't know why :unsure: . I made all your steps but it doesn't work, always KP. I'll Install Snow Leopard from my MacBook and hope it'll work

#14
superfaen

superfaen

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts

I'm using a .DMG of a Retail Snow Leopard DVD (Gold Master). No Boot-132. I'll keep trying too :)



Mhmm I can install Snow Leopard from Leopard with no errors don't know why :D . I made all your steps but it doesn't work, always KP. I'll Install Snow Leopard from my MacBook and hope it'll work


Try to boot it with as few kexts as possible. And remember to rebuild extensions.mkext. Also try booting with the -x64 flag. I still think installing from within Leopard is causing problems.

#15
nonne9

nonne9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

Try to boot it with as few kexts as possible. And remember to rebuild extensions.mkext. Also try booting with the -x64 flag. I still think installing from within Leopard is causing problems.


Yes you're right. Installing from Leopard is the problem :( . Now I'm installing Chameleon RC1 + PC EFI 10.1 + FakeSMC

#16
Defender666

Defender666

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
I want to do a fresh install on Asus Maximus Formula. I have a osx notebook where I could prepare the disc through usb. However it seems I need the dsdt.aml to follow the guide.

How did you build this file. I've seen many guides but I am confused. Do you patch your bios to use dsdt.aml I have a windowstool which patches the bios e.g. you have to provide a bios or a dsdt.aml file to build it. What are the steps you took to get the dsdt.aml. How to start from the scratch?? Is dsdt.aml also biosversion dependant.

Can someone send me his/her dsdt.aml for Asus Maximus Formula

#17
superfaen

superfaen

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
As far as I know you don't patch anything in your hardware. You use the dsdt gui tool to generate a dsdt file which you just put in your extra folder. You can find the tool by searching google for dsdt patch gui.

#18
Defender666

Defender666

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
Okay I found this but the only problem is I would need to first install some iDeneb/iAtkos or what so ever to get an OSX running on the fresh maschine. If I could generate the dsdt from a different maschine like in the windows patcher tool i would not need that step.

#19
superfaen

superfaen

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
There is no installer for chameleon or any other bootloaders for windows, so you need to get osx up first anyways.
You can boot with a boot cd and swap with the OSX install disk to install Leopard. In that way you don't need to install anything first. Boot OSX with the boot cd untill you install chameleon and dsdt. etc. I don't remember which boot cd I used the first time, but try a few of them.
You can also make a usb stick with boot files on them, but you won't be able to install from DVD then.

And you really don't need dsdt.aml to get up and running with Maximus formula.

#20
Defender666

Defender666

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
I know about BootCD, USB, and so on...that's not the point

The goal is to prepare the Disk on a different 10.5.7 OSX86 and then boot this disc.

Do you mean one does not need dsdt.aml to boot SL

I could not boot my USB DVD Image (with Cam(not RC) + Efi10 => KP). So I though I need the dsdt.aml first

From PCwiz

Latest and greatest PC_EFI, based on chameleon2

patches added for better snow leo compatibility,

they include: emulating 64-bit efi pages, removed setting IODT://options by bootloader, changed smth in hibernate, for better ati compatibility (wasnt tested yet), by default it boots 64-bit snow leo kernel on 64-bit cpus, flag -x32 will force loading 32-bit kernel

known issues: boot stalls if DSDT.aml isn’t present.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy