Jump to content

Snow Leopard on VAIO P(VGN-P90HS) working!


  • Please log in to reply
528 replies to this topic

#81
SoulZero

SoulZero

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

@maccosmo
:(

enjoy vaio P
@ccarrieta

My Install Procedure is ...

(0. make vaio recovery DVD disks.)
1. shurink VISTA partition from VISTA with diskpart.
2. boot from gparted live cd.
3. create two hfs partitions on empty area(#3:16G,#4:10G)
4. format partition #4 hfs.
5. copy entire retail dvd to partition #4(be careful copied files uid/gid)
6. copy osx86 standard kexts( dsmons, ps2 and etc...)
7. copy vaio p specific kexts( download topic link)
8. replace OSInstall.mpkg to enable MBR partition install.
9. append boot options to com.apple.Boot.plist, "cpus=1 rd=disk0s4")
10. install bootloader( mbr and pbr and /boot )
11. boot leopard installer from partition #4
12. install leopard to partiton #3
13. before reboot, install and overwrite kexts on pattions #3(installed #4 step 6. 7.)
14. append boot options to com.apple.Boot.plist, "cpus=1 rd=disk0s3")

this method saves VISTA and Instant mode.
but so complex.

I hope someone find more easy way and post here :)


I'm stuck on step 5. I don't understand how to copy the files from theDVDIso/DMG to that partition on Gpart. Do I do it by terminal? Also, I made an ISO and DMG on my external HD, how do I access that? I don't have 2 external dvd players to run both OSX and gparted.

BTW: Thanks a lot you guys for giving me a guide :)

#82
vimcat

vimcat

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

I'm stuck on step 5. I don't understand how to copy the files from theDVDIso/DMG to that partition on Gpart. Do I do it by terminal? Also, I made an ISO and DMG on my external HD, how do I access that? I don't have 2 external dvd players to run both OSX and gparted.

BTW: Thanks a lot you guys for giving me a guide :)


Once you're booted into Gparted, it detects the devices. You can select the device that contains your install files, copy the partition then select the install partition and paste it, make sure you uncheck the round size box or you may get a destination is smaller than source error.

I don't know how to boot into the install partition to start the installation either.

#83
nipro

nipro

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Here are the kexts I have inside the /Extra/Extensions folder of my USB root:

ACPIPS2Nub.kext
AppleACPIPS2Nub.kext
AppleHDA.kext
ApplePS2Controller.kext
AppleSMBIOS.kext
IntelCPUPMDisabler.kext
OpenHaltRestart.kext
PCIFix.kext
SMBIOSEnabler.kext
UUID.kext
VoodooBattery.kext
VoodooHDA.kext
VoodooPower.kext
dsmos.kext

Is there something missing or that shouldn't be in this list? I start it up in verbose but it keeps hanging at waiting for root... I did add the two plugin files to their respective locations as well.


Hi vimcat,

I'm currently loading the following kexts, in exactly that order:

1. PCIFix.kext
2. ApplePS2Controller.kext
3. AppleACPIPS2Nub.kext
4. IOATAFamily.kext
5. 5IOUSBFamily.kext

This let's me boot the system, but after that the setup hangs at the moment you see the leopard desktop background (it ends with a spinning beachball, nothing happens from there).

#84
SoulZero

SoulZero

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Once you're booted into Gparted, it detects the devices. You can select the device that contains your install files, copy the partition then select the install partition and paste it, make sure you uncheck the round size box or you may get a destination is smaller than source error.

I don't know how to boot into the install partition to start the installation either.


I tried but my files are on a NTFS HD that's 1TB. i can't just copy that entire partition over, plus it's stuck in a container ISO/DMG. Can gparted open it? so I can copy/paste it? I wish I could boot up ubuntu and easy the live disc for this, but it doesn't support graphic on GMA 500 yet.

#85
prepst

prepst

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

I tried but my files are on a NTFS HD that's 1TB. i can't just copy that entire partition over, plus it's stuck in a container ISO/DMG. Can gparted open it? so I can copy/paste it? I wish I could boot up ubuntu and easy the live disc for this, but it doesn't support graphic on GMA 500 yet.


Only you need to use Gparted and copy some files, I recommend you to use
Puppy Linux Live with some USB memory.
This is small (100MB), easy to install to the USB memory with Unetbootin
(download, format, install, and make it bootable in one action with
Windows/Linux application), and maybe you can use window system
over some VESA framebuffer.

#86
vimcat

vimcat

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
OK, I tried re-installing on my USB again with some success. I added the kexts I listed previously using kext helper, and manually dropped the plugin files into their respective plugin folders, ran permission repair, and installed chameleon 2. I booted with -v -f cpus=1 rd=disk1s2.

The first time I tried to boot, I got a reboot error. The second time I tried to boot, I got a waiting for root error. The third time loaded all the way to the desktop but the mouse and keyboard are not responsive. I plugged in my mac mouse into the free USB port, and that worked. The keyboard is definitely not working. Any ideas?

**update** I deleted AppleTyMCEDriver.kext, but that still didn't fix my mouse/keyboard problem. :wacko:

#87
nipro

nipro

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

OK, I tried re-installing on my USB again with some success. I added the kexts I listed previously using kext helper, and manually dropped the plugin files into their respective plugin folders, ran permission repair, and installed chameleon 2. I booted with -v -f cpus=1 rd=disk1s2.

The first time I tried to boot, I got a reboot error. The second time I tried to boot, I got a waiting for root error. The third time loaded all the way to the desktop but the mouse and keyboard are not responsive. I plugged in my mac mouse into the free USB port, and that worked. The keyboard is definitely not working. Any ideas?

**update** I deleted AppleTyMCEDriver.kext, but that still didn't fix my mouse/keyboard problem. ;)


For me the (USB) mouse/trackpad (can't test the keyboard) are working. Can you get to the first step of the installer with the kexts loaded I provided you? :)

#88
Wagyk

Wagyk

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

I use Chameleon 1 because maccosmo use this.
Edit com.apple.Boot.plist for boot up option. -v -f cpus=1 "Graphics Mode"="1600x768x32"

Try them.

Thanks.


Hi!!
Thanks for help me :)

I try for with your explication.
But where I found chamaleon 1 because I just found chamaleon 2 RC1.
And where is the com.apple.Boot.plist it is in the ryuus vaiop alpha 1 ??

Thanks

#89
Wagyk

Wagyk

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hi!!
Thanks for help me :)

I try for with your explication.
But where I found chamaleon 1 because I just found chamaleon 2 RC1.
And where is the com.apple.Boot.plist it is in the ryuus vaiop alpha 1 ??

Thanks



I have found the boot.plist.
But where I put -v -f cpus=1 "Graphics Mode"="1600x768x32"????
Do you put the boot in the alpha folder in the root of your usb disk?
I dont found chameleon 1

Thanks :)

#90
prepst

prepst

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Now I use Ethernet via USB-Ethernet adapter with Pegasus OSX driver.
This seems fine for me.

Next, I would try to use MLAN inside VAIO type P.
It seems Yukon, so add some informations to the *.plist inside driver kext?

MLAN@0 <class IOPCIDevice, registered, matched, active, busy 0, retain 6>
| "device-id" = <80430000>
| "vendor-id" = <ab110000>
These two informations are the key of this?

Thanks in advance.

#91
InX

InX

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

Hi,

now it works!!

based on retail 10.5.6 + vanilla 9.6


Wow!!! Remarkable!!!

Does it run PowerPoint 2004 on Mac for presentations via VGA?
Does it play QuickTime video on Mac for presentations via VGA?

Thanks!

#92
jsoryu

jsoryu

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
So far, I've done numerous times of re-try with no success.
I'm sure I am following the instruction exactly (after 3 weeks of trying, it better be), but i am still stuck at boot where it hangs.

This only possible difference with others may be that I've installed Sony's BIOS update. Do you think this has any effects? (PCIFIX's memory mapping matches with the previous post info)

BTW, I'm using Patriot 64GB USB for OS X installation.

Retail 10.5.0 upgraded to 10.5.7
Installed Chameleon 1 (Used Installer Package, any other files i need to add after?)
Installed ryuu's version 1 files
(Also tried to add standard kexts for osx86, without USB disabling kexts)
Canadian Version of Vaio P with 1.33 / 60g
All Sony upgrade installed, including BIOS update.

Used variation of boot sequence (-f -v -x) <-- attempted safe mode due to stall at /usr/bin/***[**]
Kexts Installed by Terminal

#93
zwmg

zwmg

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
I know it' not legal. But there are so many iso flying around the net for almost every netbook but not for the P. Isn't it possible to make such a image, so that people just have to run it with as less self configuration (installing kexts etc.) as possible?

It's really hard for many people to get it right. And some like ryuu123 just know how to do it. Of course, it's still illegal, but you can send the link only to people who can proof a Leopard DVD purchase (or at least an Apple computer purchase), if that's what it's all about.

A complete dvd image would be so cool. I would donate if that helps...

#94
imacken

imacken

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
I don't know if you guys can help, but the OSx86 install on my VGN-AR51E Vaio is OK - apart from no built-in wireless - except for 2 things:

1) video goes to external monitor after video driver kicks in. No internal LCD after initial boot.

2) the tap-click on the touchpad doesn't work.

Any ideas on these? Especially the first!

#95
ryuu123

ryuu123

    InsanelyMac Protégé

  • Donators
  • 85 posts

This only possible difference with others may be that I've installed Sony's BIOS update. Do you think this has any effects? (PCIFIX's memory mapping matches with the previous post info)


Hi

I've updated BIOS about a month ago,
and don't have any trouble with OSX86.

The trouble is someware else.


Wow!!! Remarkable!!!

Does it run PowerPoint 2004 on Mac for presentations via VGA?
Does it play QuickTime video on Mac for presentations via VGA?

Thanks!


I don't try but external VGA is perhaps dead.

To external monitor work, we need to wrote GMA500 video driver.

#96
grigsby1

grigsby1

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Tonight installing osx on my vaio P (first time trying, any suggestions.)

#97
Serbijan

Serbijan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi Maccosmo
Hi Ruy123

I read everything you post Here and i tried to install osx by maccosmo's guide via usb

after booting vaio with installed on usb osx i get this message. what a problem? what do you think?

http://i067.radikal....d855fa00d88.jpg

Posted Image

UPDATED - installation succsful. great thanks to ruy123, maccosmo and prepst))) trackpad still not working.but keyboard is ok

what about wifi -aitport?

#98
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,713 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
I suppose you don'l load ahci properly.. if you put those drivers.. did you set the permissions properly?
other question.. what is the 9.6.1 kernel? is a retail or modded?

#99
Serbijan

Serbijan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

I suppose you don'l load ahci properly.. if you put those drivers.. did you set the permissions properly?
other question.. what is the 9.6.1 kernel? is a retail or modded?


thans for reply ugokind!

ahci - is the kext iousbfamily.kext?
i don't understand what should i do with it - replace or just rename new kext,
kernel - is from retail dvd leopard 10.5.6 (it was in a box with my macbook)
i've done repair permissions procedure...

may be problem is in kexts/

please somebody share here theirs kext with modified


@ UGOKIND - You were absolutely right i installed ruy kext inside plugin folders and it work;s now.

i changed boot.plist with graphics mode but it's still 1024x768 and no trackpoint(((((

#100
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,713 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
no no. if you boot from a usb peripheral iousbfamily is a part but not all!

it's important the ioahcifamily and appleacpiplatform
both are required to SEE the hard disk!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy