Jump to content

Darwin Boot Screen: No USB Support?


  • Please log in to reply
5 replies to this topic

#1
azdude123

azdude123

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hello everyone! Well this has been driving me nuts for a while and I don't think this has been posted previously. I have MACOSX 10.4.4 dualbooting with Windows on different partitions. My problem is when I choose the Darwin boot loader, during the count down, my usb keyboard gets disabled. The keyboard works fine when I'm in the windows bootloading screen as well as the BIOS. The problem there is that darwin automatically chooses to go back to the Windows bootloader as default at the end of the count down. It seems the only way around this... and yes, this is odd... is to have another PS/2 keyboard connected at the same time. It seems the darwin bootloader does seem to like the PS/2 response when I hit it during the count down taking me to the selector. When it gets to selecting the OS, the USB keyboard works again. It's just during that countdown that USB gets disabled. I did try turning off USB Keyboard and mouse support in the BIOS but that did nothing. Of course, I've tried booting without a ps/2 keyboard (only the USB mouse and keyboard) but again, the darwin bootloader is unresponsive. I don't think it's an incompatibility with the USB keyboard being that it is an Apple Keyboard (same was happening with my other USB IBM Rapid Access Keyboard). I also tried using the code
<key>Kernel Flags</key>
<string>rd=disk0s2</string> (0 being the drive, 2 being the partition)

but it still defaulted to the Windows bootloader. I think I'm out of ideas... I also changed the active partitions, but still... no USB support on the countdown. Having 2 keyboards (and having to press a key) is tacky... I would like to get rid of that. Any ideas? thanks!

#2
StV

StV

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
try finding in bios an option Usb Devices in Dos [Enabled/Disabled] and enable it

#3
azdude123

azdude123

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Well, at least thanks for giving it a shot. Yes... it's been enabled... as well as trying to disable to see if that would make a difference. I think I've made up my mind and blame it on the USB controller on the motherboard. I guess I could always buy a PS/2 keypad to take less space on the desk...

#4
easyprinter

easyprinter

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Well, at least thanks for giving it a shot. Yes... it's been enabled... as well as trying to disable to see if that would make a difference. I think I've made up my mind and blame it on the USB controller on the motherboard. I guess I could always buy a PS/2 keypad to take less space on the desk...


Is your Legacy USB Support enabled? When i enabled it, my Apple Keyboard works flawlessly :) !

#5
webmonkey44

webmonkey44

    geek++

  • Members
  • PipPipPipPipPipPip
  • 443 posts
  • Gender:Male
  • Location:Bunbury
  • Interests:Christian music &amp; computers all sorts...

try finding in bios an option Usb Devices in Dos [Enabled/Disabled] and enable it

He is right. I have a USB Logitech G15 :( keyboard and to use it in the Boot-loader or DOS stages of boot I had to turn on legacy support in the BIOS

#6
Franillos

Franillos

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I have the same problem and I'm thinking is a motherboard problem. One possible solution is to use a USB to PS/2 adapter.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy