Jump to content

graphics corruption


  • Please log in to reply
14 replies to this topic

#1
cmdshft

cmdshft

    Retired OSx86

  • Members
  • PipPipPipPipPipPipPip
  • 922 posts
  • Gender:Male
  • Location:New Jersey
I ghosted my hard drive to another one, and updated to 10.5.6 (solving tons of hurdles along the way) and now there's one last issue.

There's a graphic corruption in System Preferences.

Attached File  Picture_1.png   737.18KB   576 downloads

I tried to replace the OpenGL.framework with the one from 10.5.5, set proper perms and rebooted, but there's still the same issue.

Could it be possible that it's because of my graphics card? I don't see how, as I replaced the new nvidia kexts with the ones from 10.5.5 (seems that Apple finally phased out the 5XXX series, as it wouldn't boot until I replaced those kexts), and I have full acceleration as well.

Is there anyone that could please look into this? Seems like I post issues lately and they rather go unheard...

#2
Sanya

Sanya

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hi!
I had same problem like you, and I succesfully solved it. Restore the Coregraphics.framework from 10.5.5 to /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ with Pacifist, restart and now it's working again.

#3
Quaront

Quaront

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Sanya -

Thanks for solving the corrupted "system preferences" issue. That made a big difference.

#4
uukk

uukk

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
Work fine also for me.
Many regards.

I had same problem like you, and I succesfully solved it. Restore the Coregraphics.framework from 10.5.5 to /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ with Pacifist, restart and now it's working again.



#5
RepoMonkey

RepoMonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

Hi!
I had same problem like you, and I succesfully solved it. Restore the Coregraphics.framework from 10.5.5 to /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ with Pacifist, restart and now it's working again.


Hi Sanya. Could you explain that fix in a little more detail please, because I have no idea what I'm supposed to be opening/clicking on. I have a fresh 10.5.6 install and the system graphical glitches you mentioned, but there doesn't seem to be anything in the directory you metion above that pacifist can open - and even if it did I'm not sure I'd know what to do. So could you elaborate? :D

#6
Quaront

Quaront

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
RepoMonkey, this may answer your questions:

10.5.6 and GeForce FX5500, The issues and how to fix them.

1. insert a 10.5.5. distro
2. open pacifist
3. click "open apple install disks"
4. browse to the system folder (inside of one of displayed choices, depends on which distro you are using), and follow the path to Coregraphics.framework, then right-click on it and choose install
5. when it asks you to replace, choose yes (it will over-write the 10.5.6 version)
6. it may go a bit slow, let it run. after, reboot. On reboot, working interface... :)

#7
iCF-74 ToughMac

iCF-74 ToughMac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male
  • Location:Canada eh?
RepoMonkey,


If you have trouble browsing to the file you want in pacifist, use the search. I did this when I tried this and just threw CoreGraphics into Pacifist search (upper right) and then when the search results drop down on the right of the main Pacifist screen, choose the CoreGraphics.Framework then click install .. and continue as above, overwriting when asked.


Joe

#8
RepoMonkey

RepoMonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

RepoMonkey, this may answer your questions:



RepoMonkey, If you have trouble browsing to the file you want in pacifist, use the search.


Thank-you to you both. Problem fixed. :(

#9
protactinium

protactinium

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Sanya, Quarant, Hara Taiki:

Thank you so much! Not only did your "fix" solve my corrupted System Preferences graphics problem (using a 128 mb FX 5500 PCI) but it also stopped my "About this Mac" from crashing. [BTW, I'm running 10.5.6 with the Voodoo kernel on a very old Dell GX270, SEE2.]

I would add that I downloaded the 10.5.5 update from Apple and used Pacifist to obtain and install the CoreGraphics.framework pkg as you instructed.

Thanks again!!! You are truly gifted people!

#10
kristal

kristal

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
anyone, please I need Coregraphics.framework from 10.5.5 file for update my fx 5200, because I don't have 10.5.5 cd installer. i just did fresh install from ipc 10.5.6 and I don't have internet connection at my mac.

#11
Amit Meena

Amit Meena

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Gender:Male
this method wont worked for me on fresh iPC 10.5.6 with FX5500 256MB.........

sorry guys...

other suggestions are welcome........

#12
geowiz

geowiz

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Ashland, Oregon USA
  • Interests:computers, radio control, geology, motorcycles, airplanes-flying.
Thanks to all the help here and in other posts I have been able to get my Dell Optiplex GX260 working just about perfect, Leopard 10.5.7 with dual monitors and QE/CL working on a GeForce FX5200. Took me a couple days but it was worth it. The only thing is my resolution on my 23" HP L2335 monitor tops out at 1360x768 and is actually better at 1280x1024. I wish it was able to go up to 1600x1200 or even 1920x1200 but I guess that's not to be for now. I'm actually pretty stoked and thanks again to all. I'm really not quite sure how I managed it but here is what I did basically. iAtkosv7 install using -x -f -v to boot the dvd and installed using only a few options dsmos and apple for decrypters, no smbios, kernel .9, apple ps2, disabler nothing else except network stuff, intel pro100 and all the wireless stuff (for future owners). Then once the system was up and running I forget all I did to get the graphics right but the key to dual monitors is using a custom EFI string for the graphics card. osx86 tools did the job once again. then it was the 10.5.5 core graphics and the nvkush complete package that made it all work right with QE. lot's of hassles but finally - Hackintosh Nirvana. Sound in and out with ac97.kext and that's about it. Via firewire, external disk shows up isight works sound and all the whole 9 yards. Now to see if I can update with out breaking the whole thing? I don't know, I might just have to enjoy it first for awhile. The good news is I've got seven more just like it to do so I will keep better track of the process and maybe do a write up for those interested. :) :D
P.S. You can see what didn't work on the desk top there, don't use them they will break your install. So much for the guy who said it was all a lie and fx5200 was junk

Sorry for posting twice but here are the pictures of the desktops showing nvinject.kext and titan.kext. They messed me up. ;)

Attached Files



#13
love is all

love is all

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
After i changed my memory black corruptions had occurred .. i was searching a solution about this .. really thank you very much mates.. you are number one .. thanks sanya .. :D

#14
LeapFrogger

LeapFrogger

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
And for those of you who are rudely surprised by graphics corruption caused the "Security Update" that Apple rolled out this week to 10.5 -

(see http://reviews.cnet.com/8301-13727_7-20014604-263.html)

this is the fix.

#15
ADHDMedia

ADHDMedia

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 572 posts
  • Gender:Male
  • Location:Modesto, CA, USA

And for those of you who are rudely surprised by graphics corruption caused the "Security Update" that Apple rolled out this week to 10.5 -

(see http://reviews.cnet.com/8301-13727_7-20014604-263.html)

this is the fix.



Ran into this very issue after installing updates recently, and I've followed this guide but I still come up with corruption in my Finder windows and in System Preferences. Any ideas? I'm running 10.5.8.

After i changed my memory black corruptions had occurred .. i was searching a solution about this .. really thank you very much mates.. you are number one .. thanks sanya .. :)


...but I also recently changed system memory as well.... Wonder if this is why the coregraphics.framework fix isn't working for me? Anyone have any input?





***EDIT*** Ok people, finally got the issue resolved. I had to actually download and burn the 10.5.5 distro and use Pacifist. The package installer wasn't doing the job for me for whatever reason. Thanks everyone!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy