Jump to content

{TUTO} EFI Boot Partition (nouvelle methode Retail)


  • Please log in to reply
111 replies to this topic

#81
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Il te faut le kext OpenHaltRestart de chez psystar. Va voir chez eux dans le rubrique opnesource.

#82
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels
Bigre ! Il n'y avais plus de P35 alors me voilà sur une EP45-DS3R... ICH10R.

J'ai déjà updaté le bios en F10 et mis le SATA sur AHCI. Le boot132 de sonotone fonctionne avec cette carte : merci !

J'ai modifié IOAHCIFamilly et IOATAFamilly, je suis en train de faire l'update, je posterai le dossier Extensions dès qu'il fonctionnera parfaitement.

...à suivre

#83
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)

Il te faut le kext OpenHaltRestart de chez psystar. Va voir chez eux dans le rubrique opnesource.


ok je vais tester, merci :)

au passage je vais utiliser leur r1000.kext qui à l'air pas mal :angel:

quelqu'un sait à quoi sert l'openDSDT ?
http://store.psystar...source/opendsdt



EDIT:
Super Sonotone c'était ça, merci :)
va savoir pourquoi du jour au lendemain, ça ne fonctionnait plus :wacko:


@ PM!
voici le nouveau lien pour mon dossier de kext, mis à jour avec r1000.kext et le nouveau OpenHaltRestart.kext
merci.
http://www.mediafire.com/?nxzggymymjd

#84
Eromejir

Eromejir

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:liege

Pour le son il faut que tu utilises le AppleHDAEnabler + HDA patcher avec le bon dump. Ce ne sera donc pas du full retail mais c'est mieux que pas de son.
Comme je suis sympa je te file le tout déjà patché ;) tu n'as plus qu'à te servir de kexthelper :(
(en espérant que ce soit bien du ALC662)


merci PM!, j'ai du son, c'est impeccable!!! mille merci et est-ce normal que je retrouve ceci dans le récapitulatif "A propos de ce Mac" dans la partie audio intégré:

Audio haute définition Intel :

Identifiant du périphérique : 0x10438290
Identifiant audio : 12
Appareils disponibles :

et j'ai essayé de mettre le son avec GFX Strings grâce à la technique de Sonotone et au moment de retrouver ma ligne PciRoot de ma carte audio via le terminal, il m'indique qu'il n'a rien trouvé pourtant elle est reconnue par le mac...

#85
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels
Bon bah cette méthode fonctionne avec les GA-EP45-DS3x. C'est officiel. J'ai posté le dossier extension complet. Même procédure que d'hab (Boot132 - GA-EP35-DS3R de sonotone) - plus update du bios en F10 (faisable avec clé usb, il faut juste extraire le .exe avec TheUnarchiver, par exemple et placer le bios f10 dans la clé USB).
Dans le bios j'ai désactivé : CPU Multithread, pendant l'install. Je ne sais pas si c'est absolument nécessaire. Je l'ai réactivé ensuite.

Aux chanceux qui ont cette carte : have fun !

#86
coucou

coucou

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 706 posts
superbe tuto (je viens de m'apercevoir de l'existence de cette rubrique tuto .. mais j'avais deja fait l'install avec la methode de munky ;-)


Par contre toujours le même problème quels kexts mettre dans /Volumes/EFI/Extensions pour une GA-EP35-DS4 afin de faire le mkext ... ?

#87
coucou

coucou

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 706 posts

j'ai recommencé la manip à zero avec formatage complet du disque, et même constat :)

As tu une GA-(E)P35-DS4 ?

Félicitations pour toi si tout marche
Pour ma part j'ai aussi une G33 et ce soir je viens de reformater et reinstaller proprement OSX V.0 et j'ai tout de suite Fait une MAJ vers V.5, depuis plus possible de booter meme avec le 132 ....
Je desespère .....

dites vous qu'il ne faut rien toucher à votre partoche ou est installé os x ...
TOUT se passe maintenant dans/Volumes/EFI ....

rien de plus simple.

#88
coucou

coucou

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 706 posts
Vous allez adoré :

http://www.pendrivel...-usb-installer/

en gros on crée un stick usb bootable à partir d'un iso bootable (cd) en un click (c 'est un live cd ubuntu)

je test et vous fait le feedback

#89
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

superbe tuto (je viens de m'apercevoir de l'existence de cette rubrique tuto .. mais j'avais deja fait l'install avec la methode de munky ;-)


Par contre toujours le même problème quels kexts mettre dans /Volumes/EFI/Extensions pour une GA-EP35-DS4 afin de faire le mkext ... ?

Les kext qu'il te faut... Tous ceux dont tu as besoin habituellement. (dont beaucoup devraient être inclus dans les différents Dossier Extensions proposés dans ce tuto )

Vous allez adoré :

http://www.pendrivel...-usb-installer/

en gros on crée un stick usb bootable à partir d'un iso bootable (cd) en un click (c 'est un live cd ubuntu)

je test et vous fait le feedback

Rien à faire ici.

#90
jerhom

jerhom

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Bon bah cette méthode fonctionne avec les GA-EP45-DS3x. C'est officiel. J'ai posté le dossier extension complet. Même procédure que d'hab (Boot132 - GA-EP35-DS3R de sonotone) - plus update du bios en F10 (faisable avec clé usb, il faut juste extraire le .exe avec TheUnarchiver, par exemple et placer le bios f10 dans la clé USB).
Dans le bios j'ai désactivé : CPU Multithread, pendant l'install. Je ne sais pas si c'est absolument nécessaire. Je l'ai réactivé ensuite.

Aux chanceux qui ont cette carte : have fun !


Bonjour. Je viens donc de lire que je suis un "chanceux" possesseur d'un CM GA-EP45-DS3R. C'est ce qui m'amène à poster ici, un peu HS parce que... j'ai bien du mal tout de même...

J'ai un proc Q6600, 4Go de DDR2, WXPPro sur un 1er HDD et une retail de Leopard updaté en 10.5.5 sur un deuxième HDD (2 seagates 500Go en Sata).

Une première install réussie de Kaliway 10.5.1, puis tentative de version retail osX (à l'aide d'un cd de boot) pour les avantages d'updates officiels, si j'ai bien compris.

Je suis ici pour 2 problèmes :

1. je voudrais pouvoir booter sur l'un ou l'autre système avec un dual boot, et au moins ne plus avoir à passer par le CD de boot avec lequel j'ai installé Léopard pour démarrer. Avec Kaliway, la commande au boot du dvd après F8 "-v rd=diskXsY" (avec pour moi X=1 Y=1 , XP étant en disk0s1), avait permis de me passer du cd de Kaliway pour booter. Puis-je faire la même chose avec mon cd de boot ? En attendant, j'applique la méthode du premier post de ce thread, mais il quand je fais la commande pour copier les extensions, le dossier EFI/Extensions est vite plein === (le dossier KEXT que j'ai créé sur le bureau fait 192 Mo, il faut sans doute faire une sélection des kexts, mais je ne sais pas les choisir!!!) Donc je suis bloqué là...

Rien à dire, j'ai suivi à la lettre le tuto et rebooté sans problème = les quelques kexts compris dans le package de PM pour ma carte suffisent apparemment ! Enfin, pour le moment, pas de problème apparu depuis, chui ben content, merci en grand pour PM !!!

2. Je voudrais aussi avoir la video pour chipset nVidia 8800GT 1Go, et surtout le son qui ne fonctionne pas mbien que tout soit normalement apparu dans la fenêtre de règlage son des préférences système.

Au passage, étant nul, je n'ai pas tout compris, d'une façon générale au sujet de la manipulation de ces kexts (équivalents dans windows aux inf sys et dll si j'ai bien compris ?), ni aux plists et consorts. J'ai cru comprendre que je pouvais les copier dans extensions ou bien les installer avec un kexthelper qui fait tout bien... mais faut-il enlever d'autres kexts (et comment savoir lesquels), faut-il "réparer les autorisations" dans les outils de disque après chaque opération d'installation de logiciel ou d'extension ?

Ouaih je suis pas très aiguisé, mais après des jours et des jours de lectures en anglais le plus souvent, j'ai toujours bien du mal. Donc je poste un peu une bouteille à la mer en souhaitant ne pas emm... trop, et en imaginant que d'autres pourront profiter de mes questions basiques :wacko: ...

Merci !

P.S. Dernier problème que je viens de voir : lorsque j'essaye de lancer TimeMachine, il m'ouvre une puis une deuxième fenêtre du Finder qui n'ont rien à voir apparemment et qui bloquent jusqu'à ce que j'arrive à les fermer, mais je ne peux pas faire de sauvegarde (j'ai juste cloné avec CCC). Bon, le Mac, ça s'mérite, on dirait ! :( Problème règlé avec l'application appliquée du tuto de PM. Re-merci ! :rolleyes:

#91
MowgliBook

MowgliBook

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 998 posts
  • Gender:Male
Essaye mon Retail Pack pour l'audio et la carte graphique.

#92
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

Essaye mon Retail Pack pour l'audio et la carte graphique.


Dommage que je ne l'ai pas vu plus tôt. Maintenant c'est fait et puis ça marche alors... merci quand même.

#93
jerhom

jerhom

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Essaye mon Retail Pack pour l'audio et la carte graphique.


OK Merci, on a un matériel assez similaire, il y a des chances que ça marche pour moi aussi !

En pratique, que dois-je faire avec ton Pack EP45-DSx Retail Pack v0.1 ?
Je ne voudrais pas bousiller ce qui marche déjà pour moi ! (Bon, j'ai fait un clone avec CCC, donc je suis couvert, c'est déjà ça...)

Donc finallement, je refais la manip de PM! à partir de sa "phase 4, § 3" (en effaçant auparavant le contenu du dossier Extensions de la partition EFI, puis en décomprimant les fichiers kext audio et video (et d'autres ?) de ton EP45-DSx Retail Pack v0.1 dans le dossier kext -que j'ai créé en suivant le tuto PM!- sur le bureau -ce qui doit écraser les anciens fichiers ?-, puis en suivant tout le script sur Terminal phase-4-3) ?

J'ai bon ? Ou bien il y a plus simple ?

Déjà que je ne suis pas bien sûr de la façon d'utiliser des kexts (faut-il enlever les anciens d'abord mais alors comment les reconnaître, est-il plus simple d'utiliser un logiciel d'installation de kexts, faut-il toujours "réparer les autorisations", quid des plist et mkext et autres... j'en perds un peu mon latin.

Pour la vidéo, il faut que j'approfondisse la notion de GFX strings à laquelle je n'ai pas encore compris grand'chose...


Merci derechef ;-)



Autres problèmes :

1. avec l'AHCI activé dans le BIOS, WInXP démarre jusqu'au logo avec le chenillard en dessous, puis se fige sur le bel écran bleu avec de graves délires de menace virus à la MS... En désactivant AHCI, tout roule pour XP... Il n'y aurait que Vista qui supporte l'AHCI?

2. Et puis pour le moment, je boote avec F12 pour choisir mon OS (i.e. mon DD, vu que chaque OS est sur un disque différent), je suppose que si je veux faire un dual boot, il faudra que je règle d'abord ce problème d'AHCI avec Windows... Mais le dual boot est-il possible avec une partition d'amorçage EFI comme mis en place par la méthode de PM! ?

3. Bon, j'arrête... :censored2:

#94
Kelvan

Kelvan

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
pour l'ahci faut installer des pilotes spéciaux sous windows xp. Souvent des pilotes de chipset intel mais je ne saurais pas t'en dire plus ça dépend du controleur de stockage de ta carte mère.
En tout cas pour moi j'avais du les installer pendant l'installation d'xp avec une disquette puisque l'ahci était activé au moment ou je l'ai installé.

J'espère que ça te donnera une piste

#95
jerhom

jerhom

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Bravo, c'est exactement ça, et merci : grace à toi, j'ai orienté ma recherche google et j'ai pu trouver la manip pour XP, même déja installé, en enregistrant manuellement les drivers spécifiques de contrôleur SATA de XP. On peut donc bien éviter de réinstaller XP comme c'est partout écrit pourtant. Tout est clairement expliqué sur un post de "TTHardware" (post de Pascal Thevenier d'avril dernier) .

Déjà un problème résolu, merci !

Sinon, les kext audio et video et de clavier fr de Mowglibook n'ont pas marché pour moi (installés avec KextHelper)... Je cherche encore donc ! Vais bien finir par trouver, hein ?

pour l'ahci faut installer des pilotes spéciaux sous windows xp. Souvent des pilotes de chipset intel mais je ne saurais pas t'en dire plus ça dépend du controleur de stockage de ta carte mère.
En tout cas pour moi j'avais du les installer pendant l'installation d'xp avec une disquette puisque l'ahci était activé au moment ou je l'ai installé.

J'espère que ça te donnera une piste



#96
promethee54

promethee54

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
Yes, j'y suis enfin arrivé ... A faire booter mon pc sans le CD de boot 132.

Tous les Kext sont installés :D

Copie de mon Terminal au NB2 :

Last login: Thu Nov 13 00:59:22 on ttys000
somemodelpr0-de-j-b:~ HackPro$ sudo -s
bash-3.2# diskutil info / | grep Identifier
Device Identifier: disk0s2
bash-3.2# mount_hfs /dev/disk0s1 /Volumes/EFI
mount_hfs: realpath /Volumes/EFI: No such file or directory
bash-3.2#


Il ne trouve pas l'EFI ?

Il me reste installer le driver de ma CG (8600 GTS 256 Mo) après un test avec EFI STUDIO, je n'ai jamais pu rebooter, me voilà donc sur une nouvelle instal.
Quelle solution me conseillez vous :P ?
En parrallele, j'ai téléchargé le Kernel Voodoo avec le lien du tuto et dans le dossier compressé il y a plusieurs fichiers.
Est-ce voodoo_beta2 que je dois renommer en "mach_kernel.voodoo" pour suivre le tuto à la lettre ?

Merci de votre aide je désespère ...

#97
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

Yes, j'y suis enfin arrivé ... A faire booter mon pc sans le CD de boot 132.

Tous les Kext sont installés :D

Copie de mon Terminal au NB2 :

Last login: Thu Nov 13 00:59:22 on ttys000
somemodelpr0-de-j-b:~ HackPro$ sudo -s
bash-3.2# diskutil info / | grep Identifier
Device Identifier: disk0s2
bash-3.2# mount_hfs /dev/disk0s1 /Volumes/EFI
mount_hfs: realpath /Volumes/EFI: No such file or directory
bash-3.2#


Il ne trouve pas l'EFI ?

Il me reste installer le driver de ma CG (8600 GTS 256 Mo) après un test avec EFI STUDIO, je n'ai jamais pu rebooter, me voilà donc sur une nouvelle instal.
Quelle solution me conseillez vous :( ?
En parrallele, j'ai téléchargé le Kernel Voodoo avec le lien du tuto et dans le dossier compressé il y a plusieurs fichiers.
Est-ce voodoo_beta2 que je dois renommer en "mach_kernel.voodoo" pour suivre le tuto à la lettre ?

Merci de votre aide je désespère ...


1 - Normal il faut que tu tu crées un dossier /Volumes/EFI où monter le volume...
sudo mkdir /Volumes/EFI

2 - Pour le mach_kernel je te conseille plutôt de le mettre sur le disque système (si tu peux booter sur le kernel original... en cas de mise à jour il sera remplacé). Donc tu le places sur le bureau, tu le renommes mach_kernel et tu fais :
sudo cp ~/Desktop/mach_kernel /mach_kernel


#98
kiki69

kiki69

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
Bonjour,

Après la commande, diskutil list :
disk0 Fdisk
disk0sx WINDOWS NTFS
disk0s2 MACPARTITION
Laquelle est l'EFI?

En ayant un doute,j'ai voulu re-installer l'EFI à partir de OSXTools, j'ai installé EFI Chameleon et au démarage, j'ai
boot0 :MBR
boot0:done
puis j'ai un kernel panic sur ma partirion OSX au début. Toutefois j'arrive à booter sur Windows (j'y suis :dev: )

Je n'ai qu'un seul disque dur en double boot avec OSX et Win. J'avais installé au début une iDeneb 10.5.4 où tout marchait bien ;)

Alors là, je voudrais faire une clean install avec la méthode RETAIL. Cette méthode doit se faire à partir d'une installation de OSx déjà existante, non?
Quels conseils me donner vous pour faire une installation correcte?
J'ai déjà essayé la méthode boot132 + DVD Retail mais je reste bloqué au début de l'installation OSX avec la souris/roue multicolorée.

merci

#99
PM!

PM!

    Dodo vé pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 947 posts
  • Gender:Male
  • Location:Brussels

Bonjour,

Après la commande, diskutil list :

disk0 Fdisk
 disk0sx WINDOWS NTFS
 disk0s2 MACPARTITION
Laquelle est l'EFI?

En ayant un doute,j'ai voulu re-installer l'EFI à partir de OSXTools, j'ai installé EFI Chameleon et au démarage, j'ai
boot0 :MBR
 boot0:done
puis j'ai un kernel panic sur ma partirion OSX au début. Toutefois j'arrive à booter sur Windows (j'y suis ;) )

Je n'ai qu'un seul disque dur en double boot avec OSX et Win. J'avais installé au début une iDeneb 10.5.4 où tout marchait bien ;)

Alors là, je voudrais faire une clean install avec la méthode RETAIL. Cette méthode doit se faire à partir d'une installation de OSx déjà existante, non?
Quels conseils me donner vous pour faire une installation correcte?
J'ai déjà essayé la méthode boot132 + DVD Retail mais je reste bloqué au début de l'installation OSX avec la souris/roue multicolorée.

merci


Si tu avais lu le tuto corectement tu aurais vu qu'il faut une table de partition en GUID et non en MBR. Il esr donc normal que tu n'ai pas de partition "EFI".
@+
PM!

#100
kiki69

kiki69

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
Salut,

c'est clair que je n'avais pas tout compris :P
J'ai enfin réussi à installer mon DVD de Leo avec la méthode de boot 132. J'ai un KP au démarrage certainement dû un .kext
J'ai choisi de continuer en passant directement sur ton tuto, et je démarre grâce au CD de boot 132

J'ai moi aussi l'erreur
package 0 didn't get en HPET
j'ai supprimé AppleEFIRuntime, AppleIntelCPUPowermanagement. Je vais faire la MAJ combo et voir si cela change quelque chose.

Toutefois, en enlevant ces fichiers, je n'ai plus une install retail, donc j'aimerai trouver une autre solution :unsure:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy