Jump to content

ATI Radeon HD pkg installers 10.5.x & 10.6


  • Please log in to reply
2377 replies to this topic

#1
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
Please note this: THIS DOES NOT WORK ON SNOW LEOPARD NO MATTER WHAT YOU THINK, WISH, WANT, BEG AND BRIBE ME WITH SOMETHING IT SIMPLY DO NOT WORK WITH SNOW LEOPARD THE 10.5.X INSTALLERS

PS. ATI Radeon HD Mobility is not working its "SEMI WORKING! only external screen works on 2xxx series in Tiger & Leopard" for more questions i will redirect them to apple support ask them to add in the next revision of macbooks & pro's ATI Radeon HD 6870 mobility.


ATI Radeon HD Update: almost the last day in feb

CycloneFr has a mde a pkg for all 3870x2 users :( give big thanks to him

ATI Radeon HD 48xx WORKS NOW ! with 10.5.7 kexts and some other tweaks but seems to be a great thing

ATI is not dead yet ! :D


If anyone would like to get in direct contact with me you will find me in the #RadeonHD channel @ irc.osx86.hu server


Link for the installers untill have the first post fixed


Also Give thanks to Netkas, Eps, JaS, ParanoidDK (Paranoid) and all the testers in #RadeonHD channel :D


Snow Leopard Pkgs coming soon for 46xx & 4xxx


Mobity: 3650 test Download



Snow Leopard 10.6.x

ATI Radeon HD 43xx

ATI Radeon HD 46xx

ATI Radeon HD 48xx



NO Tiger support too old Pm if needed a pkg for Tiger

ATI Radeon HD 2400 Pro AGP
Device ID: 94c4
Download

ATI Radeon HD 2400 Pcie Series
Device ID: 94c1, 94c3
Download

ATI Radeon HD 2600 Pro AGP
Device ID: 9587
Download

ATI Radeon HD 2600 XT AGP
Device ID: 9586
Download

ATI Radeon HD 2600 Pro Pcie
Device ID: 9589
Download

ATI Radeon HD 2600 XT pice
Device ID: 9588
Download


ATI Radeon HD 2900 Series
Device ID: 9400,9401,9402
Download


ATI Radeon HD 3450 & 3470 pcie
Device ID:

Coming soon

ATI Radeon HD 3650 pcie
Device ID: 9598
Download Intel

Download AMD

ATI Radeon HD 3650 AGP
Device ID: 9596

Download

ATI Radeon HD 3690
Device ID: something
Coming soon...


ATI Radeon HD 3800 series
Device ID: 9501, 9505
Download


3850/3870 For all AMD users out there
Download


New ATI Radeon HD 3870x2
Device ID: something
Download


#2
borisbadenov

borisbadenov

    InsanelyMac Sage

  • Just Joined
  • PipPipPipPipPip
  • 345 posts
  • Location:Hyde 2612
I want to first thank you folks for making my life so much easier. I have just installed an ATI HD 2600 Pro pci-e 512mb card (dev id:9589) on my rig (specs below), and using your installer, it was a snap to get my card working 100%. So much nicer than getting my hands dirty in a text editor.

Well done lads!!!

ps: my card has two dvi ports and with this patch, I can use both ports and run the monitors in extended mode.

#3
Tobbz

Tobbz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I had problems with my HD 2400XT DevID: 0x94c1 , so many problems that i ditched OSX86, and installed ubuntu on my box.

I'm waiting for people to report back on 2400XT's, before i nuke my ubuntu and install OSX86 again, and try your pkg. But thanks for your effort lastExile! It looks like you and Netkas put a lot of work into this, so thumbs up from me.

#4
filemonstertest

filemonstertest

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Works !

Not in first place. I still had the black screen on my Dell 30".

Then i tried to boot with : "Graphics Mode"="2560x1600x32" (without @60 because this causes my pc to reboot), and it worked ! Full QE/CI !! :wacko: :) :)

(but haven't tested dual-display yet...)

Thanks A Lot !

P.S.: Does anybody know how to add the "Graphics Mode"="2560x1600x32" command as default ? (so it launches it a every boot)

#5
Tobbz

Tobbz

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I took the chance, and installed ATI Radeon HD 2400XT pcie. I have a DevID 0x94c1 card.
It didn't work. Stripes and dots.. screen goes haywire.


[EDIT]

I use two monitors.. one on the VGA output, and one on the DVI output.
If i have both on, both screens goes haywire. If i only have one on the VGA, it gets stock on the grey loading/boot screen.

[EDIT2]

I need my machine, so i removed OSX86 again.. Sorry, but i just need things to work, so it's back to ubuntu.

#6
PM!

PM!

    Dodo v pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 943 posts
  • Gender:Male
  • Location:Brussels
Working great on HD2600PRO 512 PCIe !
Thank's !

PS: Does it fix the high GPU temp ?

#7
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
i will update some of the installers :hysterical:

#8
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
ATI Radeon HD Series for tiger is coming soon .. :)

ATI Radeon HD 2400pro, 2600pro&xt and some others

#9
fauxfur

fauxfur

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
ATI Radeon HD 2600 XT (0x95881002) working great. DVI working (only one tested), QE/CI:

ATI Radeon HD 2600 XT:

Chipset Model: ATI Radeon HD 2600
Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9588
Revision ID: 0x0000
ROM Revision: 113-B1480A-236
EFI Driver Version: 01.00.236
Displays:
DELL 2005FPW:
Resolution: 1680 x 1050 @ 60 Hz
Depth: 32-bit Color
Core Image: Hardware Accelerated
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Supported
Rotation: Supported
Display Connector:
Status: No display connected

Thanks a lot! :thumbsup_anim:

#10
DJLunacy

DJLunacy

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
I have two 2600 XT's (512MB) will this allow me to finally use my third LCD?

#11
wolfvn

wolfvn

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have asus eah3450 256mb pcie 2.0 (id:0x95c51002) it didnt work.

#12
MasterRU

MasterRU

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
i have asus radeonHD 3650, i have white menu problem


(i am Master in #RadeonHD)

#13
sam2062

sam2062

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
No work with my Radeon HD3850, blue screen in 10.5.3

#14
roadster

roadster

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Sorry, no joy with 2400XT (0x94c11002). Tried multiple configs (clean install with no graphic drivers whatsoever, with GMA3100 for integrated MB graphics, etc...), always dotted screen.
However after screen saver pops in, some chunks of screen make sense so I suspect som memort address offset issue. Does RAM size on graphic card make any difference ?

Keep trying !

#15
LowRadiation

LowRadiation

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
i'll be the guinea pig for mobile hd2600 :)

#16
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
will fix some of the installers in a few mins ... adding some older tiger drivers also

#17
DJLunacy

DJLunacy

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
THANK YOU!!!

I upgraded to 10.5.3 and it hosed my video drivers..

Now I Have CE once again

I used this installer

ATI Radeon HD 2600pro PciE

Device ID: 9589

Although what is odd (and this happened with my last set of drivers)

I have two of them installed

One is reported as 512MB (Main) and the other 256MB.

I have my crossfire connector still bridging the two cards.

Is there any way to be able to use two additional displays?

I have another LCD and a LCD TV that I would like to connect as well?

Thank You

#18
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

THANK YOU!!!

I upgraded to 10.5.3 and it hosed my video drivers..

Now I Have CE once again

I used this installer

ATI Radeon HD 2600pro PciE

Device ID: 9589

Although what is odd (and this happened with my last set of drivers)

I have two of them installed

One is reported as 512MB (Main) and the other 256MB.

I have my crossfire connector still bridging the two cards.

Is there any way to be able to use two additional displays?

I have another LCD and a LCD TV that I would like to connect as well?

Thank You




Post a screenshot of that window .. maybe !

#19
scho

scho

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Do I need to be running 10.5.3 for this to work? I tried the HD 3850 on a zephyroth 10.5.2 to no avail.

Here is my setup:

MB: GIGABYTE GA-M57SLI-S4
CPU: AMD Athlon 64 X2 5000+ Black
GPU: GECUBE GC-XHD3850PG3-E3R Radeon HD 3850 512MB

I get vertical bars after the loading screen. I have to safe boot to get anything to work. Any suggestions (for a 10.5.2 setup) would be appreciated!

#20
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years

Do I need to be running 10.5.3 for this to work? I tried the HD 3850 on a zephyroth 10.5.2 to no avail.

Here is my setup:

MB: GIGABYTE GA-M57SLI-S4
CPU: AMD Athlon 64 X2 5000+ Black
GPU: GECUBE GC-XHD3850PG3-E3R Radeon HD 3850 512MB

I get vertical bars after the loading screen. I have to safe boot to get anything to work. Any suggestions (for a 10.5.2 setup) would be appreciated!


No the installer should work fine on any 10.5.x installs oh tho report back if it doesnt work and i will repack the pkg and correct it





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy