Jump to content

AppleHDA v2.6.11 (10.9.3 ) for CX20590 v2.6.1

File Information

  • Rate File: * * * * - 3 Votes
  • Submitted: Oct 08 2013 02:56 PM
  • Last Updated: Jun 25 2014 04:13 PM
  • File Size: 1.53MB
  • Views: 6958
  • Downloads: 848

Previous Versions

  • 16 Oct 2013 Download AppleHDA v2.5.2 (10.9 GM) for CX20590 v2.5.2
  • 08 Oct 2013 Download AppleHDA v2.5.2 (10.9 GM) for CX20590 v2.5.2

Download AppleHDA v2.6.11 (10.9.3 ) for CX20590 v2.6.1



AppleHDA CX20590

patched version of AppleHDA for CX20590 for 10.9.3 - use layout ID 12 - see DSDT included. (thanks manwe150)
platform and layout12 have definitions for laptop and thinkpad dock ports.
will auto switch (sense) on presence of headphones with or without microphone.

What's New in Version v2.6.1 (See full changelog)

  • updated to 10.9.3 version.
  • most recent T420 DSDT added - see HDEF and HDMI Devices for examples.




Thx a lot!

I tried it. The sound is like {censored}, not noisy, but keeps on and off. Any idea on how to fix it?

 

Btw, 2.3.7 version works perfect on the same machine.

hmm. works fine on a Lenovo laptop? are you saying sound is going on and off? i have seen this on my other hack (mini-mac), where it puts the sound to sleep and then wakes it (with a pop) - had to change to MacPro3,1 (which does not put sound to sleep). what machine type do you have?

hmm. works fine on a Lenovo laptop? are you saying sound is going on and off? i have seen this on my other hack (mini-mac), where it puts the sound to sleep and then wakes it (with a pop) - had to change to MacPro3,1 (which does not put sound to sleep). what machine type do you have?


I'm using Lenovo IdeaPad U410. I know some Lenovo thinkpads work perfectly fine with this kext in 10.9, but not on mine.

What u mean by sound sleep and wake? And how did u fix it? On my machine, the sound is perfect for the first couple seconds, then volume goes down till disappeared completely. Then it goes back again quickly, but the sound is not continuous anymore. It sounds like poor signal on ur phone.

I wonder if the layout ID causes this problem, or something has changed inside applehda? I also know some alc269 have the exact problem as me. Bit there is no more clue they could tell.

Finally I figured it out! I believe the problem is related to CPU/FSB frequency. Somehow the older version of Clover uses the wrong configuration for CPU speed, put FSB as 100MHz instead of 99MHz. Problem solved in newer version of Clover. Nothing to do with AppleHDA or DSDT.

great news. yup. i had a similar issue with early versions of clover. now clover (> 2k) computes speed properly before it would be 10300? I used to hard code 99700 in config.plist.

clover 2236 bootlog:

Finally: Bus=99676kHz CPU=2491MHz

I have been having some issues with my AppleHDA on a U410. Everything is functioning --- perhaps I am just being nit picky, but I have been trying to get the menu bar applet to sync up with the volume indicator fnkeys. I have done a codec dump and looked at everything (my line in pin config is different so I had to adjust that) but otherwise the layout config is the same, can you tell me if you have a similar issue?

 

I have reviewed other fixes for this, example on the HP ProBook and solution was to correct their layout by adding the mixer/selector node for the internal speaker; however the internal speaker doesnt map through a mixer/selector...

 

My codec was marketed to me as being the CX20672 but dumps out of Linux as CX20590...  Are they one in the same rebranded? Is linux incorrectly ID'ing my codec?

 

I know there are multple questions here and I didnt quite know where to post this reply so I thought maybe on the kext.. if you can offer any help with this it would be much appreciated. 

I have been having some issues with my AppleHDA on a U410. Everything is functioning --- perhaps I am just being nit picky, but I have been trying to get the menu bar applet to sync up with the volume indicator fnkeys. I have done a codec dump and looked at everything (my line in pin config is different so I had to adjust that) but otherwise the layout config is the same, can you tell me if you have a similar issue?

 

I have reviewed other fixes for this, example on the HP ProBook and solution was to correct their layout by adding the mixer/selector node for the internal speaker; however the internal speaker doesnt map through a mixer/selector...

 

My codec was marketed to me as being the CX20672 but dumps out of Linux as CX20590...  Are they one in the same rebranded? Is linux incorrectly ID'ing my codec?

 

I know there are multple questions here and I didnt quite know where to post this reply so I thought maybe on the kext.. if you can offer any help with this it would be much appreciated. 

I believe the sync problem is a common issue on all cx20590 sound cards. I've asked some other ppl with this card and they all got this problem. And I don't even know there is a fix for it..

 

It should be cx20590. I checked vendor and device IDs, which is indeed cx20590. Maybe cx20672 is just another name for the card, I am not sure.

I have the same problem with this driver: No sound from internal speakers.  Only mic and headphone work.

 

Volume control is shown as functional for the Internal Speakers output, however no sound is produced.

 

Can you post the isolated DSDT changes you've made?  Thanks.

Hooray!  I was able to make this kext work with my X220t using the DXDT found here:

 

http://bbs.pcbeta.co...311325-1-1.html

 

I believe the issue is that the X220t is actually a CX20672 instead of the CX20590 that is stated in the codec dump.. or something.  Anyway, speakers, mic, and headphones work with autosensing.  Haven't tried anything else like HDMI.


34 user(s) are online (in the past 30 minutes)

11 members, 22 guests, 1 anonymous users


matthewsamuel2002, og0r, nomnom, pbrunnen, jstevens81, dunamis2009, Ramon Guerra, caspdin, Polizelli, alberto21, svt12

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy