Jump to content

Dell E510 - Leo4all Freezing w/Aperture and Adobe PSE 6 Install

4 posts in this topic

Recommended Posts

Hi there, first new thread of mine here . . . this place rules.


Anyway, so I've spent all my free time the last month with my Dell E510 trying to get it to work on Leopard. So far, I've been successful. Here's my machine:


Dell E510:

Pentium D 2.8GHz

4 GB DDR2 (4x1GB)

3 HHDs: 1) 80 GB SATA (Boot, 3 Parts, WinXP - NTFS, OSX HFS+, Win Apps NTFS) 2) 160GB SATA (MacData HFS+), 3) 250GB ATA, NTFS

PNY Verto 256MB GeForce 7300GS (NVInject .41)

Everything else stock and basic.


First, I installed iATKOS i.0i 10.5.1, and it was good, I got all my hardware working, but the CPU fan tended to run high all the time. Plus, I wanted to run Aperture, and it wouldn't run without 10.5.2 proper at least with my videocard.


So I got Kalyway's hacked updater, after everyone said it would work, and followed the instructions to run the kernel updater before reboot. Did that but forgot to repair permissions. Fixed that problem but got kernel traps on boot. Tried replacing the kernel with no success.


So I installed Leo4all 10.5.2 - What a great install. All sorts of bundled apps, more hardware support, and NO CPU FAN Madness! Got my hardware working and everything's copacetic. Aperture works well, too.


It runs day and night with no issues, except sometimes I'll be doing something and it just freezes.


At first I thought it was spotlight trying to index the NTFS volumes. So I killed spotlight using Spotless.


I've had it happen 2 more times in the interim and I'm worried.


The first time I was importing about 2000 images into Aperture (a fresh library, that's a whole other story). It was generating previews and I switched images, and bam. Frozen.


The second time was last night. It was installing Photoshop Elements 6 (don't sniff at the elements word, it's a 2.5gb proggie), and it I had a bunch of other stuff open (Safari etc), it was almost done, and it's froze.


When i reboot, the activity monitor shows NOTHING on any logs.


So I got to thinking, my computer uses the same chipset (945) as the Mac Mini, but the Mac Mini has a 3gb memory limit, if you install 4, it shows 3 and change.


Now, on a mac, that's no problem, but on a hacked kernel, if my machine tries to go access the upper echelons of the memory, would that cause it to freeze? Should I go to 2x1GB and 2x512? Or is it something else?

Link to comment
Share on other sites

What chipset is your controller based on? Instead of removing 2G of RAM you could just try using the bootflag maxmem=2048. Then load up aperture and go to town to see if it freezes again. The other option is network card, not sure which you are using. Some people have issues with similar to this with some types.

Link to comment
Share on other sites

My chipset is the 945 Express chipset. I have an Intel 8255x Pro/100 which took a heck of a lot of playing with to fix. It was working fine under iATKOS . . .


Wouldn't it happen more often if it was the network card? I'll try setting the bootflags and see what happens.


Interestingly, when I boot up, Darwinx86 shows 3.25 GB of ram. The activity monitor, on the other hand, is addressing 3.65GB. Kinda funky.

Link to comment
Share on other sites



I have a similar set up and also have freezing problems. In my case it happens randomly usually with the screen saver running. There default screen saver which places a series of images and zooms in and out does not work. The image just stays still. The other screen saver options work though. I don't know if this is related, but I thought I would mention it.


My hardware:

Intel Pentium 4 HT SSE3 3.2 Ghz

Dell Dimension 5150

display: Intel GMA 950

Intel 945G Chipset LGA775



Sigmatel 9220 which has has never worked for me

Intel Pro 100 LAN that works, but was painful to do it

Installed with Kalyway 10.5.2 Intel/AMD install - see my entry in the wiki HCL

Link to comment
Share on other sites


  • Create New...