Jump to content

Black/Blank screen after Apple logo


5 posts in this topic

Recommended Posts

First off, this site and all of its users are awesome!



I installed OSX Leopard (iAtkos v1.0) on a freshly formatted HD. Everything went smoothly as far as Darwin setup, partition and erase/format to HFS+, and install of OSX itself. The first boot worked beautifully with EVERY device working perfectly without any extra effort. I just wandered around and changed a couple minor settings. After a little while (15 mins or so), I shut down my laptop.


When I started back up, OSX seemed to start properly except that after the gray/white Apple logo screen with the animated spinning circle, it showed the bluish screen for only a couple seconds, then everything on my screen goes completely black. It seems as though the LCD was shut off, but the computer itself continues to run because the power light is on, the hard drive seems to be blinking occassionally, and the Wifi light is on. No matter how long I leave the laptop on (5 mins all the way up to 2 hours), it stays solid black.


Things I have tried:

1. Full re-install 3 times now with the same result. The first boot always works perfectly but every subsequent boot has a black screen.

2. Used -x in Darwin on boot and I have the same result.

3. Used -v in Darwin on boot and nothing looks out of the ordinary

4. Used "Graphics Mode"="1024x768x32@60" in Darwin on boot in hopes to override the res in case something was wrong there and I had the same problem.



Vostro 1400

14" LCD, 1440x900 native res

Intel Core 2 8100

2gb RAM

160gb 7200rpm HD

Intel X3100 integrated graphics

Pre Wireless-N card


My background:

I am an expert with Windows (any version since 3.1) but only somewhat familiar with OSX. All this hackintosh stuff is fairly new to me although I have tried and failed at getting JAS 10.4.8 to work with a previous laptop. I specifically purchased this laptop with the regular X3100 graphics card in hopes that OSX Leopard would work properly.



Please help! I would really like to transition completely to OSX and just run VMWare for WinXP but if I can't get OSX to work, I will have to switch back to WinXP :thumbsup_anim: .



Link to comment
Share on other sites

I have a similar problem, however its really not a problem. Its just OS X loading all the drivers and starting services, and my video driver just happens to be at the very end of the list. Maybe your video driver is bad, out of date, doesn't support you video chipset, or something. Try updating your drivers would be my first guess (do this using a USB flash drive with the driver from another computer and install it through the terminal on the install disk.)


Edit: After your first install did you install the hacked combo update to 10.5.2?

Link to comment
Share on other sites


I am not sure how I would install drivers using terminal when I can't see anything on my screen. Unfortunately I do not have another Mac available to me. Do you know of a relatively simple way for me to remove the older X3100 drivers and embed newer ones via WinXP so I can create a new install DVD? (I hope that made sense)



I have tried an external monitor. When I plug it in, OSX recognizes it and displays an extended desktop, as if I had a dual-monitor setup. The little Mac menu bar/strip thing at the top does not show up on the second monitor. Unfortunately no matter how many times I restart the computer, it always ends up like this.

Link to comment
Share on other sites



I have a similar problem as well, however, it only happens once in awhile after a crash. After the white apple loading screen, the display goes black but I have a mouse cursor. I've also noticed that when the screen is black like that and I right click, the cursor changes to a grabbing-hand style cursor, so the system is responsive, just not fully running I think. I've let it sit like that for hours before forcing a shutdown and rebooting. Sometimes it will take 2 -3 reboots but it will eventually reboot normally and it will be fine.


I have not tracked down exactly what is happening yet but I'll reply back if I find something. For reference, here's the specs on what I'm running:


Asus A8N-SLI Premium MB (NForce chipset)

AMD 3800+ X2 processor

eVGA Nvidia 7800GT video card

2GB PC3200 memory (2x 1GB sticks, OCZ brand, cant remember the timings)

74GB Western Digital Raptor SATA drive (OS and applications drive)

2x 300GB Seagate SATA drives (extra storage and Time Machine)

Plextor DVD burner (PATA)

Antec Smart Power 620 watt power supply

Apple 30" cinema display

Link to comment
Share on other sites


  • Create New...