Jump to content

Vista 64-Bit killed Leopard

3 posts in this topic

Recommended Posts

I had a triple boot system as follows:


Partition 1: Windows Recovery (OEM)

Partition 2: Vista Home Premium (OEM) 32-BIT

Partition 3: Leopard

Partition 4: Extended Partition:

Partition 5: Windows XP

Partition 6: Data


Everything was working fine... but I tried installing Vista Ultimate (64-BIT) and now OS X won't boot. Originally it gave me HFS+ Partition error, and I fixed it by booting off a Leopard DVD into single user mode and doing:


fdisk -e /dev/rdisk0
flag 3


which fixed the partition table (it was messed up after Vista install), and then I used Vista DVD to recover Vista booting, and used EasyBCD to get the multi-booting going. But now when I boot up OS X, it boots up, then part-way through booting it starts the shutdown sequence with no error message. Attached is a picture.


Any help would be greatly appreciated!

Link to comment
Share on other sites

Did you change your hadware or anything?


If not, i would try going into a leopard install disc, going into terminal and restoring it's boot loader.


fdisk -u /dev/rdisk0 (may differ for ur system not sure)

fdisk -f mbrboot /dev/rdisk0 (may also differ from ur system)


Then if it's restored, you may be able to select which partition u want to boot into by pressing a key at the darwin bootloader. If you can't select another partition, then just try booting mac os x again and see if it gives that error.

Link to comment
Share on other sites

Thanks for the reply!


I can get into Darwin fine after using fdisk update, but after choosing my OS X partition, it starts to boot up like normal, then starts a shutdown sequence half way through.


I didn't change any hardware...


Edit: When I boot into a DVD and try repair Disk, I get this message:

Started verify/repair volume (filesystem) on disk disk0s3 Leopard
Checking Journaled HFS Plus volume
Checking Extents Overflow file
Checking Catalog file
[color="#ff0000"] Invalid node structure[/color]
Rebuilding Catalog B-tree
The volume Leopard could not be repaired
Error detected while verifying/repairing volume disk0s3 Leopard: filesystem (... didn't catch the rest on my camera)

Link to comment
Share on other sites


  • Create New...