Jump to content

[HowTo] Fix HFS+ Partition Error


2 posts in this topic

Recommended Posts

Hello to everyone,


After looking around the board I had a hard time finding a good guide to fix the HFS+ partition error you get from reinstalling Leopard or Vista, so here's all the informations I collected. There's 3 ways I found you can fix this error :


Method 1)


If you have Vista installed on Partition 1 and Leopard on Partition 2, all you have to do to fix the HFS+ partition error is to install EasyBCD on Vista and go to the "Diagnostics Center" tab and check "Repair OS X "HFS+ Partition Error" and click "Attemp Recovery". See a screenshot here. It's that easy...


You can download EasyBCD here.


Method 2)


If you have Leopard installed on Partition 1 and Vista on Partition 2, there are to fix available :


a.) The quick and painless one:


All you have to do is re-flag the OS X partition as active.

Grab your Leopard install DVD and boot it with the -s flag to login in user mode.

From there type the following:


fdisk -e /dev/rdisk0

flag 1



Now you can reboot and you shouldn't get anymore HFS+ partition error. However, this will only work if your MBR wasn't formatted by Vista or any other software like EasyBCD, GParted, etc...


If it doesn't work you will have to go to the next step.


b.) The hard and long one:


You should try this step only if the one above did not work. This step will reset your MBR to default settings for OS X but will trash your Vista dual boot so you will have to restore it as well. To do so type the following:


fdisk -u /dev/rdisk0


Type yes at the warning and re-flag the OS X partition by doing the step a.) above.


You're now set, you should not be getting anymore HFS+ partition error. If you wish to restore your dual boot follow this guide.


There you go !

Link to comment
Share on other sites

  • 1 year later...

something really strange happened when i tried method 2. When i booted my computer something like a quick alphanumerical number starting with "0s" flashed for a couple seconds and then rebooted and then went back to the message (and so on in a loop).


i haven't tried method 1 (I don't have vista).

Link to comment
Share on other sites


  • Create New...