Jump to content

Success! ASUS P5K and Kalyway Leopard 10.5.1


7 posts in this topic

Recommended Posts

Hi all!


I had some success, finally, today after about 1 week in front of this damn screen going blind!! So i thought i would share some insights with you all, as you have helped me by posting your info up here.


First off, have a look at this thread for Charlie78's guide on the same board (cheers Charlie!) as this will help you.





My system:-


ASUS P5K (just P5K, nothing else).

Intel Core 2 Due 2.4 E6600 (Conroe, I believe)

2 GB Corsair XMS2-6400 800 MHz memory (the purple one) 2 x 1GB sticks

ATI 9200 SE 128Mb Graphics Card (don't laugh!)


NEC DVD RW ND-3500AG IDE drive* PLUGGED INTO SATA PORT #1 and jumper on MASTER on the drive.

Western Digital WDC 1600 160GB drive)** PLUGGED INTO SATA PORT #2


Play.Com 4GB Flash drive (17 quid delivered)

Motu 828 Mk II Pro Audio USB interface (not Firewire, they do a Firewire one too)

Behringer BCF2000 Midi Control Device



Realtek PCI NIC 8139 Ethernet Card - -working!


Kalyway 10.5.1 Leopard installer






*IMPORTANT! IDE optical drives wont work on this board. Otherwise you WILL get the "cannot find system/boot.plist" message. I have successfully used a Maplin IDE-SATA converter though, and it's fine. But as it was £23 I will be taking advantage of their 14 day money-back guarantee now that I got it installed :)


** I have 2 other hard drives with Windows on and another ones with music-related stuff on - but I unplug the SATA cables when booting into Leopard. - EDIT - i leave the other two drives in and can read from them in Leopard. As its NTFS and read only, i am fairly certain this isn't going to trash them as OSX can't write anything to them (correct me if i am wrong there please)


*** PS/2 Keyboard and USB Mouse mixture don't work, as I'm sure you will know if you have researched this forum. Also, USB-PS2 converters or vice versa won't do you any good as there is only a PS/2 for a keyboard on this board anyway, there isnt a mouse one. So save yourself a headache and get USB for both cos it will save you lots of time.



Ok, first things first. READ THE INSTALLER INSTRUCTIONS!!! I didn't, and had no end of grief. Turns out there is a CUSTOMISE box on the installer on the last page - click on this and install the relevant vanilla, ACPI kernals etc listed on the instructions.


I formatted as GUID partition, named Leopard. And installed EFI as per instructions. Did not select any graphics drivers. Selected the first one on the list for ON BOARD AUDIO - this works



Faultless booting now. Thank god, it's taken me ages. Actually boots about twice as fast as my mates MacBook!




On to the BIOS settings, in order of what I changed, I think, - everything else is as per "set as defaults"


Legacy Diskette A: Disabled

SATA Configuration >> Enhanced >> IDE - - - This board doesnt let you select anything else on my current BIOS (which is the latest BIOS off the ASUS site)


System Performance Settings - CPU Overclocking - EVERYTHING ON AUTO - EDIT, it appears to work fine at 3GhZ by changin the FSB ratio. Don't really need to OC though to be honest.



USB > Enabled

USB 2 Controller> Enabled >>> High Speed

Port 64/60 Emulation - Disabled

Legacy USB - AUTO

USB Mass Storage Device Config - AUTO


CPU Stuff:-


CPU ratio - Auto

C1e Suport - Enabled

CPU TM - Enabled

vanderpool - Enabled


Max CPUID Value - Disabled

Intel Speedstep - disabled



Onboard Devices


HD Audio - Enabled >>>HD Audio

1394 - Enabled

PCIE Gbe LAN - Enabled

JMICRON esata/pata controller - - - - DISABLED!!



Suspend Mode S3




Bored yet? I am.



Anyway. On Board Audio doesnt work out of the box - there are apparently ways around it but i have my USB interface and I tested it out with 99 Luftballons by Nena because that just happened to be on my USB stick, and it's fine. It's in German though...


EDIT - used the first audio kext on the list from the installer - it was working all the time i just didnt check it!


Turned on the Behringer BCF2000 and went to Audio.MIDI setup and there is a lovely picture of it.



On board Ethernet doesn't work. I don't think it ever will, unless someone comes up with a fix for the Attansic L1 Gigabit Ethernet Controller. I might just go buy the one Charlie used on his link, seeing as he got it to work.


EDIT - found a Realtek 8139 in the loft - plugged that in and used a Realtek kext i found - go to system preferences / network / type in your ip address manually - result.


Can't change the screen resolution either, however, just found an answer to that on this site, so gonna test it out when I get a chance.


EDIT - it worked "Graphics Mode"="1280x1024x32@75" on bootup, edited com.apple.boot.plist to make it permanent.


So, I just need to get hold of a copy of Logic Studio 8 and see if it'll actually do the job or not.


EDIT - yep, it works! So does Reason 4.0



Oh, and in system information it assumes I am using a Mac Pro, which is quite good fun.




Oh and one last thing, I haven't amended ANY kexts, on the grounds that i simply cannot get my head round it at the moment. So I didn't bother.


EDIT - changed the realtek one and used kexthelper. not hard to track it down.





btw i am a TOTAL noob and managed to get this going, so if I can, anyone can. Just type your error messages into Google with OSX86 next to them and you'll get the answer.


Also, I am still testing the software, most things appear to work ok. But not "X11" - keeps crashing and opening itself, not even sure what it is so going to deleted it. Also, FRONT ROW crashed to a black screen. Dunno what that is either, which means I don't need it.






Ok well the DVD drive is odd. If you leave a DVD in the computer for a while then try to access it, Finder just freezes. Also happens if you leave the installer DVD booting then come back to it later on. Its almost like the Mac "forgets" about it approx 30 seconds after it stops spinning....



Best thing, eject any DVD/CD straight after you have finished using it. Otherwise there doesn't appear to be any way out of Finder crashing if you try and access it again...


Link to comment
Share on other sites

  • 2 weeks later...

Ok since this I have also reinstalled this so I have 2 partitions - one normal one and one "backup" one in case anything goes wrong.


Last week i installed MSN messenger just for a laugh, and after that my computer wouldn't boot. not being a big fan of terminal from the installer DVD, i thought best just to start again with a spare partition to fix problems from



I have MacDrive but whenever I write anything to it from Windows my hackintosh can't boot from it anymore....hmm. So I've stopped that now.



I am now on 10.5.2 also, using the kalyway comboupdate and it's working ok. No mods or anything. It did reboot twice during install though, not once.



ASUS EN7600GT gfx card is on its way, will post back here to let you know how I get on with it.

Link to comment
Share on other sites

  • 2 weeks later...
Ok since this I have also reinstalled this so I have 2 partitions - one normal one and one "backup" one in case anything goes wrong.


Nice to see it work, m8!


I've had some problems when I use torrent programs. The system hangs and need a reboot, but only when I use torrent programs. I've tried Transmission, Azareus and several more. Have you had these problems?

Link to comment
Share on other sites

Ok, update


Got my Geforce 7300GT and yes, everything is fine - got dual screen working too. I'm using a HANNS-G HC194D 19 inch (DVI) and a Benq T701, VGA, 17 inch on it. I had to search on here to find a code to insert into the kext, but it's fine. It does take a bit of time to finally show both screens though - any idea why that is and a workaround? It's super-fast with only one screen plugged in... Oh, and the mosaic screensaver works too, which in all honesty is all you really need isn't it!



Charlie78 - I actually have Transmission working perfectly. Even Peerguardian too. In fact, my mac crashes less often then my PC! I really can't think wha the prob could be but then I am a beginner at this. I must be one of the lucky ones I guess.



Tomorrow I take delivery of a Q6600..............mmmm. So will update here when I get that installed to see if i have any issues.


Also, I'm borrowing 2 more 1GB sticks of the same Corsair RAM too to see if 4GB causes me any problems. I heard over 4GB can cause probs on this board - eventually I want to get an extra 2 x 2GB and make it a total of 6, if it'll work..



I'm hoping to give this some EXTENSIVE testing over the summer using Logic 8 to see if it'll hold up. The only thing i haven't tested is the Firewire port as I don;t have any FW interfaces. Wouldn't it be great to get a M-AUDIO card and make this a Pro-Tools rig......

Link to comment
Share on other sites

  • 4 weeks later...



Firewire doesn't work for me. Neither e-sata. Don't look like there is a ktext to fix that already ???


mobo: PK5

hackintoch : 10.5.2 kalayway

Kernel : Vanilla


Everything goes great exept that.


Excuse my english...

Link to comment
Share on other sites

  • 2 months later...

Well, i just bought a macbook Pro - its bloody bloody nice! Another hack user who has paid Apple!!


And it happily networks with my hackintosh too using a crossover ethernet cable (don't know if it needs to be crossover but it's all i had lying around) - haven't' figured out internet sharing yet but that might be my lack of osx knowledge) - currently using my macbook pro airport wirelessly, but can't get the hack to get the internet (although it passes the ethernet connection fine) - i've got file and internet sharing on both activated.



shortly i'll be getting a firewire Mbox 2 pro with pro-tools so will post here with my testing results once done.


--i still haven't tested firewire on this motherboard so maybe this will help a few people out once i've done so



i was gonna try the logic node thing at some point - again, still not entirely sure how that works - also that, apple Q-master - something about sharing processing power....might need to get a compatible gigabit ethernet card for my hackintosh - currently using a realtek one i found lying around, pretty sure its not gigabit as it came out of an old pentium 2!



one day i might patch my own install, but what's the point seeing at kalyway did such a good job! I'm currently on 10.5.2, haven't tried updating recently because to be honest i am not sure how i can work out if i am running a "vanilla" install (it's the standard kalyway disk i got from the usual source.





i love my macbook :)

Link to comment
Share on other sites


  • Create New...