Jump to content

HP Pavillion ZD8215


2 posts in this topic

Recommended Posts

Hi my name is Chasen,


Just a heads up I am total noob so reader beware. But I just wanted to possibly help anyone with a HP Pavillion zd8215 laptop. (Although I believe that this information would help anyone who has a HP zd8000 series laptop computer)


Project Hardware (Target of Kalyway install):

HP Pavilion zd8215 laptop

80gb ATA Hard Drive

ATI Mobility Radeon X600

Intel P4 3ghz

512 MB Ram (Had 2GB but had to revert back to stock 512MB ram; see problem 4)

Internal DVD drive (No external drive)



Kalyway 10.5.1


Support Computer (Computer used to burn dvd image):

Mac Pro

Stock specs

Duel Boot w/ OSX Leopard and XP Pro (via boot camp)


Software Used on Support Computer:

Disk Utility (Program on Mac OSX Leopard; Applications>Utilities>Disk Utility)

IMG Burn (Free program that burns iso images; Google it)




First major props for Kenneth M. for posting this:



First problem: (Well it is not really a problem but I wanted to add it anyways) I didn't know what to change in the bios. I looked through lots of posts but nothing about hp.


Solution to first problem: Well after going into the bios I found out that I didn't have much of an option so I left it as default.


Second problem: For some reason I burnt a corrupt or damaged .iso disk image. I used disk utility on the Mac Pro (@ 4x burn rate) to make the dvd via my Local Area Network (LAN). When I tried to burn the dvd, disk utility would not burn the dvd. I received a error message stating that the source was corrupt. I believe that this was because I encountered a blue screen of death on the HP Pavillion zd8215 when I downloaded it. (the blue screen will come into play later, so keep that in mind) So the disk image source (the torrent) was probably good. It was probably a dowload error due to the blue screen of death.


Solution to Second Problem:Ok on XP Pro side of the Mac Pro, I downloaded another kalyway .iso image using bittorrent. I burnt it using the disk utility on Mac OSX Leopard side (@ 4x burn rate) . This time the disk burnt successfully. Popped it into the internal dvd drive of the HP Pavillion. After few seconds Darwin loaded and I hit the space bar and the program began to load.


Continuing on with my install story...Ok my install got all the way to GUI (Graphical User Interface) part of the install. Formatted the disk as on using the disk utility. (Utilities> Disk Utility). I chose the name "Leopard" for the partition because I read that some where that two word names (ie Macintosh HD, Leopard OSX) might cause problems but that might be only when you are trying to duel boot with windows and linux. I also went into the options and selected MBR (Master Boot Record) on Kenneth M.'s recommendation. (***Just a side note- On my second install I could use GUID for my hard drive; make sure that the partition is set as GUID and the GUID boot loader is selected***) I finished creating the partition and closed the disk utility. I selected the disk at the source for the install and clicked customize like Kenneth M. said:


"what I selected:

Both Vanilla Kernels


MBR Boot Loader

PLEASE NOTICE I did not select any video, sound or networking drivers."



Third Problem: Ok the program begain to install, the disk was check for errors (everything ok so far), and then I got an install error. I dont remember the exact error message but it said that my install disk was corrupt about 20% through the install.


Solution to Third Problem: By this time I thought that Kalyway wasn't going to work for me. So I deleted the Kalyway .iso image and tried a couple versions of Leopard for Pc (ie Iatkos) but eventually I came back to Kalyway. I downloaded another .iso image. So I used IMG burn to burn the .iso this time. I used IMG burn this time to see if burning @ 1x burn speed would help. I dont know if downloading the torrent again or burning the image @ 1x solved the problem but I have a strong feeling that it was the latter.


Fourth Problem: So after getting back to the GUI install part and using the suggested settings by Kenneth M. I got to the install part again. But I got another install fail error "The Installer could not validate the contents of the Essentials Package".


Solution to Fourth Problem: After some reasearch I found out that this is typically due to having some aftermarket ram that is not up to snuff or is faulty. (Remember the blue screens of death that I got on the HP Pavillion zd8215 before the install?) So I found the stock 512Mb ram and installed it. "Great success!!" The install completed and I click restart. Apon startup I took out the install disk.


Fifth Problem: Ok upon booting up the darwin would show for about 5 seconds and then the white apple logo screen would show for a second and then restart.


Solution to Fifth Problem: I took Kenneth M.'s suggestion and used "tohkernel cpus=1" at start up. So at the darwin startup I hit F8 and typed in "tohkernel cpus=1". (you don't need to put "-" infront of the command like the othe other ones like "-v"). Then the computer went to the apple screen but this time it actually booted. YAY!!! I completed the install and everthing worked (ie. wifi worked, sound worked, video worked).


Sixth Problem: I tried using the software update. It seemed to work for about a minute but then I got a error message telling me to reboot. I rebooted but it put me back in the same reboot message.


Solution to Sixth Problem: Dont use software update? (I had to do another install from scratch)


Seventh Problem: I have to use "tohkernel cpus=1" everytime I boot.


Solution Seventh Problem: ???



So in closing, in the words of Kenneth M.


"Anyways, thanks for everyone else that has posted about these problems and helped me to find my own solutions.


PLEASE REMEMBER: If you encounter a problem and then figure out how to fix it, please post your solution for everyone to benefit from. "

Link to comment
Share on other sites


  • Create New...