Jump to content

Successful OSX Shuttle install? Yes and No


2 posts in this topic

Recommended Posts

After reading about this Hackintosh stuff for some time, I came across this article, http://wildwobby.com/hardware/build-a-mac-for-350/, and decided to give it a try.



As is to be expected, I had problems and successes.



My first problem was in ordering the Shuttle from Newegg. They had a Shuttle SD30G2 Plus on sale for about the same as the non-Plus mentioned on the blog, so I ordered that.



For the processor, well, I wanted a little more speed, so I ordered the 3 GHz E8400 Core 2 Duo. I would need faster memory, so I ordered a pair of 1 gig OCZ fast memory. I ordered the same DVD drive, but when it came to the hard drive, I thought speed again, so I ordered the super-fast 150 gig 10,000 RPM WD Raptor. My computer was now twice the price.



Now, the only thing my computer had in common with the article's was the DVD drive! I should have expected problems.



I put it all together, popped DVD into the drive, and tried installing. No matter what option I tried, it would get part way through the install, and it would just stall. Stall, not install.



To the boards I go. After reading many posts, I came across one that suggested trying setting you BIOS for Standard SATA Mode, not Enhanced. Guess what? The BIOS on the SD30G2 Plus has that setting grayed out. The poster had the non-plus SD30G2 like the article. Not the faster FSB Plus like I had bought.



What to do? I know! Try an IDE DVD drive. I had an old DVD RAM drive, so I used it with one of thoes handy USB to IDE adapters and tried booting from that. No luck. It would start to load, and then report missing files and stop. What to try? I took the case off the Shuttle and hung the DVD drive off to the side with an IDE cable.



Guess what? It worked! Or so I thought. When it came time partition and format the drive the OSX would not see the drive. It only saw the DVD drive.



Gotta be that SATA problem I thought, so I opened an external USB drive I had, took out the 750 gig plain old slow WD IDE drive, and it hung off the side of the Shuttle, along with the DVD drive. Started the install again, got to the same place, and the disk utility would not find the IDE drive either! What the heck? Back to the forums, and found other people with the same problem, but no clear answer. Nothing I tried worked. Time for bed.



The next morning I looked at the mess on my kitchen table. The Shuttle with it's assorted drives hanging out. What to do? Wait, I read something about USB drives on the forums.



I tried doing an install while eating breakfast, but put my 4 gig Patriot USB drive in the front of the computer.



Guess What?



When I came to Disk Utilities, IT SAW THE USB DRIVE! I knew what I was going to do when I got home from work.



Couldn't leave work early enough. When I got home I removed the IDE drive from the PC's IDE cable and connected it to my trusty USB to IDE adapter. Turned on the computer, booted from the DVD, opened Disk Utilities – THERE IT WAS – OSX finally saw my hard drive. Did the install following the articles instructions. Went smoothly, except it took me a minute to figure out which icon was "that crazy icon." It's the one in the same folder that looks like a green monster.



But would the drive work when I placed it back in the computer? Crossed my fingers and put the computer back together. (Have you ever tried to assemble a computer with your fingers crossed? Stupid thing to do, don't try it.)



Turned the computer on, let it boot, and there it was, OSX on a Shuttle! (But with the slower IDE hard-drive and DVD drive.)


I wanted to see if OSX on my Shuttle could see a SATA drive, so I put the Raptor drive in my G5 and formatted it. Hooked it up to the Shuttle to see if it would recognize it.


No luck.



Today I ordered an USB to SATA adapter and am going to try installing OSX on the Raptor using that. I expect it will install on the drive, but when I remove it from the USB adapter and place it in the Shuttle it will not be recognized. I'll let you know when it gets here.



It must be a BIOS thing in the Shuttle. I have a Raptor boot drive and a Seagate data drive in my G5 and that works just fine, so I don't think it's OSX. As I said, the BIOS in the Plus cannot be changed from SATA enhanced to basic.


Although this is my first post to this forum, I would like to thank everyone here for all the help I have received and all that I have learned from reading others questions and answers. InsanelyMac has been a huge help on this very fun project.



Thank you all.

Link to comment
Share on other sites

Just a suggestion. Send that Shuttle garbage back while you are still in your return period. In the last year alone I've had at least 15 customers bring those things into me for repair... all had either dead mobos or power supplies... and they take forever to RMA you warranty replacements. Shuttle is trash. Send back the processor, too. Get a good supported P35 board (Check the HCLs), a Q6600 Core2 Quad (G0 stepping if you can, Tiger Direct has them for $250). Now get a nice well vented case, and a good mid priced power supply of about 650w and you'll be styling.

Link to comment
Share on other sites


  • Create New...