Jump to content

[How To] Install Leopard on a P5NSLI


3 posts in this topic

Recommended Posts

I used to own an ASUS P5NSLI motherboard. I no longer do. The reason? It is a PAIN to get working properly. Sure, it’s relatively easy to just flat out install OS X on it, but to really get everything working… that’s the trick. The main difficulty is the nforce chipset. It says it’s a 570, but really it’s a 400 series north bridge and a 400 series south bridge that magically make a 570. Thus, I was ignoring posts about nforce4 until I realized this.


Since there weren’t too many threads on this particular motherboard, I had to take the information from other threads that had similar hardware. This is a slow process, especially coupled with the time spent sitting in front of the computer waiting for the thing to boot. My original plan was to document everything I did, and then share it. That is still the plan, but there is a cavaot: since I no longer own this board, I can’t really help anymore than this. I’ll try, but I can’t just go testing stuff on it… but if anyone needs clarification, just let me know.


I used iATKOS r2. I tried kalyway, ToH, and a downloaded brazilmac disc. The only one that worked, in the end was iATKOS.


Here’s the overall outline of steps:

  1. Made sure I had the proper partitions set up (I did this with acronis disk director through windows, partitioning the os x areas as fat32 temporarily)
  2. Booted into iATKOS r2 (there is a chance that you need to specify cpus=1 to boot the dvd; I don’t remember)
  3. Used diskutility to format the partition as HFS+Journaled (MBR)
  4. Continued with install, selecting the following patches:
    • Main system (or whatever that one is called)
    • Darwin x86 bootloadSSE2 SSE3 kernel
    • Remove CPUPowerManagement driver
    • If there is a “verbose mode” one, I selected that too

[*]Installed, and rebooted. Kernel panic: either temporarily remove the NVDAResman kext, or edit it to contain your vendor/device ID (mine is: 0x039110de)

[*]Hopefully I got to the setup wizard… although I may not have. I think I needed to use cpus=1 to get there.

[*]Installed NIC, graphics card, sata controller (w/ 128gb fix) :: see below

[*]Installed EFIv8: basically, put the files somewhere on your hard disk or flash drive, boot into single user mode, and run the included script (this produced immediate restart)

[*]Installed golden kernel kexts and kernel manually

[*]Put a bunch of vanilla kexts back in once I could boot w EFI (using golden kernel)

[*]Read a LOT of posts

[*]Discovered nForce-specifically-compiled "vanilla" kernel on IRC (osx86scene), which let me boot using EFI and without using cpus=1

[*]Installed Paragon using osx86scene patch

Of the above, I believe that the golden kernel stuff was all unnecessary. If I had known about the nforce kernel before that, I would have installed EFIv8 and used the nforce kernel. However, I’m not sure if doing that golden stuff helped me, so I’m including it here. I recommend that you skip that step unless something doesn’t work.


OK! Below are my actual “notes” and “thread in progress” that I was using to keep track of my install. At the end, I don’t reference the nforce kernel, because by that point I was so sick of taking notes and could barely even think straight as to what I had done. It’s included because perhaps reading through it will do two things: help somebody else who’s had trouble, and display how many obstacles this board makes you overcome. Follow the directions above, using below as notes, and of course make sure you read the whole thing. It’s helpful. Also, the specs were going to be for the HCL post, but as I started typing it out, I realized this needed its own thread.


Post your successes failures below, I’ll help with what I can!


GOOD LUCK, may the (n) force be with you. Always.


************** BEGIN SEMI-RANDOM RAMBLING NOTES **************


First my specs:


Current OS X Version: 10.5.1 (requires cpus=1 switch to boot until nforce kernel)

Install Method: iATKOS r1 NO EFI/Vanilla

(tried EFI/vanilla kernel, panic everytime)(needed cpus=1 switch to boot)

using MBR


Darwin x86 bootloader

SSE2 SSE3 kernel

Remove CPUPowerManagement driver

At first boot, boot into safe mode (-s switch) and remove NVDAResman.kext (I moved it to a backup folder; you need it later)


Desktop/Laptop: Desktop


Prebuilt:no, custom build



Manufacturer: ASUS

Model: P5NSLI

Version: A3

BIOS Version: 1401

Chipset: nForce 570 (supposedly: actually two nforce 400 series north/south bridge!)

Audio: SoundMAX ADI AD1986a (worked out of box)

LAN: Marvell Yukon Gigabit Ethernet (88E8001) required skge.kext http://forum.insanelymac.com/index.php?showtopic=15700



Model Number: Core 2 Duo 6600 (2.4gHz, O/c @ 2.53gHz)

Recognized as: Core 2 Duo 6600 2.53gHz


BIOS Settings: none that I can think of



DDR2 PC25300 Kingston ValueRAM: 2x1gb, 2x2gb (dual channel)



Manufacturer: BFG

Model: 7600GT

Bus Type: PCI-e 16x

Memory Size: 256mb

Dual Screen working: unknown

QE/CI working: Yes

Resolution Changeable: Yes

Required Patches: DiaboliK Dual Installer (http://diabolik1605.com/DHF/index.html, 10.4.9 nvidia installer) AND put NVDAResman.kext back, edited it and GeForce.kext to contain my dev/ven id (0x039110de)


SATA/IDE working:

YES using NForce SATA Controller : http://forum.insanelymac.com/index.php?showtopic=77071

with 128gb fix: http://forum.insanelymac.com/index.php?s=&...st&p=419116 (steps 1-3)


PCI Cards:

a firewire card that I've forgotten who made it

Creative XtremeGamer (obviously not working)


IDE Channel 1:

250gb Western Digital (PATA, Master)

  • A New Hope

320gb Western Digital (PATA, Slave)

  • Leopard (HFS+ Journaled)
  • TestCenter (HFS+ Journaled)
  • Return of the Jedi (NTFS)

IDE Channel 2:

  • LG 18X DVD-RW (Single/Master: this is a PATA drive, not SATA)


160gb Western Digital

  • Attack of the Clones (NTFS)

500gb Seagate

  • Empire Strikes Back (NTFS)

500gb Seagate

  • The Phantom Menace (NTFS)


installed pc_efiv8, then used nforce efi kernel from osx86scene irc channel.

put dsmos.kext into extensions folder from iatkos disc.

put vanilla AppleACPIPlatform.kext back in.

put vanilla AppleSMBIOS.kext back in, clock now reported as 3.4gHz, and correct BIOS rom information reported. Geekbench still reports stock system info (reports as 2.4gHz, actually o/c to 2.53).

Put vanilla kexts back in:


Next, that pesky booting with cpus=1. I tried so many different boot options and parameters, from trying efi, vanilla, -s, -x, etc. In the end, I used the "Golden Kernel" linked in this post: http://forum.insanelymac.com/index.php?showtopic=73199. I haven't been able to find too many details on what exactly it is, but I do know that it is version 9.0.0 XNU, not ToH or kalyway or anything. At least, that's what it reports. The golden zip files come with a script, called postpatch... I never used it. I manually backed up all the kexts from my own /System/Library/Extensions folder that were listed in the golden.zip/Golden/files/extensions. Then, I copied all of the extensions from the golden zip (make sure you DO NOT copy the Natit.kext!) into my /System/Library/Extensions/ folder. Of course, I did all this as root (sudo -s). The last thing I did regarding the golden kernel is to copy the actual kernel itself. I copied it to the root of my Drive (/), but renamed it to be mach_kernel_golden. This way, I still had my old iATKOS kernel if I needed it.


Check permissions. the golden kernel's permissions should match the mach_kernel permissions. Also check the extensions folder to make sure nothing got screwed up there permissions-wise. If you were using sudo -s, it shouldn't have.


At this point, reboot. At the Darwin boot prompt, type the following: -v -f mach_kernel_golden and hit enter. This will boot with verbose mode on, force OSX to reload all the kexts, AND use mach_kernel_golden as the kernel, instead of the mach_kernel it was using before.


Hopefully, it should have booted to the desktop.


Mine did not at first. It actually took a couple tries of alternating between cpus=1 and not (all the while using mach_kernel_golden). And then I gave up. I said screw it, I'd try more in the morning. I could always boot with cpus=1, and I'd work more on it later.


So the next day, I figured, I'll boot it into safe mode (-v -x) without using the cpus=1 switch... and bam! Desktop! From that point on, I was able to boot into normal mode (and afterwards without using the -x switch).


I edited my com.apple.Boot.plist to have the following options:


mach_kernel_golden as the kernel


Along the way, I tried booting the following kernels: tohkernel (from kalyway disk), mach_kernel (from kalyway disk), vanilla (from kalyway disk). Each of these resulted in a kernel panic, i believe having to do with my dual cores. I haven't yet looked on the iATKOS disk to see what other kernels are on there.


Last obstacle: ntfs read/write support. Paragon worked right out of the box, except for one partition. Apparently, Paragon NTFS doesn't like Logical Partitions, as once I installed paragon, OS X would no longer mount my Return of the Jedi drive (but before it was fine). It was my only logical partition. I used acronis to move it elsewhere and copy it back as a primary partition. That took... well. That took forever (270gb across two drives... twice!).


However, before you install paragon, follow the instructions here (http://forum.osx86scene.com/viewtopic.php?f=13&t=3117&p=22636#p22321) on how to patch it so that if the trial wears off, it doesn't completely NUKE your ntfs read support!


That about does it...


If anyone wants more detailed instructions, let me know. I didn't type out the command line stuff because it's good to know the theory behind that stuff, and then look up the how. But if someone is really lost, let me know. Also, I may have missed one or two things that I did. I tried to keep track of everything as I was doing it, but who knows if a combination of two things that didn't work equal something that did!


************** END SEMI-RANDOM RAMBLING NOTES **************

Link to comment
Share on other sites

  • 1 month later...

Can you check your pms please? I know you haven't been on the forums in a while but I'm hoping you might be able to help me...


Ok, I got osx86 working on my pc, I plan to write up some notes and instructions on the process a little bit later. There's not a whole lot more to say, but like many others, I have my story. I pretty much followed Kirby's post, but there are some extra kext deviations, etc. I'll write it up so anyone who has similar hw can gain some insight.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, here goes:


First, my specs:


Processor: Intel Core 2 Duo E6300 @ 1.86 GHz/each

RAM: 1 Gig



Model: ASUSTeK Computer INC. P5NSLI

Chipset: nVidia nForce 570 SLI Intel Edition + MCP51 (i think it's an nForce 4, not sure)

BIOS: Phoenix - AwardBIOS v6.00PG


Video/Graphics Card: nVidia GeForce 7600 GS (G73) (256mb)

Hard Drive: SATA (Serial ATA-II) 250GB - BIOS says first master, hwinfo prog says secondary master...


Audio: nVidia MCP51 - High Definition Audio

LAN: Marvell Yukon 88E8001/8003/8010 PCI


So I was originally following mysticus' guide to install leopard on nforce chipsets using iatkos v1.0ir3. I got the image, burned it correctly and at low speed, but no matter what, the dvd would not boot into the installer. I tried all the flags and modified all my bios settings, which are pretty limited, to no avail.


So, I decided to dust off my 500gig usb external hdd and install leopard on that using another computer. So, I booted up the iatkos dvd on another computer and installed leopard onto my hdd with these options:


-darwin bootloader

-nvidia 256mb graphics drivers

-Marvell Yukon Gigabit Ethernet Drivers


I DID NOT select a kernel to install, because, as per kirby's post above, I was planning on replacing mach_kernel with the nforce kernel. So, it installed fine and I went to boot it up on my actual computer (the one that wouldnt boot my dvd). Before booting, I renamed mach_kernel to mach_kernel.bak and copied the nforce kernel over to my installation from XP using transmac. I booted. Kernel panics. I saw what was giving me errors: kexts from hell.


So, depending on which kext appeared in the kernel panic dialog (booting with -v obviously), I just rebooted into windows and copied the kext to my internal disk, deleting the kext from the mac install. I ended up deleting:


-AppleIntelCPUManagement.kext (should have selected that install option, but whatever)

-GeForce.kext (was giving me errors, so I didnt feel like messing around with it...)



To get my kb/mouse working, I changed ACPIPS2Nub.kext to a modded one found on these forums so I could use my ps/2 kb and mouse.


That's about it, really. There were no major obstacles, and now mostly everything works OTB. Only graphics (no qe/ci, but my graphics card is recognized), LAN (fails after a while, requires restart, oh well), and sleep mode (expected not to work with hacked kernel) do not work fully. I can boot quietly with no errors, and I'm happy with the results.


Hope this helped somebody. My brute and to-the-point actions and tactics seemed enough to get me into leopard, with mostly everything working.

Link to comment
Share on other sites


  • Create New...