Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
alexthevoice

[Guida] Aggiornamento Leopard 10.5.2 - 10.5.3 - 10.5.4 - 10.5.5

150 posts in this topic

Recommended Posts

La guida è valida per chi vuole installare gli aggiornamenti per la 10.5.2 / 10.5.3 / 10.5.4 / 10.5.5 ma sicuramente anche per gli aggiornamenti successivi

 

Traduco in italiano QUESTA guida in inglese ovvero quella fatta da Netkas sul suo sito ( Sito di Netkas ).

 

Iniziamo.

 

1) fatevi il backup della cartella /System/Library/Extensions/

2) scaricate dal sito apple l'aggiornamento che vi interessa

10.5.2 ==> DOWNLOAD

10.5.3 ==> DOWNLOAD

10.5.4 ==> DOWNLOAD

10.5.5 ==> DOWNLOAD

Il consiglio è di aggiornare progressivamente al numero successivo, procedendo di un passo alla volta (certe volte gli aggiornamenti per passare per esempio dalla 10.5.2 direttamente alla 10.5.5 hanno comportato problemi).

 

ATTENZIONE! NON USATE SOFTWARE UPDATER!

 

3) Avviate l'installer e appena apre il programma "Installer" aprite il Terminale ( Applicazioni => Utility )

 

4 ) digitate:

 

sudo -s

 

ed inserite la vostra password x avere i permessi necessari (NB: DOVETE AVER IMPOSTATO UNA PASSWORD! Se non l'avete impostata, fatelo prima di eseguire questa guida!).

 

5 ) copiate ed incollate TUTTA LA STRINGA CHE SEGUE ORA:

 

while sleep 1; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done

 

e premete Invio.

 

6 ) NON CHIUDETE IL TERMINALE. Fate partire l'aggiornamento e lasciatelo terminare

 

7 ) NON RIAVVIATE FINITA L'INSTALLAZIONE!!! Spostate la finestra dell'installazione e tornate nel terminale.

 

8 ) Premete e tenete premuto CTRL e C per far terminare il processo eseguito al punto 5.

 

9 ) Ora nel terminale scrivete:

 

sudo nano /System/InstallAtStartup/scripts/1

 

(ovvero entrate in editing nel file "1" creatosi con l'installazione dell'update)

 

e cercate la stringa /System/Library/Extensions/Dont Steal Mac OS X.kext

 

10 ) al posto di quella stringa sostituite con

 

/System/Library/Extensions/dsmos.kext

 

ATTENZIONE: QUESTO AGGIORNAMENTO E' RISERVATO AGLI INTEL CHE UTILIZZANO IAKTOS, KALYWAY ETC ETC ALTRIMENTI LA RIGA DEL PUNTO 10 NON E' QUESTA, BENSI' UN'ALTRA, CHIARO??

 

11 ) una volta messa la nuova stringa al posto della vecchia salvate il file premendo CTRL + O premete INVIO ed uscite premendo CTRL + X

 

12 ) per la 10.5.2 bisogna risolvere tastiera e mouse (per gli altri non serve): digitare dal terminale

 

nano \System\Library\Extensions\AppleACPIPlatform.kext\Contents\PlugIns\ACPIPS2Nub.kext\Contents\Info.plist

 

Cercate la stringa con

 

<key>com.apple.driver.AppleACPIPlatform</key>
<string>x.x.x</string>

 

(dove al posto delle x ci sono dei numeri) e mettete

 

<key>com.apple.driver.AppleACPIPlatform</key>
<string>1.2.1</string>

 

Digitate CTRL + O per salvare, INVIO per dare l'ok e CTRL + X per uscire.

Quindi digitate exit 2 volte e chiudete il terminale.

 

13 ) rimettete i kext dentro a /System/Library/Extensions/ (intendo quelli video, audio etc etc, quelli per il vostro hardware insomma...)

 

14 ) premete su REBOOT e trattenete il fiato... FATTO?

 

Bene, avviate con -v, il sistema si avvierà, quindi si riavvierà e finalmente...

 

Benvenuti in Leopard 10.5.2 / 10.5.3 /10.5.4 / 10.5.5 :)

 

immagineyt6.jpg

 

Una volta fatto postate gentilmente:

 

- Hardware

- Versione di Leo

- problemi riscontrati

 

Che sia di aiuto a tutti :)

 

ATV

Edited by Joeandmat
Aggiornamento della guida per la 10.5.3 - 10.5.4 - 10.5.5

Share this post


Link to post
Share on other sites

Funziona anche sul mio desktop, appena finito di installare. Bello no che mi veda un 3.8 Ghz!!! MAGARI!!! :)

 

immaginetm6.jpg

 

Unico kext ripristinato del vecchio 10.5.1 è stato AppleSMBios xkè mi si riavviava altrimenti, il resto invariato...

 

P.S. non lascia + scrivere i dischi NTFS, necessario reinstallare anche Paragon per chi utilizza tale funzione...

Share this post


Link to post
Share on other sites

A me si è bloccato al 30% l'installazione dell'aggiornamento con tanto di errore. Adesso come faccio a ripristare il tutto visto che non parte più nulla?

Share this post


Link to post
Share on other sites

io ho notato che time machine crasha (mentre prima non lo faceva), le immagini (i .dmg) non le monta quasi mai, e se faccio nuovamente doppio click non fa più nulla (perchè secondo il sistema sono già montate...)

ho dovuto ripristinare l'applesmbios, non perchè rilevava la velocità male, ma solamente perchè in system profiler, non mi affacciava più la schermata principale...

ah, altra cosa, andando su mouse e tastiera, non mi spunta più nulla...

che barba, quasi quasi mantengo la kalyway 10.5.1, se la 10.5.2 deve andare così...

Share this post


Link to post
Share on other sites
io ho notato che time machine crasha (mentre prima non lo faceva), le immagini (i .dmg) non le monta quasi mai, e se faccio nuovamente doppio click non fa più nulla (perchè secondo il sistema sono già montate...)

ho dovuto ripristinare l'applesmbios, non perchè rilevava la velocità male, ma solamente perchè in system profiler, non mi affacciava più la schermata principale...

ah, altra cosa, andando su mouse e tastiera, non mi spunta più nulla...

che barba, quasi quasi mantengo la kalyway 10.5.1, se la 10.5.2 deve andare così...

 

Ma difatti.... io non vedo differenze positive.... :rolleyes:

Share this post


Link to post
Share on other sites

Rettifica...

Ho formattato e rimesso la kalyway 10.5.1 e son indeciso se rimettere o no l'aggiornamento.

La formattazione è stata fatta per colpa mia, ho ripristinato i vecchi applesmbios e acpiplatform in modo errato.

 

Ora, sinceramente, non so cosa fare...

Ma per fortuna ho erbasvizzera che fa da cavia... :) :) :D

Share this post


Link to post
Share on other sites

io ho seguito l'aggirnamento con la kalyway ed quanto inizia a caricare il bootloader mi si riavvia......per sicurezza ho rimesso la cartella kext come a prima dell aggiornamento..però niente.qualche suggerimento?

Share this post


Link to post
Share on other sites

e se uno come me si becca un kernel panic mentre installa l'aggiornamento?

 

il dvd 'di base' era quello 10.5, il primo che è uscito, quello di Toh.

 

quindi niente EFI

Share this post


Link to post
Share on other sites

io ho fatto l'aggiornamento a una toh rc2 ma al riavvio si blocca appena rilevata la firewire e non c'è verso di farlo andare fra l'altro ho gia il boot che da problemi perchè devo sempre farlo partire col dvd. durante l'ibstallazione non mi ha dato nessu errore sembra andato tutto bene cosa puo essere andato storto che provero a reinstallare la toh rc2 e poi rifare l'aggiornamento

Share this post


Link to post
Share on other sites

io ho provato a seguire la tua guida. tutto ok, ho avuto un problemino per rimettere i file della cartella Extension al loro posto originale perchè mi diceva che non potevo non avendo i privilegi. Così li ho eliminati e poi li ho reinseriti. Così ho fatto il riavvio ma mi si pianta alla schermata grigia con la mela e il cerchietto sotto che gira. dopo 30-40 sec sento anche che l'HD si spegne anche se non cambia nulla sulla schermata.

 

che posso fare?

 

premetto che installando la kalyway 10.5.1 parte tutto ma volevo far l'aggiornamento perchè non trovo driver per la mia 8600GT 512Mb per la 10.5.1

 

La mia configurazione è:

 

P5K PRO <-- mi riconosce la LAN perfettamente e l'audio coi driver della Kalyway (ALC883)

Quad core INTEL Q6600

Asus GeForce 8600GT

2x1Gb Ram 800Mhz

HD SATA 120Gb MAXTOR

Audigy

 

Da cosa può dipendere?

 

Grazie

Share this post


Link to post
Share on other sites

Ho reinstallato Leopard in seguito a un fallito aggiornamento alla 10.5.2, dopo la reinstallazione però all'avvio il computer non avvia nulla, non parte ne Leopard ne la schermata di boot per scegliere l'altro OS. Parte solo Leopard se inserisco il cd di installazione..

aiutatemi per favore!

Share this post


Link to post
Share on other sites
io ho provato a seguire la tua guida. tutto ok, ho avuto un problemino per rimettere i file della cartella Extension al loro posto originale perchè mi diceva che non potevo non avendo i privilegi. Così li ho eliminati e poi li ho reinseriti. Così ho fatto il riavvio ma mi si pianta alla schermata grigia con la mela e il cerchietto sotto che gira. dopo 30-40 sec sento anche che l'HD si spegne anche se non cambia nulla sulla schermata.

 

che posso fare?

 

premetto che installando la kalyway 10.5.1 parte tutto ma volevo far l'aggiornamento perchè non trovo driver per la mia 8600GT 512Mb per la 10.5.1

 

La mia configurazione è:

 

P5K PRO <-- mi riconosce la LAN perfettamente e l'audio coi driver della Kalyway (ALC883)

Quad core INTEL Q6600

Asus GeForce 8600GT

2x1Gb Ram 800Mhz

HD SATA 120Gb MAXTOR

Audigy

 

Da cosa può dipendere?

 

Grazie

Ma hai riparato i permessi del disco?Se no fai il boot da dvd e riparali da disk utility!

Share this post


Link to post
Share on other sites

Non ho cambiato nessun permesso, anche perchè non c'è scritto nulla sulla guida a proposito dei permessi.

Ho semplicemente eliminato quei file gettandoli nel cestino così poi ho potuto prelevare quelli "vecchi" e rimetterli nella cartella.

Eventualmente non conoscete il comando da terminale per fare un copia incolla da cartella X a cartella Extension? così mettendo sudo dovrei avere anche i privilegi no?

 

Altre soluzioni?

 

P.S: Non trovo il modo di mettere la mia firma. O meglio, credo di averla messa ma non mi compare nei miei post. Dove devo andare?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×