Jump to content

Leopard Retail Install On Gigabyte GA-945GSM-S2L


3 posts in this topic

Recommended Posts

First I wanna say Thank you to all the nice people who have been providing us with great support patiently and generously


I'll move straight into the steps and I'll include the problems that faced me and the solutions I found for them right in the text where they belong so you have to read through.



What is working?

Everything is working Perfectly including graphics CI/QE, sound, network, SATA, IDE, USB, and Time Machine too

Except for Restart & Suspend. I didn't start on them yet since its a minor thing to me because I hardly restart or turn off my machine at all.


I believe this method should work just fine with any other motherboard that runs Tiger/Leopard fine. Especially the Gigabyte GA-945GCM-XXX family and the P35-DS3.


Still you will have to copy over your own Kexts from your working Tiger installation. here is a list of the files you will need to copy over, I included them in my package already:



















Please report here if it works with your motherboard



Things you have to have before going on [ i'll include links to the kits and tools at the end. No links to the Leo DMG]


1- A working installation of Tiger.

2- Spare Hard Disk. I strongly and seriously recommend a disk that has no important files on it because you will Completely Erase it in a few minutes.

2- DMG copy of retail Leopard GM on your machine or a DVD disk of it.

3- Pacifist 2.5.1 [No Key Required]

4- EFI v8.0 kit.


1- First Prepare your Hard Disk by following this great guide

Guide For EFI v8.0 Installation


in my setup I had my disk split into two partitions. the first one is 40GB and its for Leo, the rest is for file storage. you can create any number of partitions you want.



2- I had a copy of Leopard GM on my HD and I had a 160GB SATA HD to install Leo on. I attached the HD then I mounted that image and launched Pacifict V2.5.1 [its a shareware yes, but its fully functional even if you don't register] and clicked on "Open Apple Install Disks" then I browsed through the packages and selected what I wanted to Install with Command+Click. then I did a Right-Click and opted for "Install to other disk" and choose the first partition on my SATA disk.

The extraction and install process took about one hour for me, so be prepared. at first Pacifist didn't do its job, it kept saying it was extracting then when it was done I found nothing on the target drive. so I logged in a root and ran it again, this time it worked straight.


Please notice that when Pacifist prompts you to choose between Replace and Update you MUST choose Update, if not you will end up with a corrupted installation that has many utilities not working including the terminal.


3- When the installation was done I rebooted to see if it will boot into Leo with no problems. it didn't. the grey apple appeared and the little circle kept whirling but nothing happened. I booted back into Tiger and copied the files above to the Leo installation under /System/Library/Extensions/


I had to replace AppleSMBIOS.kext with the one from the EFI pack and I added the dsmos.kext too.



After moving them I launched the terminal and did the following to repair the permissions for them



cd /Volumes/<Your-Leopard-Partition-Name-Here>/System/Library/Extensions/

chown -R 0:0 *

chmod -R 755 *

cd ..

rm Extensions.*



I didnt copy the IOATAFamily.kext over because I knew my drives are working fine.


Then I rebooted into Leo again and it worked. after logging in I had Sound, Network, and Graphics working fine but I couldn't change resolution other than 1024x768.


After searching online for a while I found a hint from someone saying that updating your Leo to 10.5.1 will solve the GMA950 problem so I went ahead and updated.


When I was applying the 10.5.1 update the installer stalled at "Writing Package Receipt". I launched Activity Monitor and forced it to quit, then i rebooted the machine and hit F8 while booting to get to boot options. I then booted into single user mode with the -S switch then ran the following command


update_prebinding -force -root /

#then I did a system check with 

fsck -fy


Then I rebooted the machine and under System Profiler I found that both CI & QE are now enabled but I still can't change resolution.


It was time to boot again into my Tiger and this time I copied over my "AppleIntelIntegratedFramebuffer.kext" to the Leo installation as before and repaired the permissions again then rebooted.


Now I had everything working perfectly including CI/QE and resolution change up to 1440x900

I didnt need to replace my kernel or patch anything else which is a great thing with this board.


My BIOS Settings


-LAN Boot = ENABLED <> This prevents the built-in LAN card from hanging up if you were in Tiger and restart the machine to go into Leopard.

-USB Keyboard/Mouse Support = ENABLED <> This makes your function keys working while the machine is booting up.

-Reset Case Open Status = DISABLED

-No-Excute Memory Protect = ENABLED

-Graphics Frame Buffer = 8 MB


Here are all the necessary Kexts to save you time


GA-945GCMS2L Pack


EFI v8.0 Pack

Download from the original EFI Guide page.


You can download Pacifist from here

Pacifist home page


If you want more reading about this method please view this topic

Leopard Via Pacifist


If I missed something out or if anyone still needs another kext file you know you all are welcome.


Link to comment
Share on other sites

  • 2 months later...

Hello thanks for all your work, but one question is there a simple way to install this inside windows xp or from a windows machine?

I have no other mac here and lots of problems installing as it won't boot into Leopard.

Thanks for all your suggestions..

Link to comment
Share on other sites

  • 1 month later...
Hello thanks for all your work, but one question is there a simple way to install this inside windows xp or from a windows machine?

I have no other mac here and lots of problems installing as it won't boot into Leopard.

Thanks for all your suggestions..



Well ...I think you can try VMWare if you have XP running on the right hardware. i.e dual core processor and enough RAM for the job. But I don't think its a good idea because even if it works its going to be so slow when running. I tried it once couple of years ago on my brother's P4 Toshiba Satellite laptop and it was awful. sorry I was late in reply, I was out of the country.

Link to comment
Share on other sites


  • Create New...