Jump to content

Keyboard problem with Leopard (post-install)


3 posts in this topic

Recommended Posts


Config : Logitech Keyboard (PS/2) and Logitech MX Revolution Mouse in USB (Bluetooth).

There is my problem : Install OK, Boot OK but when I reboot after (with the introduction video of Mac) my keyboard doesn't work. I can't finish the install...

I chose Vanilla Kernel with EFI and MBR Install for Kalyway 10.5.1.

I saw this on the forum:


cp -R /Volumes/Leopard_Install_Osx86/System/Library/Extensions/AppleACPIPlatform.kext /Volumes/leopard/System/Library/Extensions/

cp -R /Volumes/Leopard_Install_Osx86/System/Library/Extensions/ApplePS2Controller.kext /Volumes/leopard/System/Library/Extensions/


But it did'nt work for me. I have also check if the kexts are present in the /Library/Extensions folder, there are here, but I've always the same problem...

Thanks for ur help ! :)

Link to comment
Share on other sites

I also have this problem. I have a generic ps/2 keyboard with a usb Logitech Mediaplay mouse. After first boot, the mouse works fine, but I have no keyboard. Both worked fine in the Kalyway 10.5.1 installer. I have tried everything in http://forum.insanelymac.com/index.php?showtopic=35972 except for adding the load/unload to /etc/rc (or /etc/rc.local, depending on which post) because I don't have one to add it to.

Link to comment
Share on other sites

Boot install DVD, go to terminal do the following:



cd "/Volumes/(name-of-OSX-partition)" <--- use quotes if name has spaces- but don't use parentheses

cd System/Library

rm -rf Extensions.mkext Extensions.kextcache

cd Extensions/ApplePS2Controller.kext/Contents/PlugIns

mv ApplePS2Trackpad.kext ApplePS2Trackpad.kext.bak

mv ApplePS2Mouse.kext ApplePS2Mouse.kext.bak



This worked fine for me. Alternatively, go to officemax and buy a 20$ USB keyboard from logitech.. which is what I did because I got sick of having to do the above every time I broke something :)

Link to comment
Share on other sites


  • Create New...