Jump to content

Check if EFI is installed on MBR based partition table


5 posts in this topic

Recommended Posts

Sorry for asking, I've been looking around quite a few posts on various forums, but I can't seem to find a way how I can check if I have EFI installed and Leopard is aware of it.


I'm running the native kernel allright. But is that an absolute prerequiste for being able to run the stock kernel? I've got a Core 2 Duo.


I have a dual boot setup with XP (still) on the 1st partition (MBR). The leopard partition is active, booting in either XP or Leopard is all swell, but I can't find a trace of EFI anywhere because I simply don't know what to look for. On a GPT based partition table you should see a EFI listing when using diskutil list. I don't see that on my MBR based disk. Can I check this with a specifice value that can be found with dd if=/dev/rdisk0s2 of=/tmp/bootstuff count=1 bs=512?


The install was pretty clean BTW. I only had to fiddle with some kexts after installation because of somewhat new hardware (Dell Latitude D830), but sofar everything works pretty much (except for powermanagement but that's a known issue) at a blazing performance. My D830 performs better with iATKOS than with the previous Ubuntu 7.10 installation.


Thanks for your time and effort.

Link to comment
Share on other sites

  • 2 weeks later...
three ways to find out:

1. easiest is to download Geekbench and run it, if it detects your computer as Mac then definitely you have an EFI installed.


2. if you have performed a successful update using "Software Update" from the apple menu then you have an EFI.


3. lastly if you performed an explicit install of EFI in Darwin Boot then you have it please refer to this post to see screen shots:

check if you have efi installed

also if you see you have no EFI installed then you can install it as a pach please this post:

HowTo: Install EFI patch and Use Unmodified OS X Kernel in Hackintosh


eh thats not right. dont know about the geekbench thing but it worked on my machine when i didnt have EFI installed. Also for the Software update thing thats also not true because when i didnt have EFI installed i was able to update mac os x software through that and it worked wonderfully. (it was only iTunes or something like) Dont tell that to people because some might be able to use software update without EFI and even with EFI you cant install the 10.5.2 update so does that mean im not running EFI? no


To check if you have EFI you should search around there is a command in the forums somewhere you can run to see if your running EFI, if not when your PC is booting it should say something like "EFI enabled" (it goes by very quick you have to look for it) and that means you have EFI installed and working.

Link to comment
Share on other sites

Type this in the Terminal:

sudo ioreg -l -w0 -p IODeviceTree | grep efi


You should see something like this. If you don't, you don't have EFI installed:

	+-o efi  <class IOService, !registered, !matched, active, busy 0, retain 7>
| |   "name" = <"efi">

Link to comment
Share on other sites


  • Create New...