Jump to content
InsanelyMac Forum
Sign in to follow this  
streambranch

iwi2200 crash and possible fix

Recommended Posts

I installed the latest stable iwi2200_wep.dmg. It worked great at the first location I tried. Then I packed up, went to a different location. nsGUI would crash every time - so would networkSelector. Debugging showed nsGUI crashing in MainController-preAction:

 

if (priv.ieee->networks[c].ssid_len>0)

{

priv.ieee->networks[c+1]=priv.ieee->networks[c];

goto rep;

}

 

c is 127 when it crashes. If I change it as shown below it does not crash:

 

 

if (priv.ieee->networks[c].ssid_len>0 && (c < 127))

{

priv.ieee->networks[c+1]=priv.ieee->networks[c];

goto rep;

}

 

An ugly hack since I don't know the first thing about how this structure is put together but it might be a clue for someone who knows what's going on.

 

Hope this helps,

 

Stream

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×