Jump to content

Rosetta Apps Crash


9 posts in this topic

Recommended Posts

Intel Core 2 Duo E4300 Allendale 1.8GHz

GeForce 8800GTS 640MB

GeIL 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel

Seagate Barracuda 7200.10 ST3250820AS 250GB 7200 RPM SATA 3.0Gb/s Hard Drive

GIGABYTE GA-965P-DS3 (rev. 1.3) LGA 775 Intel P965 Express



^My Specs^


Basically, I'm running Kalyway's 10.5.1 and I can't get Rosetta apps to run. They all crash at launch. Some (World of Warcraft installer) don't even get that far.


I know the PPC installation was cut, but was Rosetta (PPC emulation) cut altogether too? Does anybody have a suggestion or a solution?


Can I just ask: Do Rosetta apps work for you? Is it just my install?

Link to comment
Share on other sites

  • 3 months later...



Similar story here to on my setup, running Leo4Allv3 10.5.2 9.2.0 default installation's kernel on a Asus P5K & Intel Core 2 Quad Q6600, and also an Asus GeForce 8800 GT G92, with a 250gb Maxtor plugged into the JMicron Sata port set in bios to IDE. I do have full acceleration in regards to CI, and QE. I'm mainly fighting Rosetta for StarCraft to run. I've tried installing with the OS X native installer both Broodwars from a D/L'd DMG, as well as Regular SC from a legit stock oem cd of it, no change in results. Running the alias will get me the startup options with only tabs for General, and Advanced, and no matter what options I pick, I'll get asked for my CD if it's not in the drive, throw that in, and then SC's icon eventually just dies off from the dock as if closed. Any help would be appreciated. Apologies for reviving an old thread.

Link to comment
Share on other sites

I just tried duplicating the problem sucessfully with console.app opened to All Logs, no output when SC crashes. Much less /usr/libexec/oah. Hmm. Could it be a Leopard specific problem? Part of what they did to move away from G3/PPC support overall? I have a spare partition I think I'm gonna stick Tiger on from an old copy of JaS 10.4.8 and see what happens, will post back with the results. Thanks.

Link to comment
Share on other sites

Looks to me like I do indeed have oah. I outputed all relevent details from Terminal in regards to list all commands of oah's parent directory structure and internal. Everything look correct as it should be from first glance?




kevin-mcclellands-computer:libexec kevin$ pwd


kevin-mcclellands-computer:libexec kevin$ ls -a | grep oah


kevin-mcclellands-computer:libexec kevin$ ls -a oah

. .. Shims translate

kevin-mcclellands-computer:libexec kevin$ ls -a oah/Shims/

. GLEngine.bundle

.. IOKit.framework

ApplicationServices.framework Interposers.dylib

BDL.dylib libSystem.B.dylib

CoreFoundation.framework libmathCommon.A.dylib

kevin-mcclellands-computer:libexec kevin$ ls -a oah/translate


kevin-mcclellands-computer:libexec kevin$



Link to comment
Share on other sites

Not thus far, I had "MacRar" downloaded from before when I was looking for an alternate rar/zip extraction program, and I went back to it just now to check Rosetta possibilities out on it, and as presumable, circle-cross overlaped, and I went to Get-Info incase their was a check box for useing rosetta as I recall seing it around before in the early Tiger days, and no such luck. I did swap my kernel late last night btw to that of a 9.2.2 Vanilla Kernel. 667 Smbios. Gonna try installing Tiger right now to check, I meant to try it last night but didn't get that far.


Thanks very much btw Mac Brush for the support, greatly appreciating your assistance thus far. :unsure:

Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...