Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About Nightwing

  • Rank
    InsanelyMac Protégé
  • Birthday 02/11/1984

Contact Methods

  • MSN
  • Website URL
  • ICQ
  • Yahoo

Profile Information

  • Gender
  • Location
  • Interests
  1. Dell Inspiron 1545 (GM45 Video) and Lion GM

    Hi Boewulf, I replied to your PM on kexts.com but to answer the question for anyone else here, Netkas has the answer, specify in com.apple.Boot.plist as a kernel flag npci=0x2000 Let me know if it works for you.
  2. [1337] QE/CI x3100 (GMA965 0x2a02) on Lion GM

    Hoping someone may be able to point me in a good direction to travel for assistance. I have a Dell Inspiron 1525 that I have modified slightly, [swapped the CPU, Ram, and Hard Drive to a T3400, 4GB's Ram, and my Insp1545's 250gb HDD], this machine has a GMA X3100 2a02 rev C, the AppleIntelGMAX3100.kext and FB kext all load, but I am not able to get QE/CI to work no matter what I try. I have SL[10.6.7] on the machine's original drive with working QE/CI, so I've tried it's kexts, and kexts.com's 10.6.2 64-bit drivers [using them right now], no ripple effect on dashboard when I unpin it as a workspace. logging in is choppy. No transparency on finder's menu bar. Entering and exiting full-screen apps is choppy, but sliding back and forth, and Launch pad as well, are all smooth transitions. Forgot to mention that the stock kexts complain about missing info.plist and do not load at all for me, goes straight into no kext vesa only mode. I activated OpenGL with an EFI string. I've tried Graphics Enabler set to both Y & N. arch=i386 always..as 64-bit won't ever boot. I forget where it gets stuck off hand atm. I D/L'd and installed the installer from https://sites.google.com/site/nozyczek/home...l-inspiron-1525 for post-install use. Used one of the sticky usb/chameleon tutorials on the 10.7 install forum to build the usb installer, got through that no prob after replacing the few acpi kexts a lot of Dell Users have too from their SL installs. Installer DMG is good, as I first started out with a bad one that after installing would leave me stuck with a useless install that would get stuck at first time run wizard where you would pick country and keyboard language, then would just stay stuck there never moving onto networking but got around that with a little green demon's assistance. So that shouldn't be the issue. Any idea's or concepts or theories at all would be wicked awesome, and appreciated. Any further info needed, just let me know! org.chameleon.boot.plist Contents from /E/E <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Kernel</key> <string>mach_kernel</string> <key>Kernel Flags</key> <string></string> <key>SMBIOS</key> <string>/Extra/smbios.plist</string> <key>DSDT</key> <string>/Extra/dsdt/dsdt_v2.aml</string> <key>Timeout</key> <string>3</string> <key>Wait</key> <string>no</string> <key>Graphics Mode</key> <string>1280x800x32</string> <key>SMBIOSdefaults</key> <string>no</string> <key>GUI</key> <string>yes</string> <key>Legacy Logo</key> <string>yes</string> <key>Theme</key> <string>Default</string> <key>Quiet Boot</key> <string>no</string> <key>Boot Banner</key> <string>yes</string> <key>GraphicsEnabler</key> <string>No</string> <key>device-properties</key> <string>7e0200000100000001000000720200000a00000002010c00d041030a000000000101060000027fff04001e00000072006f006d002d007200650076006900730069006f006e0000002a0000004f70656e474c20456e67696e6520616374697661746564207669612045464920537472696e672a0000004100410050004c00300031002c0044006100740061004a00750073007400690066007900000008000000010000001c0000004100410050004c00300031002c00500069007000650000000800000001000000260000004100410050004c002c004e0075006d0044006900730070006c0061007900730000000800000004000000200000004100410050004c002c00480061007300500061006e0065006c00000008000000010000002e0000004100410050004c002c004e0075006d004600720061006d0065006200750066006600650072007300000008000000020000001c0000004100410050004c00300031002c00450044004900440000008400000000ffffffffffff004ca345490000000000110103802115780a87f594574f8c2727505400000001010101010101010101010101010101ee1a008050201030103013004bcf100000190000000f0000000000000000002387026401000000fe0053414d53554e470a2020202020000000fe004c544e31353458412d4c30310a0041380000004100410050004c002c00530065006c006600520065006600720065007300680053007500700070006f007200740065006400000008000000010000001c0000004100410050004c002c004800610073004c0069006400000008000000010000001e0000004100410050004c00300031002c004400650070007400680000000800000020000000 </dict> </plist> smbios.plist Contents from /E/E <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>SMbiosdate</key> <string>05/05/09</string> <key>SMbiosvendor</key> <string>Apple Inc.</string> <key>SMbiosversion</key> <string>MBP51.88Z.007E.B05.0905051508</string> <key>SMboardmanufacturer</key> <string>Apple Inc.</string> <key>SMboardproduct</key> <string>Mac-F22788C8</string> <key>SMfamily</key> <string>MacBook</string> <key>SMmanufacturer</key> <string>Apple Inc.</string> <key>SMmemmanufacturer</key> <string>Apple Computer Inc.</string> <key>SMproductname</key> <string>MacBook3,2</string> <key>SMserial</key> <string>xyxyxyxy</string> <key>SMsystemversion</key> <string>1.0</string> </dict> </plist> From System Profiler Intel GMA X3100: Chipset Model: GMA X3100 Type: GPU Bus: Built-In VRAM (Total): 144 MB Vendor: Intel (0x8086) Device ID: 0x2a02 Revision ID: 0x000c ROM Revision: OpenGL Engine activated via EFI String Displays: Display: Resolution: 1280 x 800 Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Built-In: Yes Display Connector: Status: No Display Connected
  3. Just to elaborate on your definition of "root", do you mean that you are instructing that dsdt.aml be copied to / or to the root of /Extra? So far I have just tried to the root of /Extra after renaming my previous dsdt.aml file, and modified my com.apple.Boot.plist to be identical to yours, then copied the plist to /Library/Preferences/SystemConfiguration/ This resulted for me to either have kernel panics on ACPI, or PCINetworking & co, or an unstable system where if it were left alone for say two minutes while I'm gone to get something, apon returning, it would be frozen, and need a hard reset - and no native res to boot, still 10x7, and even single user did funky things, where console messages say from dmesg where being posted while I was typing in commands to switch back to the previous dsdt.aml and that froze the machine so again a hard reset was needed. I'm not a 100% sure if I am running GM/Retail or still a developer preview heavily updated. I installed from a DP usb drive, and ran through all updates, and the build # is 11A494a, and OSX thinks this machine is a Mac Pro, not a MBP. I've thought about taking the 915 patch and trying to modify it to work against Chamel2.0 rc5 src and see where that gets me but so far no go just yet. Will keep trying different things and let you know if I have any luck, thanks again for the details!
  4. Dell Inspiron 1545 (GM45 Video) and Lion GM

    How did you get native res???
  5. system 7 on pc?

    TGP1994 - your inquiry is irrelevant and off-topic to this particular 'system 7/pc' thread, as this one is pertaining to the Codename Star Trek project of running System 7 natively on a x86 based machine without Windows and without an emulator such as "SoftMac [eww-hate saying that word]", and Fusion-PC, Basilisk II, etc. What you need to do though - is get a completely different emulator for starters - SoftMac is {censored}, ditch it. Grab Basilisk II, or Fusion if you prefer DOS enviornments, B2 has a GUI to it that's a Win32 based App so that'll probably be easiest on you. Secondly - you need to follow this guide. If you have any troubles with anything at all, feel free to PM me for assistance. I'm not always on Insanely - but I do have e-mail notifications enabled, and constantly check my Gmail. Back to the topic at hand now, did 3rd party developers ever receive such a thing as a Sys7 SDK or sample source code that might shed any wisdom or thought-trains or info on the thread topic itself at hand? Better yet, expand that question to any Classic system version.
  6. system 7 on pc?

    I never considered the fact of actually adding in the clones era to the equation of variables - smart thinking - that would make sense and suppot why Apple would even both trying a PC-clone in the first place too. Out of curiousity - does anyone know if any one on the board works at Apple as a day job? Maybe don't post back any names to this thread for obvious security reasons, but PM them, I'm just curious to ask a few in general questions such as litterature perse in a potential Apple Archives room - Marklar Panther being another thought, this and that. Nothing to risk getting anyone in trouble of course. Cheers!
  7. system 7 on pc?

    This topic having been dead for quite sometime, ResX - how did you make out on the extraction? Ever get around to it? Did it ever get uploaded anywhere? Is there any chance of even just circulating the file as is for others to potentially extract? I realize your screenshot is photoshoped, am I possibly overlooking this filename of macosinteldemo.dd also being photoshopped, etc? Appreciate your response as to what the current word is on this. Thanks!
  8. Lenovo 3000 C200 Sound Issue

    bump. Also running a JaS 10.4.8 Tiger install on a Lenovo 3000 c200, and would love to get sound going. I tried to install Leo4Allv3 on this machine too - And that didn't go so great, it dies trying to boot the dvd even with using the flags of: -v -x -s -f -legacy platform=ACPI [or X86PC And I haven't gotten as far as upgrading 10.4.8 to 10.4.11 yet, but I see certain Tiger based softwares require this from Apple amongst others so I'll eventually make that jump, but regardless, I doubt it'd net me any further on getting a kext to provide me with any audio. Also -- Under the audio category of System Profilder, all that is displayed is: "Intel High Definition Audio:" Someone who is more farmiliar with audio on OSx86, would love to hear from you, best regards. Cheers!
  9. Rosetta Apps Crash

    Not thus far, I had "MacRar" downloaded from before when I was looking for an alternate rar/zip extraction program, and I went back to it just now to check Rosetta possibilities out on it, and as presumable, circle-cross overlaped, and I went to Get-Info incase their was a check box for useing rosetta as I recall seing it around before in the early Tiger days, and no such luck. I did swap my kernel late last night btw to that of a 9.2.2 Vanilla Kernel. 667 Smbios. Gonna try installing Tiger right now to check, I meant to try it last night but didn't get that far. Thanks very much btw Mac Brush for the support, greatly appreciating your assistance thus far.
  10. Rosetta Apps Crash

    Looks to me like I do indeed have oah. I outputed all relevent details from Terminal in regards to list all commands of oah's parent directory structure and internal. Everything look correct as it should be from first glance? <code> kevin-mcclellands-computer:libexec kevin$ pwd /usr/libexec kevin-mcclellands-computer:libexec kevin$ ls -a | grep oah oah kevin-mcclellands-computer:libexec kevin$ ls -a oah . .. Shims translate kevin-mcclellands-computer:libexec kevin$ ls -a oah/Shims/ . GLEngine.bundle .. IOKit.framework ApplicationServices.framework Interposers.dylib BDL.dylib libSystem.B.dylib CoreFoundation.framework libmathCommon.A.dylib kevin-mcclellands-computer:libexec kevin$ ls -a oah/translate oah/translate kevin-mcclellands-computer:libexec kevin$ </code>
  11. Rosetta Apps Crash

    I just tried duplicating the problem sucessfully with console.app opened to All Logs, no output when SC crashes. Much less /usr/libexec/oah. Hmm. Could it be a Leopard specific problem? Part of what they did to move away from G3/PPC support overall? I have a spare partition I think I'm gonna stick Tiger on from an old copy of JaS 10.4.8 and see what happens, will post back with the results. Thanks.
  12. Rosetta Apps Crash

    Bump. Similar story here to on my setup, running Leo4Allv3 10.5.2 9.2.0 default installation's kernel on a Asus P5K & Intel Core 2 Quad Q6600, and also an Asus GeForce 8800 GT G92, with a 250gb Maxtor plugged into the JMicron Sata port set in bios to IDE. I do have full acceleration in regards to CI, and QE. I'm mainly fighting Rosetta for StarCraft to run. I've tried installing with the OS X native installer both Broodwars from a D/L'd DMG, as well as Regular SC from a legit stock oem cd of it, no change in results. Running the alias will get me the startup options with only tabs for General, and Advanced, and no matter what options I pick, I'll get asked for my CD if it's not in the drive, throw that in, and then SC's icon eventually just dies off from the dock as if closed. Any help would be appreciated. Apologies for reviving an old thread.
  13. PS/2 keyboard

    Hey guys, another interesting keyboard issue for the thread that I haven't spotted on the forums yet, I have here a buddy's Acer Aspire 1681WLMi that I just got running Tiger last night. And the following problem is applicable wiether booted from DVD or from the native install, but when first booted in, the keyboard works up until you attempt to use the touchpad mouse, if you don't use the touchpad, keyboard stays working, so much as nick that touchpad, kiss that keyboard goodbye and hello again one reboot later. External USB mouse works just fine with the keyboard, but I've caught myself a couple times defaulting to the touchpad so I'd like to see if I can sort it out. I believe it's a JAS 10.4.8 dvd that I used. Haven't gotten as far as aqquiring and testing Leopard on it yet. Other wise this machine works well enough despite no kext's being loaded at present with QE/CI for the video card [GMA 900 series intel or there abouts anyway.] and wireless was quick and easy after a little reading up between insanelymac & google with use of a USB thumbdrive, and a download of iwiDarwin for the intel2200bg, had wireless going in no time. This keyboard being cancelled out by the touchpad problem is a really good question though, haven't tried any of the above mentioned suggestions yet though, not fully convinced they are even applicable in this situation. BTW, your best bet for copying commands for acpi and appleps2 would have been [this just being right off the top of my head] are: cp -R /System/Library/Extensions/AppleACPI.kext ~/ cp -R /System/Library/Extensions/ApplePS2Controller.kext ~/ Which would have copied them both to /Users/usernamehere. ~/ = $home Thanks,
  14. Yeah I thought it was too till I discovered 'open' in an issue of MacAddict magazine I had lying around. I noticed too that Open does not have a -help or -useage switch to specify. Instead just run open as is by itself: Welcome to Darwin! kevin-mcclellands-computer:~ Kevin$ open Usage: open [-e] [-t] [-f] [-b <bundle identifier>] [-a <appname>] [filenames] Help: Open opens files from a shell. By default, opens each file using the default application for that file. If the file is in the form of a URL, the file will be opened as a URL. Options: -a Opens with the specified application. -b Opens with the specified application bundle identifier. -e Opens with TextEdit. -t Opens with default text editor. -f Reads input from standard input and opens with TextEdit. kevin-mcclellands-computer:~ Kevin$ Have fun!
  15. Awesome link!! I especially like the front page news post about controlling the laptop fan speed..! Especially considering my laptop just burnt me something decent! Unforunatley Hackintosh's are not supported yet, but I'll see if I can find a way around that! I advise everyone to check out osxdaily! Terriffic site! Race Day right now till 2pm pacific, and so I'll cut this short, but after the race I'll post some more tips!