Jump to content

10.5.1 retail DVD with brazilmac patch


4 posts in this topic

Recommended Posts

  • 2 months later...

You do not need a new OSInstall.mpkg, to my knowledge.

I bought a 10.5.1 retail DVD recently, and out of curiosity, tried using the BrazilMac 9a581 patch.


Here's what I did:


I used an Uphuck 10.4.9 installation for the patching. I unzipped the patch files to my Desktop and edited the patch as needed (user name, apdir, dmg). I opened a terminal shell and typed sudo -s and my password, to log in as root. I then opened the patch file in terminal, and it proceeded to patch my leopard 10.5.1 dvd image.


One problem I ran into:

For some odd reason, the patcher would not mount the leopard.iso.cdr from the patch's first step, as Mac OS X Installation DVD. Instead, it mounted as Install. As a result, when the patch tried to rename Mac OS X Installation DVD to OSx86DVD, it of course did not work and every step afterwards failed (Directory not found: /Volumes/OSx86DVD). To get around this, I simply changed a line in the patch.sh file to rename /Volumes/Install to OSx86DVD. This fixed all of my problems right away. The only other error occured at the very last step, updating the prebindings. I thought that this would make the patch fail, but it did not.


I burnt the resulting 4 gb dvd image and booted from it. After 10-15 minutes, it had fully booted and I then installed Leopard.


After, of course the first reboot failed, and I then applied the post patch from my Uphuck 10.4.9 tiger partition. After it patched, I rebooted into Leopard, and was treated to the usual "flying through space" welcome video. Leopard works like a charm now, and About this Mac says Mac OS X 10.5.1.


Right now, I am trying to install pc_efi. We'll see how that goes.


Hope this solves anyone's problems. :)

Link to comment
Share on other sites


  • Create New...