Jump to content

Acer Aspire AM5630-U5209A


12 posts in this topic

Recommended Posts



I decided to try out OS X on the new Acer Aspire AM5630-U5209A (with a q6600 Intel quad cores) just to see if it work. I installed it with Kalyway 1.5.1. At first, the DVD will just get to certain point the restart the machine. I found out that I need to disable the APIC mode in the BIOS. After that it installed fine, everything went smoothly.


How ever, when I reboot, it just stuck at "Using 10485 buffer headers and 4096 cluster IO buffer headers" , the boot just freezes. I have tried all options, -v, -f, -s, -legacy and cpus=1, none of them works. I even tried something I read from another post to remove all FireWire related kext. That didn't work either.


Is there anyone have the same machine?

Link to comment
Share on other sites

I just bought this computer also and I plan on installing the Iatkos version...I am currently downloading it and once I have my results I will let you know. Keep posting here though and let me know if you get the Acer M5360 to work with Kalyway. Did you install this on a clean disk or a partition of the 500 gb drive that came with it?


Also, have you tried this: http://forum.insanelymac.com/index.php?sho...aded&start=

Link to comment
Share on other sites

I have an Acer AM5620 - U5210A. It is also a Core 2 quad Q6600. I could only get a good install by entering cpus=1 to boot the DVD. APIC mode needs to be enabled in BIOS for this.


I installed Kalyway 10.5.1 by installing the SSE2 system/kernel, and MBR EFI boot. My drives are formatted as MBR since I have Windows installed also. After install I need to use cpus=1 to boot the system. You can add this to com.apple.boot.plist after install.


Now I have a fully working system (but only 1 cpu works). Everything else works - sound with Azalia from Kalyway DVD, LAN with 3COM PCI card (the MB Intel 82566DC has no driver yet), all 10 USB ports and QE/CI video with Radeon HD 2600 Pro card.


I tried installing SSE3 kernel and also vanilla kernel, but the result was always a reboot loop. Only SSE2 with cpus=1 works.

Link to comment
Share on other sites

I also purchased the AM5630-U5209A in hopes of installing Leo 10.5.1 with the Kalaway disc. No luck as of yet. I've been pulling my hair out trying to figure out this thing. Kalaway seems to be the only disc that's loading the install for me with the APIC mode disabled in BIOS. Couldn't get either version of the iATKOS versions to load into the installer.


PS. I am also trying to triple boot Vista/XP/OSX. But, I have never been able to load OSX after installing with Kalaway.


I REALLY hope we can get some help and figure this beast out. :-) Hopefully!

Link to comment
Share on other sites

Just got My AM5630 up running Leopard last night. It was actually very simple (once I properly partioned the hard drive). Here is how I got it to work:


I used a secondary Western Digital 250 GB SATA drive for the install (so I wouldn't mess up Vista)


1) Disable ACPI in the BIOS

2) Boot Kalyway Disk by pressing F12 during startup

3) Use Disk Utility to partion the drive as GUID

4) Select "Customize" before the install and select Vanilla Kernel (must select both options), SSE2, and GUID-efi options


After the instal it will reboot (I went ahead and reenabled ACPI at this point)

It will come to the Darwin boot screen and press enter to customize

Type cpus=1 and it should boot up


I have no sound right now and my resolution is stuck at 1024 x 768 but I am going to work on this and I will let you guys know how it goes.

Link to comment
Share on other sites

Wow! So I got leopard up and running as well!


How I got it to work is by selecting the SSE2 option (in addition to the vanilla set, and I chose EFI_MBR (because I am trying to tri-boot with vista and XP)) in the customize section of the initial install. PS, I don't need to use the cpus=1 command to boot this either.


The post that GREATLY helped me out on getting Leopard running as well as getting vista and Leo to atleast (for now) dual boot is: http://forum.insanelymac.com/index.php?showtopic=39253


I had some HFS+ Partition errors and b0 errors when trying to dual-boot initially but after going through that guide, it's all gravy. Now I just need to get this XP partition fixed....


My setup (using all stock hardware that came with this unit, minus the pci-e video card because my pci-e slot never worked) is:


- OnBoard video (only can get 1024x768)

- Stock 500GB SATA drive partitioned into three: 1-Vista (using the recovery CDs), 2-XP, 3-Leo 10.5.1- No audio. (I REALLY WANT THIS TO BE AVAILABLE!!)

- Using vista boot loader for now. If I want to boot into Leo I need to choose os x from the vista boot loader, then when the darwin loader shows I need to hit F8 then choose Leopard. A pain that I will probably solve by just using the darwin boot loader to save the hassle.


I'm REALLY looking forward to getting the friggin' audio working! :-D


-----> naddy69, In this other form post ( http://forum.insanelymac.com/index.php?s=&...st&p=610270 ) You said you got sound to work. Could you explain please how you did this? And, possibly how someone like me who already have Leo up and running to get sound working? Any help to get the audio working on this system would make my night!

Link to comment
Share on other sites

  • 2 weeks later...


Unfortunately, I haven't been able to get this to work because my PCI-E slot is broken (came that way) and won't be able to test this out until I get it fixed. However, I have read about people getting this card to work.




Also, I have 10.5.2 fully (per say) working on my Acer. Sound too!


How did you get 10.5.2? Direct download through OSX? I'm afraid to download it out of fear that it will crash my setup. I still have no sound and my resolution is still stuck.

Link to comment
Share on other sites

There's a tutorial on this site to upgrade to 10.5.2: http://forum.insanelymac.com/index.php?showtopic=87078


The way I got sound to work was by selecting the Azalia kexts in during the customize setup. I tried this because I had to reinstall due to a botched 10.5.2 install.


For the last step in that tutorial, I replaced back the AppleHDA, AppleSMBIOS, AppleACPIPlatform, DSMOS kexts and replaced the ACPI_SMC_PlatformPlugin thats located IN the IOPlatformPluginFamily kext. Then, before rebooting, you call up terminal and restore permissions doing the chown -R 0:0 /path/to/kext/here and the chmod -R 755 /path/to/kext/here. THEN you can reboot. It didn't boot for me at first, I had to boot with -x and repair the permissions i stated above, then i got it to work.


For the system profiler to work again, I had to download the system profiler again and reinstall it using a post on page like 10 of that tutorial.


Hope this helps! I know I never got any direct help from any user on here, I just figured it out by piecing {censored} together.....

Link to comment
Share on other sites


  • Create New...