Jump to content

Restart and Shutdown Problems


7 posts in this topic

Recommended Posts

In addition to my computer waking up with graphics corruption, I cannot shut down or restart the computer by going clicking apple, shutdown or restart. Whenever i do this, it seems as if the computer is going to shutdown, but the screen just turns blank. The only way I actually shut down or restart is by using my front pannel switches. Any thoughts? Thanks





Asus p5b

nvidia 7600


Link to comment
Share on other sites

Sure is ! Here is what fixed it for me.


Download this file: http://rapidshare.com/files/74550142/AppleACPIPlatform.html


Follow the instructions below:


How to fix the Reboot problem in 11 simple Steps.

This is a guide to help you applying the Reboot fix. This Guide is not meant for 'real Macs' but so called 'Hackintoshs'.

1) Download the Reboot fix you need. You can get it from the IRC channel #Leopard or click this link: [[1]].

2) You will have an file called 'AppleACPIPlatform'.

3) Right click this File and pick 'Copy'.

4) Then navigate to /System/Library/Extensions/AppleACPIPlatform.kext using the Finder and right click on 'AppleACPIPlatform.kext', In the context menu pick "copy AppleACPIPlatform.kext", then navigate out to your "Desktop" and then from the Finder menu-bar select 'Edit' and pick 'Paste'..

5) Then navigate to /System/Library/Extensions/AppleACPIPlatform.kext using the Finder and right click on 'AppleACPIPlatform.kext'. In the context menu pick 'Show Package Contents'. A new Finder window should open. Navigate to './Contents/MacOS'. From the Finder menu-bar select 'Edit' and pick 'Paste'.

6) OS X will ask you to authenticate yourself. Choose 'Replace' in the dialogue Box, enter your password and confirm.

7) If everything went right (aka no error message at this point), open 'Terminal' from 'Applications/Utilities'.

8) Type 'sudo -s' and press enter to make yourself a so called 'superuser' (aka more power!). Type your user-password again and confirm.

Congrats, you're superuser now. Be careful, now you can destroy everything as easy as you can repair things.

9) Type: 'chmod -Rv 755 /System/Library/Extensions/AppleACPIPlatform.kext && chown -Rv root:wheel /System/Library/Extensions/AppleACPIPlatform.kext' and press enter.

10) Type 'exit', close Terminal, restart your Computer.

11) At the Darwin Bootloader, press F8, and at the boot prompt, type '-f' to force the system to rebuild the kext cache.


Fixed it for me.

Link to comment
Share on other sites

I tried a AppleACPIPlatform install using kext helper b7. Said kext was supplied to me by a fellow Acer laptop user who said it would work, though he has a Celeron laptop as against my Core 2 Duo. It initially allowed me to boot up without having to type cpus=1 - but still no shutdown. Subsequent boots/reboots always freeze on the spinning cog. My only way in is to type cpus=1 . If I had wanted a single core laptop I would have bought a laptop with a Celeron!

Link to comment
Share on other sites

  • 9 months later...

  • Create New...