Jump to content

My Leopard refuses to boot w/o an installation disk


8 posts in this topic

Recommended Posts

Hello anyone who came in and read my problem.


I'm trying to make my laptop able to dual boot Vista/OS X.

It has one hard drive which I separated into 3 partitions, all primary.

I picked the first one for Vista and the 3rd for OS X.

I installed Vista first then Leopard. Both installation went well, but I was unable to boot up OS X


So I tried manually set the 3rd partition to be the active one, yet it said "HFS+ partition error"

Then I tried fixing this problem by setting the partition type to AF following this guide


I've already done these steps.

fdisk -e /dev/rdisk0

flag 3

setpid 3



Then made the 3rd active again just to be sure. Still HFS+ error was there :)


I can boot it though if I leave the installation disk inside and do not press F8 (just let the timer runs). This way is not very convenient and not possible to make it dual-bootable.


So does anyone know where did I screwed up? Or any suggestion on what else I should try?


Thank you very much for just reading :P

Link to comment
Share on other sites



See if you can find that 200mb download "Format Make Bootable HD for Leopard iso" (google, first link). I have it, but haven't needed to burn it, but it appears to do what all the newer releases do, make your partition bootable. I don't know what it will do to your vista boot, so backup or better, image, your system before you try it.


I had to do the AF thing, and change something to 07, but it never worked right a couple months back, so I ended up doing a quick install of Jas Tiger 10.4.7 or 8, and then installing leopard. The older leopard releases did not make the drive or partition bootable I believe.


PS: What distro are you using, and are you trying MBR, or GUID partitions? MBR seems easier to work with dual booting and non dedicated drives. Are you using EFI/Vanilla installations, or patching things?

Link to comment
Share on other sites

Thanks for answering retro :wacko:


I'm really new to this thing, so I'm not so sure about what you asked.

-Is Kalyway a distro? The name of the image is KALYWAY_LEO_10.5.1intel_SSE2_SSE3_DarKMenTaL-CZ, so I guess it is.

-I tried GUID because it was on default and I didn't know the different -_-

-And I used Vanilla installation

Link to comment
Share on other sites

I'm new to this as well, I call Kalyway's ISOs, distros, not sure if that's the proper term though. I have the same one you have, and only now got it to work (Kalyway 10.5.1). I chose MBR instead of GUID, because the 10 times I tried the GUID version, I couldn't get it to boot. My problem was a setting in bios, yours might be that you don't have a dedicated hard drive, which I think is recommended if you use GUID mode.


Make sure that you erase your drive (or at least your partition), and retry by partitioning it in MBR mode. Then customize the Kalyway install using MBR only, and make sure the EFI setting is set for MBR. Hope that helps!

Link to comment
Share on other sites

u may try this.

make disk 3 partition fist-primary 2-3-extend



1. vista install disk

2. kalyway 10.5.1 when install don't select any driver vga, network, audio except vanila/ EFI

3. gat Gpart iso and burn it! free


Now format C and D then install

1. drive C vista. reboot

before install osx make it boot disk using Gpart program and 2. dirve D install osx


when finish u should get into osx now play with it and install vga audio and network. reboot


for due boot use gpart to change boot disk to drive C (Vista) !!cution if u don't change boot disk to drive C before vista restore u may loss vista.!!


u must change boot disk to drive C using Gpart and then use vista install disk to restore

I think it will work now before u can due boot get easy BCD from net. install it and add osx to due boot screen.


have fun

that what i do with my com

Link to comment
Share on other sites


  • Create New...