Jump to content

Dual booting is not working, 'HFS+ partition error' , 'Try hd(0,0) extended or non-MS: skip'

Jen Zi

4 posts in this topic

Recommended Posts

Actually, I've tried just about everything I could find.


I'll start from the beginning.

One year ago, my boyfriend wanted to try running Tiger on my pc (intel pentium d

 asus pl2p5 motherboard, onboard sound and network, 1024 mb ram, nVidia geforce 


Back then, everything worked except for sound. Well, that was too bad and after 

aving some fun with it, I simply switched back to primarily XP.


A year later, I decided I want Leopard on my pc. Still the same pc, only differe

ce is the harddisk (IDE, now SATA).

I have xp installed on the first partition, some 15 gb or so. I left a second pa

tition empty, about 20 gb. Then there's a third partition, the rest of my hd, where I store all my data.

The second partition is especially for leopard, but the disk utility from the dvd installer was not able to turn it into a proper mac partition (as in, it kept saying FAT32 after an erase, and yes, I selected the topmost one, Mac (journaled) or whatever it says).


We, since my boyfriend has more experience with this type of stuff, eventually found [url = http://wiki.osx86project.org/wiki/index.php/Install_On_A_Partition_Simple_And_Accurate] a Tiger guide[/url] saying we should turn the partition meant for leopard into an 'af' type, and that worked! Leopard runs smoothly and boots so fast it's almost creepy. The only problem is, it'll only boot from CD/DVD. (First pressing F8 for the bios boot selection and then choosing the dvd drive, not pressing any keys after that)


I put the master boot record back. The method mentioned in the guide works and has been working for us for.. well, quite some time XD. It was unconfirmed in the guide so I figured I'd mention it.


Anyway, back to booting.


Leopard's installed on a second primary partition with the EFI option checked at customize. The first primary partition contains Windows XP. The third is a extended partition with 1 logical partition in it.



It works when I boot from the DVD and don't press any keys and the OSX partition is set active. Windows won't boot obviously.


With the windows partition active only windows boots, the DVD just boots to the installer.


We tried the chain0 method. Copied the chain0 file from the dvd to C:\ and edited the boot.ini file to this :

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


disk0s3 is the name the partition had in the Disk Utility. When I chose disk0s3 at boot, it throws me a HFS+ Partition error.


Tried installing Wingrub, ended up with some weird errors like

Try hd(0,0) extended or non-MS:skip

Try hd(0,1) extended or non-MS:skip

Try hd(0,2) extended or non-MS:skip




timeout 10

title Windows at (hd0,0)
root (hd0,0)
chainloader +1

title OSX at (hd0,1)
root (hd0,1)
chainloader +1


While hd(0,0) contains Windows XP? And boot.ini has 'C:\GRLDR="Start Grub"' to load Grub.


I've also tried installing Easybcd, also throws a HFS+ partition error. Windows still boots fine though.


Setting the OSX partition active with no cd gives me b0 error I believe it was.


So yea, pretty much running out of options..



And sorry for the long post. I just wanted to make sure every step we took was clear.


Hi! Nice to meet.. well, whoever reads/reacts to this topic! I'm new, and I absolutely love this project :P



Edit: I forgot to mention that I installed Leopard on my hd wiped clean before, and it ran beautifully. My only problem was my favourite game, so I've tried emulating windows, but this also means emulated hardware. That's not gonna run Guild Wars, so I figured I'd dual boot. Partition Magic didn't even recognise my hd anymore, so I figured that now I know it works, I'll just try again later and wiped it clean again and turned it into what it is now. (all my data was backed up, so losing it is not a problem. Copying it back would take a while though..)

Link to comment
Share on other sites

Couple of questions:


1, Why don't you get a second hard drive and all your headache would be gone. Harddrive are very cheap now. Are you using a laptop?


2, you mac drive should be disk0s2 as it's the second partition. Chain0="disk0s3" would point it to the third partition, which is the data partition.

Link to comment
Share on other sites

1. Because I don't want to spend money needlessly. If it can be done with a partition, it will be done with a partition. Besides, I'm broke at the moment.


2. Alright, I'll try that. Disk Utility from the leopard install dvd always seems to rename it disk0s3, regardless of what name I gave it. I'll post how it went later, I'm at school now so yeah..

Link to comment
Share on other sites

Tried changing it to disk0s2. Even added disk0s1, disk0s3 and disk0s4 to the list. Nothing but xp will boot from harddisk. Oddly enough, disk0s1, which would be xp, is also not booting.


Gonna try installing fedora next to it now, maybe the normal grub will have better luck than this method and wingrub.

Link to comment
Share on other sites


  • Create New...