Jump to content

Iatkos 1.0i - can't install DARWIN_BOOT


4 posts in this topic

Recommended Posts

System specs: P5K Deluxe WiFi, Core2 1.8ghz, 2gb ram, 8600GT

Five Hard Drives: 0=WinXP, 1-3=other, 4=Iatkos (partition 1)


Followed Dual Boot Vista/iatkos guide word-for-word for setting up the partition with fdisk


When I get to the Leopard Install, I erase the first partion of my 5th disk (disk4s1) using Disk Utility and it mounts OK. Also says "bootable yes" in the information window.


I then choose Darwin_Boot, and use disk#5, part#1 - it correctly sees it as disk4s1 (HFS, local, journaled).

I choose EFI, yes, yes I am sure...


Then I get this:


hdiutil: unmount: "s1" failed to unmount due to error 2

hdiutil: unmount failed - No such file or directory

startupfiletool: opendev(s1): No such file or directory

dd: s1: Read-only file system

hdiutil: mountvol failed - No such file or directory


Tried going through and installing leopard anyway. I leave the DVD in and boot to it, but it goes right back to the installer.


Also tried the "option rdisk disk4s1" item at the darwin loader that I saw in a different post, but it still boots to the installer.


...HELP! How can I get this to work? What am I doing wrong?

Link to comment
Share on other sites

  • 2 weeks later...

Well it is actually your 5th drive that you need to install Darwin Bootloader on. Disk 0 does not exist in BSD. So when you are in the terminal doing the Darwin Bootloader type 5 then partition 1, that should work for you.


disk 1 = windows XP

disk 2-4 = other

disk 5 = iATKOS


By the way the bootloader might erase you Windows MBR.

Link to comment
Share on other sites

Actually - yes - the trick for me was to make sure I had the entire drive formatted as HFS+ and making sure the Master Boot Record option was chosen. When you select the drive (not just the partition) and then "Parition," there the Options item. If you can't select that button, then there's another partition on the drive that is not HFS+, and any time that's the case, Darwin_Boot wouldn't work for me.


So if you have a clean drive, choose the drive in Disk Util, choose 1 Partition and make sure that the drive is HFS+ Journaled, hit apply. Then Darwin_Boot will work correctly. When you shoose your drive in Darwin_Boot, it should say something like "/dev/disk2/" and when you choose the partition, it'll be "HFS+ Journaled" etc.


I suppose option #2 is to install Darwin manually, as you have to do with iatkos 1.0r2. No clue how to do that myself though.


Unfortunately - still have 8600GT woes. Can't get QE/QC.

Link to comment
Share on other sites


  • Create New...