Jump to content

ECS G31T-M Boards Trouble

David Anon

6 posts in this topic

Recommended Posts

I have an ECS G31T-M motherboard, the hardware compatability test says that for Tiger, it didn't work no matter what. Well in Leopard it works but only with cpus=1.


I have installed through Kalyway 10.5.1 with boot command cpus=1

it also only worked for me when I used EFI, Vanilla, and the GUID partitioning method.

Although sound has still not worked for this motherboard and I can't find kexts for the soundcard on the ECS G31T-M.


The main problem is that when booting with cpus=1, installing with cpus=1, and then post installation booting with cpus=1, you only get 1 core working. I double-checked this in the system moniter. If anyone has any solution to this problem please post reply. I have done my homework and searched about 200 forum topics, sorry if this was already cleared up, I haven't found it yet.


Also if anyone does have this motherboard, and installed using Kalyway, please post a way to fix the sound. I had to go back to Windows now that school has started but I wish to dual boot using GUID, possibly bootcamp if someone figures that one out. Basically everything else works.


Many problems are fixed with booting through a combination of

-x -v -f and cpus=1

-legacy= doesn't do anything

-vanilla= restarts


Also a personal reply to my e-mail would be much appreciated :)


Link to comment
Share on other sites

  • 5 months later...

Same problem here!


tried leo4allV3, with IDE DVD and SATA HD.

Boot from DVD only with cpus=1

At 1st restart it looped at boot, fixed this by disabling APIC in bios.

Then account creation loop. fixed with


/sbin/fsck -fy

/sbin/mount -uw /



(from http://osx86leo4all.wikidot.com/known-issues)


voilà! Leo boots. (About this Mac saying: 1 core! how can this be? only typed the command at 1st dvd-boot. At least now i know that my intel 6750 really only ran with one core... thanks to david)


My problem now is, i wanted to try other kernels with fresh install, but now i always get stuck at 1st boot. any clues?



just so you know, david, someone's in the same boat...








flashed bios to latest version.

now i can avoid cpus=1 by disabling apic in bios.

still only one core recognized in about-this-mac

Link to comment
Share on other sites

  • 1 month later...
  • 5 weeks later...

  • Create New...