Jump to content

Patcher gets stuck after SPDIF detection


3 posts in this topic

Recommended Posts

Sorry, I never would have thought this card had its own forum so I also posted this in the general SigmaTel thread.


I used PuppyLinux to get the attached dump, which works more than other dumps that I've tried but I'm still not having any success. I have a SigmaTel 9200 (HDAUDIO\FUNC_01&VEN_8384&DEV_7690&SUBSYS_102801C2&REV_1022) and when I throw this dump into the patcher, I get as far as:


Patching AppleHDA.kext to 0x83847690 Done

* Checking AppleHDA for patch Done

0001f4a7 cmpl $0x83847690,%eax

0002058b cmpl $0x83847690,%eax

* Checking for SPDIF Out Detected

* Checking for SPDIF In Not Detected


Using other dumps I've found, it won't even detect SPDIF Out. No matter what, it never progresses past this point.


Any ideas on how to fix this?


Other info:

I'm using Kalyway's Leopard

I've tried just about every recent version of the patcher, from 1.10 on

I'm on a Dell D620

I miss sound :blink:


Link to comment
Share on other sites

  • 9 months later...
This specific issue is resolved: I had to move the codec dump off of my flash drive prior to running the patcher ;)


Thanks for sharing! I'm having the same issue... gonna try your solution now!


edit : yep, that was the problem ;)

Link to comment
Share on other sites


  • Create New...