Jump to content

Ethernet Kernel Panic under iATKOS 1.0


35 posts in this topic

Recommended Posts

Kernel Panics under Uphuck 10.4 and 10.5.1 1.0i releases, Darwin BIOS as well as the new EFI method. D945GCL (C2D GMA950) with an Intel Pro 1000 GT (or MT single-port) ethernet card. Vendor ID 8086, Device ID 1076. JaS 10.4.8 works fine.


The ethernet card works, but the system freezes (10.4.8 kexts) or kernel panics (10.5 kexts) seconds after a browser is used, or Dashboard loads a page. Adium seems to work fine. It could be DNS accessing triggering the panic, or webkit, I can't tell.


Problem is described here on ToH by PolishOX-



Also here on Uphuck 1.3 by DHerrington-



Using the JaS 10.4.8 extensions IONetworkingFamily.kext and/or IOPCIFamily.kext, after repairing permissions and clearing the kextcache, causes a freeze. This happens in Uphuck's 10.4 as well.


I have both installed on different partitions so I can continue to use OS X.4, but I can move extensions around. Perhaps you know what extensions or tricks to try? Perhaps you know of an ideal gigabit ethernet card (9k frames) that has always worked with OSX86. I'd very much appreciate a solution since I'm stuck on an old OSX86, thank you!

Link to comment
Share on other sites

As posted in another forum, I fixed my KP using the 10.4.8 kext by JAS.


Never had another issue since. This NIC is ULTRA FAST in Leopard.


I'm waiting for a more standardized release of Leopard and the scene to unite a bit more.


I feel OSX86 is like LINUX -> the best guys are either retired, working alone, or completely against one another.


The result is a HIGHLY technical and almost tedious process with knowledge bases scattered everywhere with lots of bad information to pick through.


In my case I installed JAS 10.4.8 first (with NO fixes or patches) and then ToH Leopard.

In your case you are increasing the # of possible problems using various discs and abstraction layers like PC EFI and such.


How about posting your system information and I'll do what I can to help you. Stuff like motherboard, chipset, etc.

Link to comment
Share on other sites

Thanks for the reply PolishOX. I really appreciate it since this has held me back for a while.


The D945GCL meant the motherboard, 945 chipset (GMA950 video, Core2Duo).


I have JaS 10.4.8 working with no patches. Trying any Uphuck release so far has the ethernet problem. I've tried 10.5 with and without EFI, and only had the ethernet problem.


My copy of IONetworkingFamily from JaS 10.4.8 is v.1.5.1 and 1.6mb. From Uphuck's iAtkos 1.0 it is v.1.6 and about 120kb smaller. Inside the kext package there are plugin kexts, and I don't know which applies to this card. There's also a 2.4mb version of 1.5.1 with more plugins, which eventually causes a kernel panic but allows web surfing. I am running JaS' right now with no issues, but moving the extension over to the Leopard partition still causes the system to stall when accessing a webpage. Maybe Uphuck uses a different version of another extension that conflicts with this fix, where ToH does not. Maybe using the different plugins while keeping the leopard extension would work.


In case my methodology is incorrect-

1. Move IONetworkingFamily.kext from JaS' system to /System/Library/Extensions/ (replacing the backed-up original)

2. Delete /System/Library/Extensions.mkext and /System/Library/Caches/com.apple.KernelCaches

3. Repair Permissions and restart.


This is the best ethernet card IMHO. It works natively in OS X normally. I'd consider the PT card, which is faster as PCI-E, but there are no reports of it with OSX86 yet. The best I'm getting now in 10.5 is slow internet and a delayed kernel panic with it, so unless there's another fix I may need a replacement.

Link to comment
Share on other sites



I have NEVER heard of this step, ever.


Delete extensions.kext and extensions.mkext, repair permissions, reboot with -f


If this still fails, try going on IRC and asking for JOE75.


I'll try to do more research to help you later tomorrow.

Link to comment
Share on other sites

Yeah, I was looking for Extensions.kextcache, which doesn't exist in this copy of Leopard, so I deleted the kernelcaches that last time. Probably a bad idea, but I was restarting anyway. Tried booting with -f, still got a KP before the safari apple homepage loaded.


There seems to be no extensions.kext

Link to comment
Share on other sites

I found this post by Precision670

"I managed to get an Intel pro 1000 MT server card to work in tiger with the addition of the ID 10268086 to the correct kext, appleintel8254xethernet.kext,

info.plist,so line reads IOPCIPrimaryMatch

0x10008086&0x0000ffff 0x10268086"


Since the card I have is already recognized by Leopard, I don't think this kext edit is necessary (my device ID is different). I tried using the original Leopard IONetworkingFamily.kext with the older JaS AppleIntel8254xethernet.kext plugin, and SystemPreferences is unable to set the speed for the adapter (eg. it's not usable). I didn't get any kernel panics with the card not loaded.

Link to comment
Share on other sites

I have the same issue with iATKOS v1r2 and the Intel8254Ethernet, kernel panic with Safari trying loading start page.


Can you post a pointer to 10.4.8 Jas IONetworkFamily, I can test it so we could compare notes.

Link to comment
Share on other sites

PolishOX, can you post your copy of IONetworkingFamily.kext? My copy KPs on my machine, and there were PPF updates for JaS' DVDs, so we could have different versions. I can post my copy tomorrow if not, neihn; hopefully it'll help. Thanks for posting another confirmation of the issue ;)

Link to comment
Share on other sites

I was going to include the Leopard kext, but oh well. Here's JaS 10.4.8 IONetworkingFamily.kext, along with IOPCI if the former doesn't help. Sorry it's .7z.zip, but the forum wouldn't allow a 7zip file, and I wanted it small. I believe there should be no resource forks to be lost.

Link to comment
Share on other sites

Thanks for the IONetworkFamily form Jas 10.4.8. However, I still have the same kernel panic, when accessing the web pages


BTW, I installed 10.4.11, and it works great. I think I will stay with 10.4.11.


Thanks again.

Link to comment
Share on other sites

I also tried the IONetworkFamily.kext and IOPCI from XxX 10.4.11 with same result (kernel panic). XxX 10.4.11 by itself is working great.


That made me think it not the IONetworkFamily problem, it is something else.

Link to comment
Share on other sites

Hmm, not sure how PolishOX did it then. Thanks for checking that.


I'm looking at getting an SMC tigercard or a Netgear GA311NA. I'll be upgrading the motherboard in a while; maybe I'll find one with decent onboard ethernet that works.


I guess this relates to another thread of mine, on diagnosing KPs. There doesn't seem to be a way in OSX86. From here, we go nowhere? I could do some perebor/bruteforce kext replacements. I guess we'll be kept off 10.5 until it's figured out :-\

Link to comment
Share on other sites

  • 3 weeks later...

I just found more information about it.


I have the Intel Pro 1000 MT adapter, 82541GI chipset. This differs from PolishOX's 82450EM.


The relevant kext should be appleintel8254xethernet.kext . Looking at the different versions, there are changes in info.plist as to timers and maximums, including a RXDelayTimer1000 which is now set to 0 when it used to be 25 like the others.


With all the kext versions, I've confused myself a bit, so I may have to reinstall Leopard to be certain of getting the original kexts. From there I'll try patching the original with different numbers and deviceids, etc.

Link to comment
Share on other sites

More progress has been made.


I changed the default values in the iATKOS ionetworkingfamily's 8254x info.plist to be the way they were in JaS's 10.4.8. That didn't help anything.


I did find that kernel panics can be viewed! In the boot screen, type without the quotes "debug=0x100". Thanks go to KirbySaysHi on these forums!


My kernel panic when using Safari is as follows-

cpu 0 caller 0x001af680 "local apic error\n~@/path /leo_xnu/xnu-1228/osfmk/i386/mp.c:683


No mapping exists for frame pointer

BSD process name corresponding to current thread: Safari. MacOS version 9B18. Kernel 9.1.0 by ToH:xnu-1228.0.2~1


I was of course looking for a specific kext to be listed so that I could do something. I'm guessing this means that this kernel revision is not compatible. If no one has any ideas, I'll post a new thread in a week about motherboard/card replacements.

Link to comment
Share on other sites

I noticed something odd. I'm getting errors about ATSServer repeatedly crashing. I found this about it-



It says that "NOTE2: This fixes issues with hanging browsers. Safari might still crash from time to time, or other reasons. I'm using Camino, Deerpark and Firefox..."


The problem was supposedly fixed, and the fix they recommend doesn't help here (removing otf fonts, input managers, etc). However, opening such a font in Font Book caused Font Book to crash. Someone said that the crash can cause a "cascading effect" where other processes that rely on ATSServer will crash. Watching the kernel panics, I've even seen kernel_task panic with the same error that safari was getting.


mp.c seems pretty important and basic, talking about APIC etc. Maybe it's a dualcore issue?

An old version of mp.c from http://lxr.linux.no/darwin-xnu+792.6.76/osfmk/i386/mp.c

# if (!cpu_datap(slot_num)->cpu_running) {

# DBG("Failed to start CPU %02d\n", slot_num);

# printf("Failed to start CPU %02d, rebooting...\n", slot_num);

# delay(1000000);

Line 683# cpu_shutdown();

# return KERN_SUCCESS;

# } else {

# DBG("Started CPU %02d\n", slot_num);

# printf("Started CPU %02d\n", slot_num);

# return KERN_SUCCESS;


edit: setting cpus=1 when booting seemed to delay the kernel panic. For once the ethernet card was seen as having the cable "plugged in" without manual configuration of 1000baset etc. (what I use in Tiger). Setting it to autoconfiguration actually made webpages load quickly. A minute later the same KP happened, and ATSServer was still dying.


Was anyone getting that ATSServer Died message in console?

Link to comment
Share on other sites

  • 4 weeks later...

i have tried the small tree driver which same to include my mic, device 1010 vendor 8086, but i receive an unsupported device on system log



<string>0x10108086 0x10118086 0x10128086 0x101d8086 0x10268086 0x10278086 0x10288086 0x105e8086 0x105f8086 0x10798086 0x107a8086 0x107b8086 0x107c8086 0x107d8086 0x107e8086 0x10a48086 0x10b58086 0x10b98086</string>
<string>0x000a8086 0x000a1374</string>


the right source of mp.c http://fxr.watson.org/fxr/source/osfmk/i386/mp.c?v=xnu-1228

682				 lapic_dump();
683				 panic("Local APIC error\n");
684				 _lapic_end_of_interrupt();
685				 retval = 1;
686				 break;

Link to comment
Share on other sites

Whoa, someone else posting in my thread? Thanks for more info!


So you're getting the KP on a completely different version of OSX86. That's important, since I thought it might be just an iATKOS 1.0 issue.


I'm still getting that KP. I can't find any compatible replacement ethernet cards, and certainly nothing like the MT, so I've been looking at a new motherboard.


"Local Advanced Programmable Interrupt Controller (LAPIC)" and http://en.wikipedia.org/wiki/Intel_APIC_Architecture

They suggest a feature in linux and freebsd to disable APIC. sysctl in OSX86 10.4.8 does not have an APIC entry, though it does have it under "machdep.cpu.features". APIC can be disabled on some motherboard's bios. Disabling AppleAPIC.kext here causes boot to stop at "devfs_make_node not ready for devices", and still mentions ProcessorApicIDs. Neither setting acpi=off nor Platform=x86pc helps after that.

Link to comment
Share on other sites

Absolutely, thank you. I have my files stored on the OSX86 PC though, and it serves them to other computers around the house. USB is possibly the future of ethernet, combined with motherboard integration, but USB2 isn't fast enough to replace gigabit ethernet.


By BIOS has no entry for APIC, and I cannot find an entry to disable ACPI.

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...

No status, didn't work for me. I replaced the motherboard with one that had built-in ethernet that is known to work.


Sorry. It's a bad solution, but it's the only one I knew would work. I'll no longer be posting any new troubleshooting info on OSX86 and this problem since I've replaced the hardware.

Link to comment
Share on other sites

  • 2 weeks later...

This sucks donkey :P


I have the same problem. Internet/LAN works perfectly for a while and then freezes the OS.


My motherboard has Intel integrated Pro/1000 MT 82540EM - Device ID 8086100e.


Specs in my signature.


It doesn't matter what kind of traffic it is, the system will eventually freeze.

I'm on a fresh install of Kalyway 10.5.1 which I have been updating out of spite all day using files transferred on a pen drive, and it's been doing the freezing all the way up to 10.5.4.


But the {censored}tiest thing is that I already had 10.5.4 running on the same PC, FULLY WORKING with THE SAME on-board LAN, I just wanted to reinstall to see if it would fix a display issue I had. Of course I'm still having the display issue, and now this freezing on network traffic is happening as a bonus with no fix in sight.


I'm ready to...I don't know...scream hard into a pillow or something.

Link to comment
Share on other sites


  • Create New...