Jump to content

Installation problems


4 posts in this topic

Recommended Posts

Hello all ! Happy new year !


I have a problem when i want to install OSX on my PC (Jas 10.4.8 Intel/AMD SSE2/3 ETC....)

The DVD boots, and stops at "Still waiting for root device"


I've searched in many OSX86 forums and i found the solution : have hdd pri master and pri slave dvdrom.

But i can't have this configuration :) ! And i don't have ATA HDD...


I've a SATA hdd but the BIOS can emulate it as a IDE Drive.

The DVD-ROM Drive is ATA.

They can't be on same channel . SATA is "Third Master" and DVDROM "Secondary master" and it's not possible to resolve this.

I can just switch the DVDROM drive on primary master/slave but i've already tried this solution : no result.

I've tried to boot without HDD but no change...



My Config :


CPU : AMD Sempron 3000+ 1.8Ghz

GPU : ATI XPRESS 200G (IGP) - 128Mo


Drives :

Primary : none

Secondary Master : DVDROM

Secondary Slave : DVDROM

Third Master : 200GB HDD



Sorry for my english, i'm french and actually studying english.


Is it possible to install OSX86 with hdd and dvd on different channels ?

Link to comment
Share on other sites

Finally, I've solved this problem by switching the DVDROM drives and makes them primary.


The boot continues, with a lot of messages, a few minor errors...

Finally the Graphical Interface starts, but the keyboard doesn't work (A error message during boot can explain this : "ApplePS2Controller : timed Out on keyboard input")...

... But no importance, i continue with the mouse.

When it's time to convert the FAT32 partition, the hard drive doesn't appear in the disk manager (probably because the HDD isn't on the same channel of the DVDROM drive) and i can't install...


Is there a way to install OSX86 if my hdd is Third Master ? I can't change it...



There's my detailed configuration :


CPU : AMD Sempron 3000+ 1.8Ghz (with SSE2)

GPU : ATI XPRESS 200G Integrated (128MB PCIE)

Motherboard : MSI Orion MS-7168 (µATX)

Ethernet : Realtek RTL8100C(L) 10/100 Mbps

Audio : AC'97 (Realtek ALC655)

Firewire : VIA VT6307 100/200/400 Mbps


DVDROM : Lect/Graveur DVD+R9 Phillips (Primary master)

DVDROM2 : idem + lightscribe (Primary slave)

DD : Seagate Barracuda 7200,8 , 200GB (SATA) (Third master)

Partitionnement : 20Gio FAT32 Empty | 10Gio linux (/) | ~160Gio linux (/home/) | 1Gio linux (swap)

Bootloader GRUB

Link to comment
Share on other sites

There's probably no way you're installing JaS from an IDE optical drive.


I myself tried different combinations, even using my internal IDE drive as an external one via USB.


The only thing that worked was an internal SATA drive.


About the PS2 keyboard... Install using a USB keyboard (borrow one). When installation is done, install a PS2 kext (it's floating around and it should be included in your JaS disk - strange) and then use your old keyboard.


hope i helped

Link to comment
Share on other sites


  • Create New...