Jump to content

The Toshiba Problem


2 posts in this topic

Recommended Posts

Alright after many attempts of what looked like parrallel fixed to my exact hardware... i get failure...

I have Mac OS X Leopard via ToH's install DVD

I have a Toshiba Satellite P105-6004 (i have that number memorized after all the problems i have with it)

here are the spec's via lspci


00:1b.0 Audio device [0403]:[b] Intel Corporation 82801G[/b] (ICH7 Family) High Definition Audio Controller [[b]8086:27d8[/b]] (rev 02)
03:00.0 Network controller [0280]: [b]Intel Corporation PRO/Wireless 3945ABG [/b]Network Connection [[b]8086:4222[/b]] (rev 02)
0a:04.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
0a:04.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
0a:04.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
0a:04.3 Generic system peripheral [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]
0a:08.0 Ethernet controller [0200]: [b]Intel Corporation PRO/100 VE[/b] Network Connection [[b]8086:1092[/b]] (rev 02)
0b:00.0 Ethernet controller [0200]: [b]Atheros[/b] Communications, Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor [[b]168c:0013[/b]] (rev 01)


What i have in bold are the problems. I have editting my info.plist in the AppleAtheros.kext to match my device id's/vender id's and i went through this whole process outlined here... http://forum.insanelymac.com/index.php?sho...theros+wireless buttt i feel like possibly my problem might be my PCI slots. I look in the Profiler says that there are NO PCI cards when my Proxim Gold card is there. I have replaced the NetworkFamily.kext and the OI8022Family.kext with a 10.4.8 update version. I have tried many other tutorials on this site for getting any kind of network connection... none work.


I feel like ive tried everything... all i have in my network settings is a Built-in Ethernet that says its unplugged... even when i plug something in... and Built-in Firewire... also i havent even began to start working on getting my sound to work because honestly its been such a pain in the past to even get it to work in Ubuntu Linux.


Whats the solution?!

Link to comment
Share on other sites

  • 4 months later...

shavex, youre not alone. I am also on the lookout to get my wirless card (AR5213 chipset) going. for the life of me I can't get the card to show in the profiler despite editing the info.plist in AppleAtheros.kext (from 10.4.8). is this chipset is just incompatible??


EDIT: solution at http://forum.insanelymac.com/index.php?s=&...st&p=780131 (thanks to antimony) the card is recognised as airport...

Link to comment
Share on other sites


  • Create New...