Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
__Dragon__

Mac Os X 10.4.11 on a Compaq Evo N610C Laptop

58 posts in this topic

Recommended Posts

i found a good copy of mac osx 10.4.11 that will install on my laptop. this install disc has alot of drivers and extra stuff. with the right drivers you can install this on almost anything. i have it installed on my compaq evo n610c laptop which has a intel p4 m 2.20 ghz cpu, dvd-rom, 512 memory, ati radeon mobility m7 7500 32mb video.

 

Install Disc: XxX OS x86 10.4.11 Intel

 

here is a screenshot of my laptop:

Picture1.png

 

there were a few things i had to get working, video i had to fix to get qe working and the battery indicator. but i still have not got the pcmcia slot working on 10.4.11 but i did get it working on 10.4.7.

Share this post


Link to post
Share on other sites

Hi _Dragon_

 

Im just new here and saw your post. Have you tried to install a leopard on your n610c?

How's the performance of tiger in you lappy?

Im still on the process of downloading the 10.4.11 and im just curious if leopard will work on our rig.

 

Thanks! See yah around! :)

Share this post


Link to post
Share on other sites

i have yet to find a good copy of leopard, but i think if 10.4.11 works on the n610c then it leopard should ( i am just thinking about this) work on it. the performance of tiger is ok, there are a little problems but other then that it runs smooth. oh and make sure you are downloading the XxX version of tiger.

Share this post


Link to post
Share on other sites

Installed the version below on my good ol' Evo N610c it worked ;)

 

XxX OS x86 10.4.11 Intel

 

I tried almost all version of the OS from torrent sites, the only one that worked was JAS 10.4.8 on my Evil. I had been looking for a newer version because Norton and Office 08 did not work with 10.4.8. After installing the above version, i confirm that it will install on an EVO N610c computer. Search for the above file and I am pretty sure it will work on your EVIL N610c computer. I just need to find NIC drivers and on to Leopard!

Share this post


Link to post
Share on other sites

Dear all,

 

i would like to share my experiences. I installed successfully 10.4.6 on the Evo N610c where

 

- Ethernet was : WORKING

- Sound : NOT WORKING

- W-LAN : NOT Working

- W-LAN USB STick : NOT Working

- Resoultion : 1024x768

 

With 10.4.9 JAS

- Ethernat : NOT WORKING

- W-LAN : NOT WORKING

- W-LAN STick : WORKING

- SOUND : WORKING

- Resolution : 1024x768

 

Tonight i will try 10.4.11 to see how far i achieve but search for the RALINK company who provides some NIC drivers.

 

Regards,

KT 12

 

lets get EVO's running.

Share this post


Link to post
Share on other sites

the drivers are on the install disc, you just need to select the one you want. all that is not on there is the pcimcia bus card driver and video. you can find out how to get them to work on insanely mac, i did. it took me about 4 times to find out all the drivers that are need to get sound and everything else working. i am right now using the laptop with 10.4.11 on it. i got it almost all working but core image. i am searching for a fix now for it.

Share this post


Link to post
Share on other sites

I have installed 10.4.11 on my n610c, applied the ATI fixes and now have the QE enabled... but now I still can't play DVDs smoothly (no CI?). Anyone have this working?

 

Also, once the OS is booted up, the fan seems to run continuously. Interested to hear anyone's thoughts on the issue here.

Share this post


Link to post
Share on other sites

don't worry about the fan is you have it connected to the charger. once you disconnect it, it will work normally. the reason why no ci is because the video card is too old to handle the ci system. oh and for the video what program are you using? if you are using the dvd player that comes with mac do not use it. use vlc or mplayer they will work better then dvd player on the mac. i have been trying to find a way to enable ci but no luck, i ended up screwing up my video drivers and had to reinstall mac os x. munkeyboy, i noticed you on your sig you have it saying hp, you are kinda right but the laptop is still known as a compaq.

 

but all in time i will find a way to get ci working if not someone else will. if they can't then we are stuck with just qe. i have noticed when trying to reinstall mac i can not install any other kernel but 8.9.1 which sucks. i am still trying to find a good copy of 10.5 and have yet found a copy that will install without kernel errors.

Share this post


Link to post
Share on other sites

can you give me a link to the ATI fixes and how did you get the powermanger to work ???

Share this post


Link to post
Share on other sites

http://forum.insanelymac.com/index.php?sho...ati+radeon+7500

 

for the power manger i have no clue how i got it working. i was trying to get the pcmcia working and it cam up. i reinstalled mac os x 10.4.11 and now i can not get my own video working and i did it the last time lol. so i need to work on it more to get it all rigth again.

Share this post


Link to post
Share on other sites

worked great but i reistalled to kalaway leopard 10.5.2 and it work great

Share this post


Link to post
Share on other sites

Hi All!

Did I read that you have the built-in W200 wifi working? :hysterical:

Which OS version and what did you use for drivers?

 

Thanks

Share this post


Link to post
Share on other sites

Hi, im new to all this and ill really apreciate some help. i have got a compaq evo n610c ind i have got XxX OS x86 which i have tried to install but keep getting panics so i think in doing something wrong when selecting package during installation on the laptop., i would really appreciate if some 1 coyld tell me what pakages i would need to select at installation to get it up and running. ;)

 

 

Many thanx in advance....

Share this post


Link to post
Share on other sites

I'm fairly green too so I hope my post isn't too confusing.

 

This is more from what I remember. I apologize if I'm a little hazy and maybe someone else can reply with helpful hints or something you/I should do differently on my install.

 

I too get nothing, but panics unless I install:

 

kernel 8.9.1...uncheck the other kernals...thanks Dragon for mentioning this in your post. Ah, maybe this is why p4-M (onlySSE2?):

http://forum.insanelymac.com/index.php?sho...mp;hl=evo+n610c

 

I skipped ATA.USB because I couldn't figure out what to check.

Under GraphicDrivers/ATI I selected callisto3

Under agpgart I selected: AGPart2.2

Under AudioDrivers I selected: ADI1980AC97

Under Network I believe I selected: AppleIntel8255

 

I believe there's other or optional install and I also selected the radeontool.

 

I apologize in that I'm doing this from memory.

 

For the life of me I could never get Quartz Extreme to work. I mainly tried Rogan's package & even tried to manually copy over gl ati radeon files. Spent hours and got a huge headache. I so would buy MAC OS X if there was an official release from Apple. I think of myself as a semi-geek, but that terminal & permissions stuff makes my head swim.

 

You might also be able to load it at the install (I didn't at the time), but this powermanagement tool post (which shows battery) life worked for me.

 

http://forum.insanelymac.com/index.php?showtopic=14912

 

If you're in the bay area Fry's has the Airlink 101 usb mimo xr for $12.99 (least it did last Wednesday) and I randomly bought it because it was cheap. Turns out it works with the manuf. regular drivers on our hackintoshes. Whoo Hooo! I'd suggest changing the icon on the USB wireless utility. Dang, is it ugly compared to regular MAC apps.

 

http://www.insanelymac.com/lofiversion/index.php/t28148.html

 

Overall I've been pretty happy, but again getting QE (did accidentally get OpenGL working for about 10 minutes till I had to re-install) hasn't worked for me so far. Argh.

 

Hope this helps & doesn't make things worse for you.

 

This is random and off topic, but this guy got 2 G of ram in his evo & also installed an internal antennae (I think I'd end up breaking the laptop if I tried that) to replace his mini-pci modem card with a wireless one:

 

http://blogs.ebay.com/dhobbs713/entry/Geek...0QQidZ268242017

 

This is random too, but...

 

I already had Windows XP loaded so to start I personally made a fat32 partion using paragon partion manager software. After you load OS X xxx you should be able to choose between Windows XP & OS X. You can also push f8 for advance options...if you're having problems choosing or you can use something like Acronis boot manager, but I personally have had problems with that software in the past.

Share this post


Link to post
Share on other sites

Hi Retrorandy, thanks for the info you provided now i have got OS X running smoothly, i just wanted to no if there is a wifi available for the evo n610c? :(

Share this post


Link to post
Share on other sites

i got an usb 108mbit/S wlan to work on the n610c so it should work great on your to the pcmied

Share this post


Link to post
Share on other sites

I had QE working under 10.4.9. I have tried several times to do it so under 10.4.11 without any luck...

 

Maybe anybody get this done under 10.4.11???

Share this post


Link to post
Share on other sites

I have been getting alot of messages on this post on how to get it to install on other's hack boxs so i am going to do a tutorial on how to do it. remember not all things will worl right off the bat.

 

retrorandy: thanks for helping, the reason i didn't mention the sse2 is i forgot and didn't realize some people don't know the specs of the laptop.

 

Ok first, i am using the entire hdd that means no dual booting. the first thing you need to do is format the hdd to be journaled.

 

ok here comes the tricky part, selecting the right patches and packages to install on the compaq laptop:

 

you want to have the 10.4.11 update checked because you want to install it.

now go to kernels and kexts. uncheck 8.10.1 and no-EFI, you will not be needing these since you do not have sse3.

extend the kernel option for 8.9.1, you will want to install this kernel so check it for install.

ok this one i recommend, extend Recommendedpatches. once done uncheck the verbosemode (unless you want to wait the 7 seconds, i don't so i uncheck it).

now lets move on to the next section. Optionalkernel/patches, ok this one would be easy. extend it to see the options. under optionalkernels i checked 8.9.1.kernel.uniersal.apr23, under optionalpatches i checked nothing.

now for graphics drivers, since it is an ati radeon mobility 7500 m 32mb i selected to use callisto.b008. for the AGPGart i clected AGPGart.v2.2.

for sound i checked adi1980.ac97.audio

for networking i checked the fallowing:

AtherosAR5004G Wireless Driver

10.4.5.IO8021Family.kext

10.4.3IONetworkingFamily.kext

AppleIntel8255x.kext

 

this is about the end of the tutorial, but there are a few more things. the last option on the custom install for mac os x 10.4.11 is a miscellaneous so you can check what ever you want on it. but this is a warning, the radeontool doesn't for with the video card so don't install it.

 

 

the quarts extreme i have gottin it to work on 10.4.11 but when i did a reinstall i couldn't get it to work but some of you might. but this is what i used to get it to work the first time Tutorial Here

 

for the cardbuss (pcmcia slots) i used this to get it working Tutorial Here

 

well this is as far as i can go. it took me more then a year to get mac installed on my laptop, if this tutorial is hard to understand please ask questions. just a reminder it took me 3 months to get the info on how to get alot of the hardware working on here so just bare with me, i am just a single guy who is into computers. so now i am off to bed because i am sick with the flu and i had time to write this. i hope you people get help from this.

Share this post


Link to post
Share on other sites

I had a heck of a time trying to track down the files for QE on the 7500. Oddly enough I managed to download the 7500 pack from this message thread about an IBM laptop:

http://forum.insanelymac.com/index.php?showtopic=83073

 

The actual download guide/files were from a rapidshare link (which in itself can be a tricky service to try and download things from):

http://rapidshare.de/files/38401034/Guide.zip.html

 

I never got QE going on a 10.4.11 installation because I forgot to check the box and loaded 10.4.10 only. Since I got QE running on 10.4.10 I'm sort of afraid to do another installation in the fear I won't get QE going again. hehe

 

For me the most important part was deleting the Open GL files and replacing them manually with the ones that work from the 7500 drivers folder/pack. Then I went ahead and deleted all of the ATI files and replaced them manually (extracting from Pacifist) with the ones from the pack.

 

Not sure if it's working properly, but I currently have radeontool (attached a screenshot) loaded. I didn't know too much about the Mac OS until I started to get it running on this laptop.

 

This is a no brainer too, but I didn't know "about this mac" was so complete under the apple symbol then clicking "more info" & realizing you can click on "extensions" and "frameworks" to see if open GL loaded. I'm always such a windows guy and finally realized that section in Mac is like the system/hardware part under windows.

 

As far as being retarded about the specs of my own laptop I'll admit to that. I helped a friend upgrade his Ibook G4 1.2Ghz and liked the computer/OS so much I tried to buy one for cheap on Ebay, but boy do they hold their value. I so wasn't going to pay $300 or $400 dollars so I began bidding on cheap P4 laptops. This EvoN610c came up and I read about it's durability for being a business laptop. I bid and didn't think I'd get it, but low & behold I won it for approx. $240. Of course that's when I read about the poor design of the cooling fan being below the laptop and people having major heat issues. As most of you know keep the laptop up on a book or elevated when it's on a table making sure cool air gets in there.

 

I've babbled on enough for a Friday night I need to get back to focusing on cable's TCM's Underground movie. Thanks again Dragon for creating the thread and allowing me to have a pretty cool laptop with the ability to boot both PC & Mac. Seems like the 10.5 distributions need to get a little more mature before I attempt them. Especially, since it looks like it runs better on more memory & hard drive space. Right now I still have a little old 30G split between the 2 OS's. I do find myself sticking to the Mac OS side most of the time because the OS seems to flow that much better & I love the look of it too. I'm amazed at all the little things that do work so well on a hackintosh laptop (love that little volume thing that pops up when you hit the volume up & down buttons in the front...you don't see that in Windows even).

 

This is super random, but I've been kicking around the idea of attemping a third very small partion with BEOSMax which I love & think it's so sad that OS didn't get more attention.

post-22102-1207380563_thumb.jpg

Share this post


Link to post
Share on other sites

retrorandy, when i reinstall and get it all back to normal i will attempt to get qe working again, ci will never work unless you can change the video card on the system. if i get it running i will do another tutorial on how i got it to work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×