Jump to content

Kalyway Leo 10.5.1 Intel Issues out of the box


3 posts in this topic

Recommended Posts

Hi All,


Check my hardware in sig. I just installed Kalyway's latest 10.5.1 intel image and it constantly reboots itself.... I tried all flags including -v -legacy -vanilla -f -x and what not... no luck -s also reboots


I used MBR option as per the guide as I have MBR partition ....


The prev image from Kalyway 10.4.10 worked just right on the same hardware .... I have dual boot Tiger / Leopard (new) , so I can login to Tiger and check the logs if somebody can help and need some information


Thanks in Advance

-Luv2Rip :(

Link to comment
Share on other sites

Hey ALL,


I just fixed the issue for me ... did the following


1. Boot from your DVD again and open terminal when the installation first screen appears.

2. check with "df -k" that your Leo volume appears

3. Open the com.apple.Boot.plist with ,


/Volume/<Leo Vol>/usr/bin/vi /Volume/<Leo Vol>/Library/Preferences/SystemConfiguration/com.apple.Boot.plist


and add "-f -x -legacy" in the Kernel Flags as shown below


	<key>Kernel Flags</key>
	<string>-f -x -legacy</string>


4. Now delete your /Volume/<Leo Vol>/System/Library/Extensions.mkext file

5. copy the file from /System/Library/Extensions.mkext (this is DVD version) in location of step 4

6. From the /Volume/<Leo Vol> directory rename the existing mach_kernel to mach_kernel.BAK and copy the version on the DVD / volume


Just restart your machine and it should work .... once you are all setup, put message to Kalyway for solution with the non-working kernel


Good Luck


Link to comment
Share on other sites

I fixed this for myself by disabling Hyperthreading in my Bios; as soon as I did that it booted all the way through and has been solid for a week now.


What does the above do, exactly? Forgive my ignorance as I'm a MAC Newbie :)



Intel D865GBL -everything on-board

Link to comment
Share on other sites


  • Create New...