Jump to content

Presonus Firebox - Potiental FireWire Problem


7 posts in this topic

Recommended Posts



When I installed Leopard on my system almost everything worked right off the bat but I'm having an issue with my Presonus Firebox that I just can't get figured out. It happens on both Kalyway and iATKOS.


When I go into System Preferences and then Sounds I see it listed as a Recording and a Playback device but when I try to change the volume or do anything with it the light on the front of the firebox just keeps blinking between red (no driver) and blue (driver found).

If I try to play an audio file the system either just locks up or the sound will start but it cuts out like every other second.


I looked on Presonus' site and there isn't any newer driver download that I could find. Supposedly the Firebox works great for most in Leopard.


I'm thinking at this point it may be my firewire card. My motherboard doesn't support FW out of the box so I had to buy an expansion card. The card uses a VIA chipset although I am not really sure which model.


System Specs:


Intel Core 2 Duo

Gigabyte 965P-DS3

1GB PC800

nVidia GeForce 7300

2 WD SATA2 150GB HDD's

Via Firewire Card


I am using PC EFI and running Vanilla.


I know probably not too many people here are using the Firebox so any help that you might be able to provide is greatly appreciated.






EDIT: I also wanted to note that this exact same setup was working fine in Tiger (Jas 10.4.8) and that it is still working fine in Windows right now. Its not a hardware issue.

Link to comment
Share on other sites

  • 1 month later...

ok this may not be your problem, but i had this with my mbox 2 pro (also a firewire device)


i read something about firewire devices booting their firmware each time they're turned on, basedo n hte OS thats loading… may be the cause?


anyway every so often, between vista and OSX, i would just lose sound entirely from the mbox 2 pro - i'd have to re-initialise it by unplugging both the power and firewire cables, and then reconnecting - the device would work fine after that…

Link to comment
Share on other sites

  • 7 months later...

i have the presonus firebox and i lost sync. I had the red light. I'm on 10.5.4 and it was working fine. I replugged the firewire cable to the back of the presonus firebox and i still only had a red light..


The solution was to unplug/replug the cable from the back of the motherboard i/o port. I don't know why that fixes it but it worked

Link to comment
Share on other sites

  • 1 year later...

use a firewire bus thats on TI (texas instrument) chipset


can buy PCI firewire card or motherboard (gigabyte) that uses TI chipsets for their firewire and shouldnt have any issues with this audio interface


red light issue usually related to VIA chipset which some are recognized fine by OSX and work but when you need perfect performance with firewire you need TI

Link to comment
Share on other sites


  • Create New...