Jump to content

Another Graphic issue...


CyberShadow
 Share

3 posts in this topic

Recommended Posts

Hello Everybody,

 

With time and manipulations in the Extensions, I became an warned amateur of Hackintosh ...

I successfully installed the ToH Leopard 10.5.1 for AMD.

In fact my config consists of a mobo MSI K8N Diamond with a Athlon X2 4800 + S939, 4Gb of RAM and ... 2 GeForce 7800 GTX (2 SAME CARD from Leadtek (PX7800GTX MyViVo 256Mb).

SLI is hardware enabled (Bridged cards and shared BUS PCIe 8 +8) and software (in the BIOS and under windows).

Under MacOS, I have edited GeFrorce.kext, NVDANResman.kext and NVDANV40HAL.kext with the value 0x009110de for IOPCIMATCH.

The driver that I use is the latest NVinject 1.0.7 for leopard. The system boot and works great with 1 single card in the slot 1 or 2 of PCIexpress Mobo extension. I’ve 1 screen in DVI on the port1 on the card 1 (Belinea 102035W).

 

So the bad point:

 

Does a charitable soul knows how to boot Leopard WITH 2 cards installed.

I don’t want SLI and also it’s not a problem if the 2nd card with screens above are not recognized ...

 

I just want to be able to use the system normally without removing any kind of hardware Have I to modify other Extensions Files?

 

Thanks for your help because the MAC is great! It would be a shame to drop down because of this (small) problem ...

 

Sorry for my poor English, I’m French…

Link to comment
Share on other sites

You are doing great. I have one 7600GS, but maybe it is applicable to you two cards as well. What you should do is the following:

- Download the Natit edited driver (see wiki for that)

- Copy Natit.kext to the /System/Library/Extentions/ folder (note: the Natit.kext should be directly in this folder not in the /System/Library/Extentions/Natit_edited/ !)

- Insert you device id in GeFrorce.kext, NVDANResman.kext, NVDANV40HAL.kext and Natit.kext

- Reboot

 

If you have done that I am able to have dual screens (mirrored is not supported yet).

 

Please note: This works on a 10.4.8 installation.

Link to comment
Share on other sites

Thank you for your answer ;)

 

This Afternoon I've downloaded an installed directly from Software update the Security update why some people saying that it's safe...

I use the 10.5.1 AMD DVD and I guess I've not EFI. So, at thne next boot, the desktop was always here but when I click for open a software or a menu, the system hang-up... :wacko: I've broke my install :D

 

So, for Natit, i've read on the forum and understanding that is for 2 screens (DvI or VGA) plugged both on the SAME card (Nati Dual 0.2 or Natit Edited). My Problem is the oposite side: i've only ONE screen for 2 cards... :unsure:

 

I will try it anyway but i don't think that will work. At the best, i will have a black screen when the desktop start...

 

I think that the problem come drivers themselves (Resman, Geforce and NV40HAL): they can manage and expect 1 card at boot but when they detects the 2nd, the try to initialize it and the card haven't any screen plugged in so Nvresman is still waiting and that why the black screen accors?

I'm on my problem since 1 week and didn't find any solutions. I become " a desperate hackuser". The only solution if i want use the MAC, is to remove Qe/Ci but keep NVRasman and leave as.

 

But again, thanks for advises. I'll try...

Link to comment
Share on other sites

 Share

×
×
  • Create New...